Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge llvm and freetype fails on fresh install {solved}
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Tue Feb 05, 2013 1:08 am    Post subject: emerge llvm and freetype fails on fresh install {solved} Reply with quote

I did a fresh hardened amd64 full disk encryption install on two identical machines that will forward secondary displays and save backup data.

Almost everything works out of the box, but llvm and freetype fail to emerge when i try to emerge xorg-server and many other programs have them as dependency.

those lines seems to be the problem


3.2.src/Makefile.llvmbuild
for dir in lib/Support lib/TableGen utils lib/VMCore lib tools/llvm-shlib tools/llvm-config tools runtime docs unittests; do \
(make -C $dir all ) || exit 1; \
done
bash: xmalloc: locale.c:73: cannot allocate 2 bytes (2320 bytes allocated)
make: *** [all] Error 2
* ERROR: sys-devel/llvm-3.2 failed (compile phase):
* emake failed

llvm build. full log
http://pastebin.com/h6TdPb6R


FreeType build system -- automatic system detection

The following settings are used:

platform unix

gmake: Nothing to be done for `unix'.
>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-libs/freetype-2.4.11/work/freetype-2.4.11 ...
make -j3
bash: xmalloc: locale.c:73: cannot allocate 2 bytes (2320 bytes allocated)
config.mk:36: /builds/freetype.mk: No such file or directory
config.mk:57: /builds/unix/install.mk: No such file or directory
builds/toplevel.mk:169: /builds/modules.mk: No such file or directory
make: *** No rule to make target `/builds/modules.mk'. Stop.
#[31;01m*#[0m ERROR: media-libs/freetype-2.4.11 failed (compile phase):

freetype full log
http://pastebin.com/XhJfUZG7


Last edited by jpc22 on Mon Feb 25, 2013 3:06 am; edited 3 times in total
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Tue Feb 05, 2013 1:11 am    Post subject: Reply with quote

jpc22,

Just a guess from the error locale.c:73: cannot allocate 2 bytes- did you set your locales :?:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Tue Feb 05, 2013 11:10 pm    Post subject: Reply with quote

yes i did configure locale gen and ran it afterward.. had forgotten the default locale. now i get

bin/sh: xmalloc: make_cmd.c:76: cannot allocate 480bytes (0bytes allocated)


for both llvm and freetype
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Feb 06, 2013 12:22 am    Post subject: Reply with quote

jpc22,

This error is strange in that there's no locale.c in media-libs/freetype and this was the first xmalloc attempt. A grep of the work directory reveals:
Code:
xen freetype-2.4.11 # grep -rn "locale.c" *
builds/unix/libtool:1097:# func_show_eval_locale cmd [fail_exp]
builds/unix/ltmain.sh:669:# func_show_eval_locale cmd [fail_exp]

So I can only guess that that's maybe where the failure emanates :?

Can you wgetpaste or paste back
Code:
emerge --info ='media-libs/freetype-2.4.11'

cat /etc/portage/make.conf

I once had a failure with sys-fs/ntfs3g due to a malformed LINGUAS entry.
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Wed Feb 06, 2013 10:34 pm    Post subject: Reply with quote

emerge --info ='media-libs/freetype-2.4.11'
http://bpaste.net/show/75564/

cat /etc/portage/make.conf
http://bpaste.net/show/75565/

thanks for the wgetpaste trick, saves me the hassle of cp to a usb drive and upload on my laptop.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Feb 06, 2013 11:53 pm    Post subject: Reply with quote

jpc22,

The bad news for you is
Code:
ibtool: link: (cd "/var/tmp/portage/media-libs/freetype-2.4.11/work/freetype-2.4.11/objs/.libs" && rm -f "libfreetype.so.6" && ln -s "libfreetype.so.6.10.0" "libfreetype.so.6")
libtool: link: (cd "/var/tmp/portage/media-libs/freetype-2.4.11/work/freetype-2.4.11/objs/.libs" && rm -f "libfreetype.so" && ln -s "libfreetype.so.6.10.0" "libfreetype.so")
libtool: link: ( cd "/var/tmp/portage/media-libs/freetype-2.4.11/work/freetype-2.4.11/objs/.libs" && rm -f "libfreetype.la" && ln -s "../libfreetype.la" "libfreetype.la" )
>>> Source compiled.


What I did was symlinked make.conf to yours then executed ebuild $(equery w media-libs/freetype) compile and it compiled fine.

http://bpaste.net/show/75584/ shows the USE settings from your make mangled with mine (I'm not running hardened).

Check your python interpreter since most of portage is bash and python scripts.
Code:
stable portage # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.2


Also maybe try python-updater for lack of any brilliant ideas :?
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Thu Feb 07, 2013 1:17 am    Post subject: Reply with quote

same error after python updater. will try reinstalling one of the two pc with a different gentoo disc this weekend.
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Mon Feb 25, 2013 3:07 am    Post subject: Reply with quote

found the problem while looking at bash use flags-

mem-scramble was giving the malloc error.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5721
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Oct 03, 2014 10:09 pm    Post subject: Reply with quote

jpc22 wrote:
found the problem while looking at bash use flags-

mem-scramble was giving the malloc error.


got the same issue during attempted compilation of a new kernel :x

thanks for posting the solution :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum