Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Any e-builds for Mozilla Sync server?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1253
Location: Adelaide/Australia

PostPosted: Thu Mar 22, 2012 12:51 am    Post subject: Any e-builds for Mozilla Sync server? Reply with quote

I am interested in hosting my own Mozilla Sync Server.

http://docs.services.mozilla.com/howtos/run-sync.html

Are there any e-builds out there for this?
_________________
...Lyall
Back to top
View user's profile Send private message
cdstealer
Guru
Guru


Joined: 30 Oct 2005
Posts: 341
Location: Leeds

PostPosted: Thu Mar 22, 2012 1:33 pm    Post subject: Reply with quote

not to my knowledge.. however, I did write a how to :)

http://cdblog.cdstealer.com/?p=408
_________________
# touch cock
touch: cannot touch `cock': Permission denied
Back to top
View user's profile Send private message
stintel
n00b
n00b


Joined: 06 Feb 2013
Posts: 2

PostPosted: Wed Feb 06, 2013 5:21 am    Post subject: Mozilla Sync overlay Reply with quote

Not sure if anyone still needs them, but I just pushed all required ebuilds for Mozilla Sync Server to https://github.com/stintel/mozilla-sync-overlay.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1253
Location: Adelaide/Australia

PostPosted: Wed Feb 06, 2013 11:08 am    Post subject: Reply with quote

That does not show up in my layman overlay.
Is that expected?
_________________
...Lyall
Back to top
View user's profile Send private message
stintel
n00b
n00b


Joined: 06 Feb 2013
Posts: 2

PostPosted: Wed Feb 06, 2013 7:24 pm    Post subject: Reply with quote

Yes, that is expected. To install via layman, add this to "overlays : " in /etc/layman/layman.cfg:
http://www.linux-ipv6.be/mozilla-sync.xml

Don't forget to run "layman -f" before trying to add the overlay again.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1253
Location: Adelaide/Australia

PostPosted: Fri Mar 29, 2013 11:12 am    Post subject: Reply with quote

Went to OwnCloud with the mozilla_sync app instead.

:)
_________________
...Lyall
Back to top
View user's profile Send private message
WendyB
n00b
n00b


Joined: 30 May 2010
Posts: 38
Location: Hilversum, Holland

PostPosted: Wed Apr 10, 2013 5:12 pm    Post subject: Reply with quote

I had a more or less working install using the source code straight from Mozilla. Now I tried the ebuild in the overlay by Stintel which works fine except the server keeps complaining about:

KeyError: "Unknown fully qualified name for the backend: 'services.auth.sql.SQLAuth', or error in the module: cannot import name Column"

When I used the source code I had to manually use the (local) easy_install to install python-Mysql. That's why I suspect that the first part of the error message isn't important, but it's about the missing 'Column'. Using sqlite gives the same error message.

Any suggestions?
_________________
several years playing with (Open)SuSE and since 2009 switched to Gentoo for PC (AMD Phemon X4), Laptop (Asus A55VD) and EasyPC( ARM, VT8500)
Back to top
View user's profile Send private message
Havin_it
Veteran
Veteran


Joined: 17 Jul 2005
Posts: 1076
Location: Edinburgh, UK

PostPosted: Sat Oct 12, 2013 12:37 pm    Post subject: Reply with quote

WendyB wrote:
I had a more or less working install using the source code straight from Mozilla. Now I tried the ebuild in the overlay by Stintel which works fine except the server keeps complaining about:

KeyError: "Unknown fully qualified name for the backend: 'services.auth.sql.SQLAuth', or error in the module: cannot import name Column"

When I used the source code I had to manually use the (local) easy_install to install python-Mysql. That's why I suspect that the first part of the error message isn't important, but it's about the missing 'Column'. Using sqlite gives the same error message.

Any suggestions?


Unless the overlay's code is quite old (Jan 2012!), you may be wrong to overlook the first part: at that time, the SQL auth backend was changed to "services.user.sql.SQLUser" so this is what should be in your config file (bin/sync.conf in the Mozilla distribution).
Code:

#...
[auth]
backend = services.user.sql.SQLUser
sqluri = sqlite:////path/to/your/sync.db
#...


Info here.

On the other hand, I was getting this error with the new backend... ultimately had to completely clean-install the server from Mozilla's repo :(
Back to top
View user's profile Send private message
WendyB
n00b
n00b


Joined: 30 May 2010
Posts: 38
Location: Hilversum, Holland

PostPosted: Tue Jan 14, 2014 6:06 pm    Post subject: Reply with quote

I'm using the ebuilds from the overlay now for quite some time. Working pefectly now.
_________________
several years playing with (Open)SuSE and since 2009 switched to Gentoo for PC (AMD Phemon X4), Laptop (Asus A55VD) and EasyPC( ARM, VT8500)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum