Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
steam undefined symbol: gl*
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
demigod.669
n00b
n00b


Joined: 23 Jan 2013
Posts: 1

PostPosted: Wed Jan 23, 2013 11:49 pm    Post subject: steam undefined symbol: gl* Reply with quote

hey guys I got this when I try to start steam on x86_64

Code:

     12818:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glBlitFramebufferANGLE (fatal)
     12818:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glEGLImageTargetTexture2DOES (fatal)
     12818:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glGetTranslatedShaderSourceANGLE (fatal)
     12818:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glRenderbufferStorageMultisampleANGLE (fatal)
     12818:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glXCopySubBufferMESA (fatal)

I have latest emul-linux* installed and use multilibs
latest nvidia-driver tried downgraded them too.


ty
Back to top
View user's profile Send private message
Letharion
Veteran
Veteran


Joined: 13 Jun 2005
Posts: 1260
Location: Sweden

PostPosted: Thu Jan 24, 2013 10:15 am    Post subject: Re: steam undefined symbol: gl* Reply with quote

Looks like you need to run a
Code:
revdep-rebuild
as a fix and start using
Code:
FEATURES="preserve-libs"
to prevent similar problems in the future.
Back to top
View user's profile Send private message
Tronil
n00b
n00b


Joined: 04 Aug 2004
Posts: 21
Location: Denmark

PostPosted: Sun Feb 03, 2013 8:05 pm    Post subject: Reply with quote

I have the same issue here on a clean install of gentoo (installed from scratch yesterday). Running revdep-rebuild doesn't find anything.

/usr/lib32/libGL.so.1 is symlinked to opengl/nvidia/lib/libGL.so.313.18, so it could be related to the nvidia driver...
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 426

PostPosted: Sun Feb 03, 2013 8:32 pm    Post subject: Reply with quote

Steam is 32bit and needs a 32bit gl driver. I have no idea how nvidias driver handles that though.
_________________
MB: Biostar TForce 6100 AM2 @ 250x10
CPU: AMD Athlon 64 3800+ X2 @ 2500mhz
MEM: G. Skill DDR2-800 2GB @ DDR2-1000
GPU: nVidia GeForce 7600 GT
OS: Gentoo Linux 2006.1
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 372

PostPosted: Mon Feb 04, 2013 10:34 am    Post subject: Reply with quote

Just a "me too" here. I'm using the 20121202 emul-linux-x86 on Intel graphics (GM4500). Steam used to work, but broke at some point and has been liked this for a while now. It segfaults due to missing symbols.

Code:
/home/user/.steam/ubuntu12_32/steam: error: symbol lookup error: undefined symbol: gtk_widget_device_is_shadowed (fatal)

Code:
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glBlitFramebufferEXT (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glBlitFramebufferANGLE (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glGetQueryObjecti64v (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glGetQueryObjectui64v (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glGetTranslatedShaderSourceANGLE (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glQueryCounter (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glRenderbufferStorageMultisampleANGLE (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glTexStorage2DEXT (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glGenFencesNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glDeleteFencesNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glSetFenceNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glTestFenceNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glFinishFenceNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glIsFenceNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glGetFenceivNV (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glXCopySubBufferMESA (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glXBindTexImageEXT (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glXReleaseTexImageEXT (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glXSwapIntervalEXT (fatal)
      9010:     /usr/lib32/libGL.so.1: error: symbol lookup error: undefined symbol: glXCreateContextAttribsARB (fatal)
Back to top
View user's profile Send private message
Tronil
n00b
n00b


Joined: 04 Aug 2004
Posts: 21
Location: Denmark

PostPosted: Mon Feb 04, 2013 5:24 pm    Post subject: Reply with quote

Just tried installing steam on my ubuntu 12.04 based laptop, and I still get the same errors:
Code:

      5301:   /usr/lib32/nvidia-current-updates/libGL.so.1: error: symbol lookup error: undefined symbol: glBlitFramebufferANGLE (fatal)
      5301:   /usr/lib32/nvidia-current-updates/libGL.so.1: error: symbol lookup error: undefined symbol: glEGLImageTargetTexture2DOES (fatal)
      5301:   /usr/lib32/nvidia-current-updates/libGL.so.1: error: symbol lookup error: undefined symbol: glGetTranslatedShaderSourceANGLE (fatal)
      5301:   /usr/lib32/nvidia-current-updates/libGL.so.1: error: symbol lookup error: undefined symbol: glRenderbufferStorageMultisampleANGLE (fatal)
      5301:   /usr/lib32/nvidia-current-updates/libGL.so.1: error: symbol lookup error: undefined symbol: glXCopySubBufferMESA (fatal)


However, it then carries on happily without any problems. So the segmentation fault is probably not related to these errors at all.
Back to top
View user's profile Send private message
Tronil
n00b
n00b


Joined: 04 Aug 2004
Posts: 21
Location: Denmark

PostPosted: Sat Feb 09, 2013 10:40 am    Post subject: Reply with quote

The last steam update fixed the segmentation fault for me - looks like it was related to some localisation problem:
https://github.com/ValveSoftware/steam-for-linux/issues/142
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 372

PostPosted: Sat Feb 09, 2013 10:42 am    Post subject: Reply with quote

Same here. It's fixed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum