Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Forums very often unreachable
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback
View previous topic :: View next topic  
Author Message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Sat Feb 02, 2013 2:50 pm    Post subject: [SOLVED] Forums very often unreachable Reply with quote

Hi,

For the most part of the day, when trying to access the forums, my browser (Google Chrome) gives the following error message:
Code:
Error 137 (net::ERR_NAME_RESOLUTION_FAILED): Unknown error

This has been going on for the past week or so.

Is anyone else having trouble reaching the forums, or is this just me?

(I'm even having trouble posting this message due to this issue... Other sites are 100% fine, by the way, so AFAICT the problem is not on my end.)

EDIT: Solved by adding the following entry in my hosts file and accepting that my ISP's DNS servers are crap:
Code:
204.187.15.12 forums.gentoo.org

(DNS caching is not feasible for me because I also use the hosts file to block ads.)


Last edited by Aquous on Wed Feb 06, 2013 9:44 am; edited 1 time in total
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7840
Location: Somewhere over Atlanta, Georgia

PostPosted: Sat Feb 02, 2013 2:54 pm    Post subject: Reply with quote

I'm not currently seeing any connectivity issues.

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Sat Feb 02, 2013 3:40 pm    Post subject: Reply with quote

From my home network (which is generally not very reliable and therefore not that meaningful) and from network at work I can connect to the forums but loading any page is mostly very slow although google/youtube etc are not slow, and if I post something I have to wait up to 30 seconds until I receive the affirmation that my post was entered.
_________________
"I want to see gamma rays! I want to hear X-rays! Do you see the absurdity of what I am? I can't even express these things properly because I have to conceptualize complex ideas in this stupid limiting spoken language!"
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Sun Feb 03, 2013 10:46 am    Post subject: Reply with quote

Guess the problem is on my end then :(
The problem is that only for forums.gentoo.org, about 80% of the times I try I can't resolve the DNS. Pinging doesn't work either. Any other site works fine, including other *.gentoo.org sites.

I'm gonna try mucking around in the router settings a bit. This is going to be a ***** to debug... :P
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 5:07 pm    Post subject: Reply with quote

Before you go screwing around with your router, read this.

I recently discovered that, often, the DNS servers provided by my ISP have no record of gentoo.org. Why that is I can't tell you, but I confirmed it by manually doing nameserver queries over the course of several days.

I found this out because I suddenly started having name resolution errors when trying to connect to the forums. What was actually happening was that my alternate DNS servers (opendns and googledns, which I specify in my dhcp client configuration be appended to those named by my ISP's dhcp server) were no longer present in my resolv.conf. This in turn was happening because my dhcp client wasn't actually being invoked, and a default (i.e., unconfigured) udhcp instance was being used instead. That, in turn, was caused by either:

a) the default busybox configuration changing to include udhcp; or

b) openrc changing to prefer udhcp over dhclient if no module is specified in /etc/conf.d/net

To fix this in my case I simply added a modules entry to my /etc/conf.d/net file, which cased my configured dhcp client to be used, which resulted in my alternate dns servers being added to my resolv.conf (actually, they were added to the resolv.conf file used by my local caching nameserver), which resulted in not having any problems connecting to gentoo.org URLs.

So, I suggest trying a manual 'dnslookup gentoo.org <ip address of your dns server>' to test if your dns server actually has gentoo.org records or not. And, if you're finding that gentoo.org address is not available (occasionally, frequently, always), a work-around would be to add some other dns server (preferably operated by a different organization) to your list of dns servers.

If this is a widespread problem, maybe one of the admins should look into it and ask gentoo's domain name registrar or hosting provider what's going on.
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.


Last edited by Bones McCracker on Sun Feb 03, 2013 5:18 pm; edited 2 times in total
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sun Feb 03, 2013 5:14 pm    Post subject: Reply with quote

as root add to the bottom of /etc/hosts

89.16.167.134 gentoo.org

static gentoo resolve, dont pester your dns server then. :twisted:
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 5:20 pm    Post subject: Reply with quote

666threesixes666 wrote:
as root add to the bottom of /etc/hosts

89.16.167.134 gentoo.org

static gentoo resolve, dont pester your dns server then. :twisted:

Is that the address for all <foo>.gentoo.org services? Is it always going to be correct and never change?
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sun Feb 03, 2013 6:44 pm    Post subject: Reply with quote

im not sure if thats functioning correctly.... so i fixed up a far superior solution... in a 1-2-3-4-5 BAM format...

https://wiki.gentoo.org/wiki/BIND#Easy_Caching_DNS

this will cache <foo>.gentoo.org locally

instead of hitting googles dns 150,000,000 times a day, bind will pull it once or twice, then u hit bind 150,000,000 times a day... same deal for foo.gentoo.org
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666


Last edited by 666threesixes666 on Sun Feb 03, 2013 6:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 6:52 pm    Post subject: Reply with quote

Not if there's no record for the URL on your upstream dns server to begin with, it won't. :lol:
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sun Feb 03, 2013 7:00 pm    Post subject: Reply with quote

it uses 8.8.8.8 and usurps power from your upstream dns server, unless you add it to the bind configs.... bind uses 8.8.8.8 or 8.8.4.4... googles dns's you could skip bind entirely and throw your dns out the window and use 8.8.8.8 & 8.8.4.4 instead. this actually resolved some issues that were on my back boiler.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Sun Feb 03, 2013 7:05 pm    Post subject: Reply with quote

The stuff posted here seems quite advanced, so I'll need some time to do the necessary reading, but I can say this:

666threesixes666 wrote:
as root add to the bottom of /etc/hosts

89.16.167.134 gentoo.org

static gentoo resolve, dont pester your dns server then. :twisted:

shouldn't that be 204.187.15.12?
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sun Feb 03, 2013 7:10 pm    Post subject: Reply with quote

204.187.15.12 forums.gentoo.org

though im not sure it will work correctly.... instead
Code:

sudo mv /etc/resolv.conf /etc/resolv.conf.backup



and
Code:

sudo nano /etc/resolv.conf


then have it say just
Code:

nameserver 8.8.8.8


to test googles dns and see if its any better than your internet services.

if googles no better then to revert back

Code:

sudo mv /etc/resolv.conf.backup /etc/resolv.conf

_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 7:20 pm    Post subject: Reply with quote

666threesixes666 wrote:
it uses 8.8.8.8 and usurps power from your upstream dns server, unless you add it to the bind configs.... bind uses 8.8.8.8 or 8.8.4.4... googles dns's you could skip bind entirely and throw your dns out the window and use 8.8.8.8 & 8.8.4.4 instead. this actually resolved some issues that were on my back boiler.

The downside to using googledns or opendns is that the round-trip-time (RTT) is probably about twice the RTT is for a query to the DNS server provided by your ISP.
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 7:22 pm    Post subject: Reply with quote

666threesixes666 wrote:
204.187.15.12 forums.gentoo.org

though im not sure it will work correctly.... instead
Code:

sudo mv /etc/resolv.conf /etc/resolv.conf.backup



and
Code:

sudo nano /etc/resolv.conf


then have it say just
Code:

nameserver 8.8.8.8


to test googles dns and see if its any better than your internet services.

if googles no better then to revert back

Code:

sudo mv /etc/resolv.conf.backup /etc/resolv.conf

That's fine, except resolv.conf gets dynamically generated by various products, including openrc, dhcp clients, openresolv, etc.. So, any direct edits you make there are likely to vanish pretty quickly (like as soon as you reboot). I believe you can add such an entry to your /etc/conf.d/net file. I do it in my dhcp configuration file.
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sun Feb 03, 2013 7:35 pm    Post subject: Reply with quote

yup i tested reboot and realized that i edited a file thats dynamically generated, and didnt know if networkmanager was doing it or not because i have manual dns and manual ip.

mkultra@mksrv [ ~ ]$ cat /etc/conf.d/net
#Generated by NetworkManager


8.8.8.8 will resolve gentoo and the forums, idk id take function over speed.

aparently deleting resolv.conf will default to localhost resolution. thx for pointing @ /etc/conf.d/net

im gonna work on the wiki bind stuff
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 8:21 pm    Post subject: Reply with quote

You might want to look into dnsmasq and openresolv.
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sun Feb 03, 2013 8:29 pm    Post subject: Reply with quote

your the one with the resolv problems to forums.gentoo.org or gentoo.org

Code:

mkultra@mksrv [ ~ ]$ dig forums.gentoo.org
;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun Feb  3 15:26:24 2013


Code:

mkultra@mksrv [ ~ ]$ dig gentoo.org
;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun Feb  3 15:28:08 2013


i use dnsmasq on my openwrt router, its much easier than bind.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Sun Feb 03, 2013 8:49 pm    Post subject: Reply with quote

:?
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
Aquous
l33t
l33t


Joined: 08 Jan 2011
Posts: 646

PostPosted: Mon Feb 04, 2013 2:33 pm    Post subject: Reply with quote

OK, I tried screwing around with my router settings and came up empty. bind/dnsmasq were too complicated for me, and also don't exist for Windows/Android AFAIK, which I both use, so I just added an entry to my hosts files and the site works just fine now :)
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Mon Feb 04, 2013 3:22 pm    Post subject: Reply with quote

for windows
http://www.reaper-x.com/2008/07/10/set-up-caching-nameserver-on-windows-using-bind/

for android
http://forum.xda-developers.com/showthread.php?t=627118

to see and find more for your self....

google (android or windows or linux or osx or your router model) caching name server

searching "windows caching nameserver" & "android caching nameserver" on google found those links posted (sorry if im not supposed to link external sites here)

please post your host entry to confirm what host entry works, then edit post no.1 of the thread and add "solved" to the title
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
derk
Apprentice
Apprentice


Joined: 10 Mar 2003
Posts: 277
Location: St Thomas Ontario

PostPosted: Tue Feb 05, 2013 1:37 am    Post subject: Reply with quote

you can use

/etc/resolv.conf.head and /etc/resolv.conf.tail to add dns info namerserver info and search domains etc permenantly to your resolv.conf file under openrc with any dhcp service I believe .. I know it works with dhcpcd
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1567
Location: U.S.A.

PostPosted: Tue Feb 05, 2013 1:59 am    Post subject: Reply with quote

derk wrote:
you can use

/etc/resolv.conf.head and /etc/resolv.conf.tail to add dns info namerserver info and search domains etc permenantly to your resolv.conf file under openrc with any dhcp service I believe .. I know it works with dhcpcd

Yes. Openrc provides a couple of ways of managing this. Some dhcp clients do as well. I would consider adding a static /etc/hosts entry for some website to be a solution of last resort.
_________________
pjp wrote:
I didn't misquote you, I just misunderstood you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Forums Feedback All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum