Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GELÖST] weis nicht mehr weiter: umts stick -> kein /dev/..
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Marco_H
n00b
n00b


Joined: 02 Feb 2013
Posts: 5

PostPosted: Sat Feb 02, 2013 6:37 pm    Post subject: [GELÖST] weis nicht mehr weiter: umts stick -> kein /dev/ Reply with quote

Hi!

Habe vor vielen Jahren schonmal mit Gentoo Linux gearbeitet, aber nur im Server bereich. Da ich jetzt auch für den Desktop Linux einsetzen möchte bin ich hier gelandet.

Gentoo: Aktuelles Stage3 vom 31.01.13 (ebenso aktuelles portage) und Kernel 3.6.11 (nicht genkernel)

Nach endlosem Handbücher lesen und Googeln (außerdem 2x 2 stück ibuprofen 800) läuft jetzt soweit alles zu meiner zufriedenheit ;)

Nur meinen UMTS Stick (XS STICK p14) kann ich nicht dazu überreden seinen dienst zu verrichten!

Was ich bisher getan habe:

usb_modeswitch, ppp installiert und alle Kernel module aktiviert

Ausgabe von lsusb:

Code:

Bus 001 Device 006: ID 1c9e:9605 OMEGA TECHNOLOGY


von dmesg:

Code:

[ 4156.924420] usb-storage 1-1.1:1.4: usb_probe_interface
[ 4156.924425] usb-storage 1-1.1:1.4: usb_probe_interface - got id
[ 4156.924566] scsi10 : usb-storage 1-1.1:1.4
[ 4156.924631] hub 1-1:1.0: state 7 ports 6 chg 0000 evt 0002
[ 4157.925350] scsi 10:0:0:0: Direct-Access     USBModem Disk             2.31 PQ: 0 ANSI: 2
[ 4157.925641] sd 10:0:0:0: Attached scsi generic sg3 type 0
[ 4157.932130] sd 10:0:0:0: [sdc] Attached SCSI removable disk


Laut lsusb müsste sich der Stick schon im Modem "modus" befinden. Zumindest wenn man Google trauen kann. Aber warum wird dann kein /dev/ttyUSB0 erstellt?

Auch ein:

Code:

modprobe usbserial vendor=0x1c9e product=0x9605


brachte mich nicht weiter.

Die Ausgabe von usb_modeswitch -c

Code:

usb_modeswitch -c /etc/usb_modeswitch.conf -v 0x1c9e -p 0x9605
Looking for default devices ...
   found matching product ID
   adding device
 Found device in default mode, class or configuration (1)
Accessing device 008 on bus 001 ...
Getting the current device configuration ...
 OK, got current device configuration (1)
Using interface number 0
Using endpoints 0x01 (out) and 0x81 (in)
Not a storage device, skipping SCSI inquiry

USB description data (for identification)
-------------------------
Manufacturer: USB Modem
     Product: USB Modem
  Serial No.: 1234567890ABCDEF
-------------------------
Warning: no switching method given.
-> Run lsusb to note any changes. Bye.


Evtl fällt ja euch noch was ein.

Grüße

Marco

//EDIT

meine Kernel config: http://pastebin.com/q0dFPPMG


Last edited by Marco_H on Mon Feb 04, 2013 11:24 am; edited 1 time in total
Back to top
View user's profile Send private message
Marco_H
n00b
n00b


Joined: 02 Feb 2013
Posts: 5

PostPosted: Mon Feb 04, 2013 11:23 am    Post subject: Reply with quote

Nach weitere versuchen und viel Kaffee + Kopfschmerzen habe ich die Lösung zusammen mit Google selbst gefunden!

Aus welchem grund auch immer wurde bei mir kein /dev/ttyUSB0 erstellt. Daher musste ich das selbst erledigen:

Code:

modprobe option
echo "1c9e 9605" | tee /sys/bus/usb-serial/drivers/option1/new_id


So wurden bei mir /dev/ttyUSB0 bis 3 erstellt und ttyUSB3 war mein 4G stick

Dann noch die Konfiguration von wvdial:

Code:

[Dialer Defaults]
Phone = *99#
Username = gprs
Password = eplus
Stupid Mode = on
Dial Command = ATDT
Modem Type = USB Modem
Modem = /dev/ttyUSB3
Init1 = ATZ

[Dialer umts]
Carrier Check = off
Init2= AT+CGDCONT?
Init3= AT+CGDCONT=1,"IP","internet.eplus.de"
ISDN = off


Das ist übrigens eine funktionierende Konf. für Aldi Talk ;)

und danach ein:

Code:

wvdial -C /etc/wvdial.conf


Und schon war ich online!

Grüße Marco
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1075
Location: Buchholz/GER

PostPosted: Mon Feb 04, 2013 1:34 pm    Post subject: Reply with quote

Hmm .. auf den ersten Teil Deiner Problemlösung muss man erstmal kommen. ;)

Vielen Dank dafür, dass Du die Problemlösung hier nochmal veröffentlicht hast. Das dürfte dem einen oder anderen sicher weiterhelfen.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Marco_H
n00b
n00b


Joined: 02 Feb 2013
Posts: 5

PostPosted: Mon Feb 04, 2013 3:19 pm    Post subject: Reply with quote

Hi!

Ja, wenn das mal jeder so machen würde. Sehe leider viel zu oft Threads in Foren mit dem schönen letzten Eintrag:

"kann geschlossen werden, habe die lösung gefunden"

toll....

Grüße Marco
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum