Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Python-Error [workaround]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
SpiderPigLoki
n00b
n00b


Joined: 22 Aug 2008
Posts: 52

PostPosted: Fri Jul 29, 2011 11:57 am    Post subject: Python-Error [workaround] Reply with quote

Hi Forum,
whenever I want to emerge a KDE-Prog portage gives me this (I think Python-related) error.
Quote:

emerge -va kmail

These are the packages that would be merged, in order:

Calculating dependencies ... done!
Traceback (most recent call last):
File "/usr/bin/emerge", line 43, in <module>
retval = emerge_main()
File "/usr/lib64/portage/pym/_emerge/main.py", line 1907, in emerge_main
myopts, myaction, myfiles, spinner)
File "/usr/lib64/portage/pym/_emerge/actions.py", line 302, in action_build
mydepgraph.display_problems()
File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 5998, in display_problems
self._display_problems()
File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 6019, in _display_problems
self._show_slot_collision_notice()
File "/usr/lib64/portage/pym/_emerge/depgraph.py", line 702, in _show_slot_collision_notice
self._dynamic_config._slot_conflict_handler = slot_conflict_handler(self)
File "/usr/lib64/portage/pym/_emerge/resolver/slot_collision.py", line 129, in __init__
self._prepare_conflict_msg_and_check_for_specificity()
File "/usr/lib64/portage/pym/_emerge/resolver/slot_collision.py", line 346, in _prepare_conflict_msg_and_check_for_specificity
if use in violated_atom.use.enabled.union(violated_atom.use.disabled):
AttributeError: 'NoneType' object has no attribute 'enabled'


However something like "emerge -eva system" works well

Quote:

Portage 2.1.10.3 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-x86_64-Intel-R-_Core-TM-_i3-2310M_CPU_@_2.10GHz-with-gentoo-2.0.3
Timestamp of tree: Fri, 29 Jul 2011 10:00:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.1-r1, 3.1.3-r1
dev-util/ccache: 2.4-r9
dev-util/cmake: 2.8.4-r1
dev-util/pkgconfig: 0.26
sys-apps/baselayout: 2.0.3
sys-apps/openrc: 0.8.3-r1
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.20.1-r1
sys-devel/gcc: 4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool: 2.2.10
sys-devel/make: 3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc: 2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs candy distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X a52 aac acl alsa amd64 bash-completion berkdb bzip2 cli consolekit cracklib crypt cups cxx dbus dhcp dhcpcd dri dynamic fam fortran gdbm gif iconv id3tag ios ipod ipv6 java javascript jpeg libnotify mem-scramble mmx modules mp3 mpeg mudflap multilib multislot ncurses nls nptl nptlonly offensive ogg opengl openmp pam pcre perl pm-utils png policykit pppd python readline resolvconf session sse sse2 sse4 sse4_1 ssl ssse3 startup-notification svg symlink sysfs syslog taglib tcpd thinkpad truetype twolame udev unicode v4l v4l2 vim-syntax vorbis wifi wimax xinerama xorg xosd xrandr xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


I Already used the Guide to update from Python2.6 to 2.7 and it ran without any error.

Seems very KDE-realated
Code:
 USE="kde" emerge -vauND world = fails with above error
USE="-kde" emerge -vauND world = success


EDIT:

So, I changed my Profile to "Desktop/KDE" (No. 4) and now I got the emerge-process running...
Back to top
View user's profile Send private message
goober07
n00b
n00b


Joined: 02 Aug 2011
Posts: 2

PostPosted: Tue Aug 02, 2011 4:19 pm    Post subject: Reply with quote

Hi SpiderPig,

I have the same exact issue and I saw that you solved it. Can you elaborate your solution? You said you added KDE/Desktop to your profile. Is this /etc/profile.env? Would you mind listing the exact commands?

Thank you in advance.
Back to top
View user's profile Send private message
SpiderPigLoki
n00b
n00b


Joined: 22 Aug 2008
Posts: 52

PostPosted: Tue Aug 02, 2011 4:50 pm    Post subject: Reply with quote

Sure thing goober07.

1. Select the Profile we need
Code:

TPX spiderpigloki # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/10.0
  [2]   default/linux/amd64/10.0/desktop *
  [3]   default/linux/amd64/10.0/desktop/gnome
  [4]   default/linux/amd64/10.0/desktop/kde
  [5]   default/linux/amd64/10.0/developer
  [6]   default/linux/amd64/10.0/no-multilib
  [7]   default/linux/amd64/10.0/server
  [8]   hardened/linux/amd64
  [9]   hardened/linux/amd64/selinux
  [10]  hardened/linux/amd64/no-multilib
  [11]  hardened/linux/amd64/no-multilib/selinux
  [12]  selinux/2007.0/amd64
  [13]  selinux/2007.0/amd64/hardened
  [14]  selinux/v2refpolicy/amd64
  [15]  selinux/v2refpolicy/amd64/desktop
  [16]  selinux/v2refpolicy/amd64/developer
  [17]  selinux/v2refpolicy/amd64/hardened
  [18]  selinux/v2refpolicy/amd64/server
TPX spiderpigloki # eselect profile set 4

2. Install the stuff
Code:
emerge KDE-foo

(3. Change back to the normal Profile, if wanted)
Code:
eselect profile set 4


I changed back the Profile, because it sets USE-Flags, that I don't need (at least thats what I think ;))

Hope this helps

Greetz - SPL
Back to top
View user's profile Send private message
goober07
n00b
n00b


Joined: 02 Aug 2011
Posts: 2

PostPosted: Tue Aug 02, 2011 5:50 pm    Post subject: Reply with quote

Yes! I don't get those errors anymore! Thank you SpiderPig for your help!
Back to top
View user's profile Send private message
SpiderPigLoki
n00b
n00b


Joined: 22 Aug 2008
Posts: 52

PostPosted: Tue Aug 02, 2011 7:12 pm    Post subject: Reply with quote

Great - Always happy to help :)
Back to top
View user's profile Send private message
vlynd
n00b
n00b


Joined: 23 Jan 2012
Posts: 50

PostPosted: Fri Feb 01, 2013 11:14 pm    Post subject: Reply with quote

Okay, this thread is quite old, but I encountered the same problem and SpiderPigLoki's solution didn't work for me.

eselect python list told me I was using python 3.2, after I switched to python 2.7, and run python-updater, everything worked for me.
Back to top
View user's profile Send private message
SpiderPigLoki
n00b
n00b


Joined: 22 Aug 2008
Posts: 52

PostPosted: Sat Feb 02, 2013 11:05 am    Post subject: Reply with quote

LOL almost a week ago I switched back to Gentoo (yes yes I sined the Ubuntu-Way) and I also came t realise, how important python-updater is....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum