Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iwlwifi cannot load fw
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
weejus
n00b
n00b


Joined: 01 Feb 2013
Posts: 1

PostPosted: Fri Feb 01, 2013 3:40 pm    Post subject: iwlwifi cannot load fw Reply with quote

I've been working on installing gentoo on my thinkpad W520, but ran into a problem with getting my wifi to work. I'm using a non-genkernel 3.6.11 kernel which I made sure to configure to include iwlwifi as a module and enable userspace firmware loading support. Since my card is an Intel Centrino Advanced-N 6205, I downloaded the 6000g2a tarball and put the microcode in /lib/firmware. The modules load, but wlan0 doesn't show up. When I run dmesg | grep iwlwifi I get this:


[ 13.570227] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[ 13.570231] iwlwifi 0000:03:00.0: pci_resource_base = ffffc9000627c000
[ 13.570234] iwlwifi 0000:03:00.0: HW Revision ID = 0x34
[ 13.570905] iwlwifi 0000:03:00.0: irq 53 for MSI/MSI-X
[ 13.571099] iwlwifi 0000:03:00.0: Couldn't request the fw
[ 13.571289] iwlwifi: probe of 0000:03:00.0 failed with error -14

Anyone know what could be causing this?
Back to top
View user's profile Send private message
derk
Apprentice
Apprentice


Joined: 10 Mar 2003
Posts: 273
Location: St Thomas Ontario

PostPosted: Fri Feb 01, 2013 4:39 pm    Post subject: Reply with quote

if you do have the correct firmware it should load .. so is there a mismatch ? what does lspci tell you about the detected wifi version ?

Also there is a way to load the firmware at compile time .. if you are interested there are other posts dealing with that you can search for as required. The wiki has other info available on loading firmware for various video cards .. network driver .. compile time loads work the same way ..
Back to top
View user's profile Send private message
kimmie
Guru
Guru


Joined: 08 Sep 2004
Posts: 531
Location: Australia

PostPosted: Sat Feb 02, 2013 3:18 am    Post subject: Reply with quote

Have you tried getting the firmware from portage? sys-firmware/iwl6005-microcode

If that doesn't work, here's how my firmware (note it's 6000, not 6005) looks under /lib/firmware, maybe you need to unpack differently.

Code:
~ $ cd /lib/firmware
/lib/firmware $ ls -R
.:
intel-ucode  iwlwifi-6000-4.ucode  microcode.dat

./intel-ucode:
06-03-02  06-07-01  06-0a-01  06-0f-0a  06-1c-0a  06-2d-07  0f-02-09  0f-04-09
06-05-00  06-07-02  06-0b-01  06-0f-0b  06-1d-01  06-3a-09  0f-03-02  0f-04-0a
06-05-01  06-07-03  06-0b-04  06-0f-0d  06-1e-04  0f-00-07  0f-03-03  0f-06-02
06-05-02  06-08-01  06-0d-06  06-16-01  06-1e-05  0f-00-0a  0f-03-04  0f-06-04
06-05-03  06-08-03  06-0e-08  06-17-06  06-25-02  0f-01-02  0f-04-01  0f-06-05
06-06-00  06-08-06  06-0e-0c  06-17-07  06-25-05  0f-02-04  0f-04-03  0f-06-08
06-06-05  06-08-0a  06-0f-02  06-17-0a  06-26-01  0f-02-05  0f-04-04
06-06-0a  06-09-05  06-0f-06  06-1a-04  06-2a-07  0f-02-06  0f-04-07
06-06-0d  06-0a-00  06-0f-07  06-1c-02  06-2d-06  0f-02-07  0f-04-08
/lib/firmware $
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 207

PostPosted: Sun Apr 28, 2013 11:31 am    Post subject: Reply with quote

do you run a deblobbed kernel? That will not work...
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2103
Location: Finland

PostPosted: Sun Apr 28, 2013 3:53 pm    Post subject: Reply with quote

Is USE="firmware-loader" enabled or disabled in sys-fs/udev? If it's disabled, then make sure kernel configuration is correct for loading it from there.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum