Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Not installed package is blocking one installed?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rudregues
Apprentice
Apprentice


Joined: 29 Jan 2013
Posts: 195

PostPosted: Fri Feb 01, 2013 6:19 pm    Post subject: [SOLVED]Not installed package is blocking one installed? Reply with quote

I was following this guide http://www.gentoo.org/doc/en/xorg-config.xml to install X and it ask to install linux-firmware and radeon-ucode. So I've installed linux-firmware with no problems. But when it comes to the other package
emerge radeon-ucode
Code:
* IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] x11-drivers/radeon-ucode-20120320
[blocks B      ] x11-drivers/radeon-ucode ("x11-drivers/radeon-ucode" is blocking sys-kernel/linux-firmware-20120924)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-drivers/radeon-ucode-20120320::gentoo, ebuild scheduled for merge) pulled in by
    radeon-ucode

  (sys-kernel/linux-firmware-20120924::gentoo, installed) pulled in by
    sys-kernel/linux-firmware required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Then I try to unmerge with emerge radeon-ucode --unmerge and receive another output:
Code:
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'radeon-ucode' to unmerge.

>>> No packages selected for removal by unmerge


It's really weird, how could a not installed program block a installed one? And why I cannot install radeon-ucode? If linux-firmware was blocking radeon-ucode it would make sense that I should not install it.

[ ]'s
_________________
Emerging en gentoo


Last edited by rudregues on Fri Feb 01, 2013 7:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
jrussia
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2012
Posts: 89
Location: Chicago

PostPosted: Fri Feb 01, 2013 7:21 pm    Post subject: Reply with quote

Hi rudregues,

You are mis-reading the output. radeon-ucode is being blocked by linux-firmware. You do not need both. From the guide you are using:

Quote:
For newer AMD/ATI cards (RadeonHD 2000 and up), you will need to emerge radeon-ucode or linux-firmware.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum