Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Icon way too big in XFCE (menu and panel)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pvh1987
n00b
n00b


Joined: 06 Jun 2012
Posts: 37

PostPosted: Thu Jan 31, 2013 1:50 am    Post subject: Icon way too big in XFCE (menu and panel) Reply with quote

When I started up my computer today, I found out that my icon for the Eclipse IDE had grown to an extremely large size so it does not fit in the panel or Application Menu in XFCE. I have never experienced anything like this before. I haven't done anything to either XFCE or Eclipse to make this happen. It used to be scaled to a nice 22x22 icon (or similar size) like all other icons. What can cause this and how do I fix this? Here is a screenshot:

http://i.tinyuploads.com/jvrJO9.png
Back to top
View user's profile Send private message
pvh1987
n00b
n00b


Joined: 06 Jun 2012
Posts: 37

PostPosted: Thu Jan 31, 2013 11:12 pm    Post subject: Reply with quote

It looks like I am not the only one having this problem. Some Ubuntu users seem to have the exact same problem:

https://bugs.launchpad.net/ubuntu/+source/dash/+bug/1068702

http://ubuntuforums.org/showthread.php?t=2079010

It might be related to the XPM icon format. But why this is suddenly happening from one day to the other is still very weird. I will try to find a solution. If you have any ideas, please let me know.
Back to top
View user's profile Send private message
pvh1987
n00b
n00b


Joined: 06 Jun 2012
Posts: 37

PostPosted: Thu Jan 31, 2013 11:23 pm    Post subject: Reply with quote

Ok, so now I done a quick and dirty fix. I converted the XPM icon to PNG and saved it as icon.png in the same folder as the old icon.xpm. Then I changed the desktop file in /usr/share/applications to use icon.png instead of icon.xpm. Now it works. However, it is not a real solution. XFCE (and other desktops) should be able to scale XPM icons just like PNG. And as I said before, it all worked fine until yesterday. I do not know if this is a known bug or where I should report it. It seems more general than just an XFCE-bug.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1590
Location: 127.0.0.1

PostPosted: Tue Feb 05, 2013 4:24 pm    Post subject: Reply with quote

Hi,

For the record :
gentoo bug 438786 - x11-libs/gdk-pixbuf-2.26.4 - xpm image are not being resized
upstream bug 686514 - gdk_pixbuf_new_from_file_at_scale() fails to scale xpm images
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum