Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ SOLVED ] having issues with getting wpa_supplicant to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
bedtime
n00b
n00b


Joined: 19 Dec 2012
Posts: 40

PostPosted: Wed Jan 30, 2013 7:58 pm    Post subject: [ SOLVED ] having issues with getting wpa_supplicant to work Reply with quote

I've followed the Gentoo guide to the best of my ability with no luck. When I open up wpa_gui in e17 it says:

Code:
Status: Could not get status from wpa_supplicant


Pressing 'scan' or 'connect' does nothing. I cannot enter in my network either.

I am running the latest kernel with CONFIG_CFG80211_WEXT, CONFIG_PACKET, and ath9k driver enabled (no initramfs, so automatically loaded). Connman seems to work fine but I'd rather just use wpa_gui instead. I've been making sure to do a 'rc-update del connman' before using wpa_supplicant. I'm using dhcpcd.

driver: ath9k

/etc/conf.d/net:
Code:
#Generated by NetworkManager
###### Global Configuration ######
modules="wpa_supplicant"

modules_wlan0="wpa_supplicant"
wpa_supplicant_wlan0="-Dwext"
config_wlan0="dhcp"

###### Connection Configuration ######
#----------------------------------
#enable_ipv6_0x776972656C6573732D7072696E746572="false"
#auto_0x776972656C6573732D7072696E746572="true"
#config_0x776972656C6573732D7072696E746572="dhcp"
#----------------------------------
dns_domain_lo="homenetwork"


eix wpa_supplicant:
Code:
user@tux ~ $ eix wpa_supplicant
[I] net-wireless/wpa_supplicant
     /.../
     Installed versions:  0.7.3-r5(08:01:31 AM 01/13/2013)([b]dbus kernel_linux qt4 readline ssl -debug -eap-sim -fasteap -gnutls -kernel_FreeBSD -madwifi -ps3 -selinux -wimax -wps[/b])
     /.../



eix dhcpcd:
Code:
[I] net-misc/dhcpcd
     Available versions:  5.6.4 ~5.6.6 {{elibc_glibc +zeroconf}}
     Installed versions:  5.6.4(10:27:50 AM 01/07/2013)(elibc_glibc zeroconf)
     Homepage:            http://roy.marples.name/projects/dhcpcd/
     Description:         A fully featured, yet light weight RFC2131 compliant DHCP client



/etc/wpa_supplicant/wpa_supplicant.conf:
http://bpaste.net/show/73933/


rc-update:
Code:
tux user # rc-update
                acpid |      default                 
            alsasound | boot                         
             bootmisc | boot                         
                 dbus |      default                 
                devfs |                       sysinit
                 fsck | boot                         
             hostname | boot                         
              hwclock | boot                         
              keymaps | boot                         
            killprocs |              shutdown       
                local |      default                 
           localmount | boot                         
             mount-ro |              shutdown       
                 mtab | boot                         
               net.lo | boot                         
             netmount |      default                 
               procfs | boot                         
                 root | boot                         
            savecache |              shutdown       
                 swap | boot                         
            swapfiles | boot                         
               sysctl | boot                         
                sysfs |                       sysinit
         termencoding | boot                         
       tmpfiles.setup | boot                         
                 udev |                       sysinit
           udev-mount |                       sysinit
              urandom | boot                         
tux user #


Anyways, net configuration has never been my speciality and I'm thinking there's just a little step I've not included.


*** EDIT ***

Well, I wasn't starting it, thats why it wasn't working. That and I've only recently enabled kernel support for wext.

Code:
wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -B
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Wed Jan 30, 2013 8:42 pm    Post subject: Reply with quote

bedtime.

The wpa_supplicant is not quite kosher - it should look something like this:

Code:
bill@laptop ~ $ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
update_config=1

network={
   ssid="myssid"
   psk="mypsk"
   proto=WPA2
   key_mgmt=WPA-PSK
   pairwise=CCMP TKIP-
   group=CCMP TKIP
   id_str="gentoo-laptop"
}

/etc/conf.d/net should be:
Code:
modules="wpa_supplicant"
wpa_supplicant_wlan0="-Dnl80211 -c/etc/wpa_supplicant/wpa_supplicant.conf"
config_wlan0="dhcp"

You could try -Dwext if -Dnl80211 doesn't work.

symlink net.wlan0 to net.lo and add net.wlan0 to your default runlevel.

That should get you started :wink:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
bedtime
n00b
n00b


Joined: 19 Dec 2012
Posts: 40

PostPosted: Thu Jan 31, 2013 1:56 am    Post subject: Reply with quote

BillWho,

Thanx. Its working. I got it working but I tried your solution and that seems to work as well.

Anyways, its working so I'm happy.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum