Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VGL error with xauth ( openrc problem? )
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Rhiakath
Guru
Guru


Joined: 10 Feb 2006
Posts: 572
Location: Hell...

PostPosted: Wed Jan 30, 2013 2:29 pm    Post subject: VGL error with xauth ( openrc problem? ) Reply with quote

Hi there. I've already seen some posts about this, but they're all a few months old, and i haven't found any solution yet.

Before anything else, i already had this working, but i formatted the disk, and reinstalled gentoo, and now it's not working.

the vgl init script hangs while trying to find XAuthority. And, like suggested in other posts here, if i do an echo $XAUTHORITY inside the init script it prints an empty line.
Also, like in those other posts, i do have XAUTHORITY with a correct value both as root, and as my own user.

So, i tried adding a start call at the end of the init script for vgl, and run it like this:

sh /etc/init.d/vgl

and, it complains about estart, but shows a correct XAUTHORITY value on that echo i put there earlier.
if i try to start the vgl service, the value is empty again.

So the value is indeed ok, regarding the script. So I guess the problem mustn't be on the script but on the caller.

Is this script called by openrc, or something? Is it possible openrc is clearing that value?
_________________
pc-rhiakath ~ $ emerge -s happiness
Searching..
[ Results for search key : happiness ]
[ Applications found : 0 ]

-------------------------------------------

I see dead pixels...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum