Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge genkernel doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
3v4n_D
n00b
n00b


Joined: 21 Apr 2012
Posts: 2

PostPosted: Sat Apr 21, 2012 3:48 pm    Post subject: emerge genkernel doesn't work Reply with quote

hello everybody...

I'm trying to install gentoo on my AMD Sempron box, but i get etuck when i get to the "7.d Alternative: Using genkernel" ....
i issue de command "emerge genkernel" and i get the following error:

Code:
 * ERROR: app-arch/cpio-2.11 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   85:  Called src_configure
 *        environment, line 1837:  Called econf '--enable-nls' '--bindir=/bin' '--with-rmt=/usr/sbin/rmt'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =app-arch/cpio-2.11',
 * the complete build log and the output of 'emerge -pqv =app-arch/cpio-2.11'.
 * The complete build log is located at '/var/tmp/portage/app-arch/cpio-2.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-arch/cpio-2.11/temp/environment'.
 * S: '/var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11'


i do emerge --info =app-arch/cpio-2.11 and i get:
Code:
ortage 2.1.10.49 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.13-r4, 2.6.32-5-amd64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-2.6.32-5-amd64-x86_64-AMD_Sempron-tm-_140_Processor-with-gentoo-2.0.3
Timestamp of tree: Sat, 21 Apr 2012 00:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          3.2.2
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo http://gentoo.localhost.net.ar/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.namerica.gentoo.org"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

so i'm asking your kind help to solve this issue
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Sat Apr 21, 2012 5:28 pm    Post subject: Reply with quote

3v4n_D,

Welcome to Gentoo.

Your problems is not with genkernel itself, its with cpio, which is a package it depends on.
Please post /var/tmp/portage/app-arch/cpio-2.11/temp/build.log.

The easiest way for you to do that is
Code:
emerge wgetpaste
wgetpaste /var/tmp/portage/app-arch/cpio-2.11/temp/build.log
then tell us the URL you get.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
theamazingplant2
n00b
n00b


Joined: 12 Apr 2012
Posts: 14

PostPosted: Sat Apr 21, 2012 8:18 pm    Post subject: Chroot Reply with quote

Hi, are you chrooting into the environment? I am asking this because, i recently had a problem where the SAME dependency would not work when i chrooted into gentoo. The solution is simply to make sure that proc is mounted, and just for good measure dev is also.
if you are in a chrooted environment. exit out of it and mount proc and dev with the following codes, with the /mnt/gentoo being replaced with where your gentoo is mounted at.
Code:

sudo mount -t proc none /mnt/gentoo/proc

and to mount dev
Code:

sudo mount -o bind /dev /mnt/gentoo/dev

I hope this helped.
Back to top
View user's profile Send private message
3v4n_D
n00b
n00b


Joined: 21 Apr 2012
Posts: 2

PostPosted: Sun Apr 22, 2012 6:54 am    Post subject: Re: Chroot Reply with quote

theamazingplant2 wrote:
Hi, are you chrooting into the environment? I am asking this because, i recently had a problem where the SAME dependency would not work when i chrooted into gentoo. The solution is simply to make sure that proc is mounted, and just for good measure dev is also.
if you are in a chrooted environment. exit out of it and mount proc and dev with the following codes, with the /mnt/gentoo being replaced with where your gentoo is mounted at.
Code:

sudo mount -t proc none /mnt/gentoo/proc

and to mount dev
Code:

sudo mount -o bind /dev /mnt/gentoo/dev

I hope this helped.


it did !!!

i made
Code:
#mount -t proc none /mnt/gentoo/proc
#mount -o bind /dev /mnt/gentoo/dev
instead of
Code:
#mount -t proc none /mnt/gentoo/proc
#mount --rbind /dev /mnt/gentoo/dev
and the problem got solved
Back to top
View user's profile Send private message
erdnuesse
n00b
n00b


Joined: 29 Jan 2013
Posts: 1

PostPosted: Tue Jan 29, 2013 1:11 pm    Post subject: same issue here. Reply with quote

Hi, there.

I am experiencing the exact (from what i read) same issue, except for the line numbers.
(That's the reason I did not want to open a new thread - because the symptoms are identical.)
BUT: I do it in a virtualbox, if that matters.

Code:
>>> Emerging (1 of 2) app-arch/cpio-2.11
openpty failed: 'out of pty devices'
...
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11/config.log
 * ERROR: app-arch/cpio-2.11 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 1998:  Called econf '--enable-nls' '--bindir=/bin' '--with-rmt=/usr/sbin/rmt'
 *   phase-helpers.sh, line  501:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=app-arch/cpio-2.11'`,
 * the complete build log and the output of `emerge -pqv '=app-arch/cpio-2.11'`.
 * The complete build log is located at '/var/tmp/portage/app-arch/cpio-2.11/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-arch/cpio-2.11/temp/environment'.
 * Working directory: '/var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11'
 * S: '/var/tmp/portage/app-arch/cpio-2.11/work/cpio-2.11'


I already tried chrooting out and remounting /dev and /proc with no success.

Find my wgetpaste here:
http://bpaste.net/show/73615/

Thanks in advance.
/erdnuesse
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum