Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] php-toolkit wanting to install but no ebuild
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Sun Jan 27, 2013 1:48 pm    Post subject: [Solved] php-toolkit wanting to install but no ebuild Reply with quote

Hi,

While doing the following I encountered this error :

emerge --update --newuse --deep --with-bdeps=y @world
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "app-admin/php-toolkit".
(dependency required by "dev-lang/php-5.3.3-r1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

php-toolkit is not installed on this system, trying to find reverse dependencies therefore did not work ?

I have attempted to grep app-toolkit in /usr/portage as well as /etc/portage yet find no instance.
Using grep, I cannot find php-5.3.3-r1 in /etc/portage

emerge -s php indicates that dev-lang/php 5.4.8 is installed
eselect php list apache2 indicates that 5.4 is selected (as with cli, cgi)

Google does not offer anything specific to this and I am now out of my depth :)

Any assistance would be appreciated.

Have fun.


Last edited by palchen on Tue Jan 29, 2013 1:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Sun Jan 27, 2013 6:26 pm    Post subject: Reply with quote

Does this happen when you run

Code:

emerge -pvuDN world


?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4613
Location: Saint Amant, Acadiana

PostPosted: Sun Jan 27, 2013 6:32 pm    Post subject: Reply with quote

Quote:
(dependency required by "dev-lang/php-5.3.3-r1" [installed])

It seems portage thinks it's installed, did you try and unmerge it?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Mon Jan 28, 2013 4:57 am    Post subject: php-toolkit wanting to install but no ebuild Reply with quote

Hi,

"emerge -pvuDN world" yields the same results as "emerge --update --newuse --deep --with-bdeps=y @world"

emerge -s php-toolkit
Searching...
[ Results for search key : php-toolkit ]
[ Applications found : 0 ][/code]

locate php-toolkit |less
/var/cache/http-replicator/php-toolkit-1.0.1.tar.bz2
but it is not installed ...

Something has a dependency for this but I am unable to find what it is, there is no reference to this in /etc/portage/ nor make.conf.
The two overlays that I use do not have them either - I successfully updated Davical from the Sunrise overlay without this dependency being required.

I have even "masked" this package in package.mask to no avail !
How do I find which package is calling this in ?

Thanks.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5251

PostPosted: Mon Jan 28, 2013 6:07 pm    Post subject: Re: php-toolkit wanting to install but no ebuild Reply with quote

palchen wrote:
How do I find which package is calling this in ?


I think it's equery belongs (package).
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Tue Jan 29, 2013 5:18 am    Post subject: Re: php-toolkit wanting to install but no ebuild Reply with quote

audiodef wrote:
palchen wrote:
How do I find which package is calling this in ?


I think it's equery belongs (package).


I tried this against php-toolkit but as it is not installed, no info given.

If this is indicating something of value then I am missing it :(
Code:
equery depends php-5.3.3-r1
[ Searching for packages depending on php-5.3.3-r1... ]
dev-db/phpmyadmin-3.3.8.1 (dev-lang/php[crypt,ctype,filter,session,unicode])
                          (dev-lang/php[mysql])
                          (>=dev-lang/php-5.3)
dev-lang/php-5.3.3-r1 (=dev-lang/php-5.3.3-r1[-libedit])
                      (=dev-lang/php-5.3.3-r1[gd])
                      (=dev-lang/php-5.3.3-r1[hash])
                      (=dev-lang/php-5.3.3-r1[xml])
                      (=dev-lang/php-5.3.3-r1[zlib,-gd-external])
dev-php/PEAR-PEAR-1.9.0 (dev-lang/php)
dev-php/awl-0.53 (dev-lang/php)
                 (dev-lang/php[pdo,postgres,xml])
                 (=dev-lang/php-5*)
mail-client/roundcube-0.3.1 (!postgres & !mysql? dev-lang/php[sqlite])
                            (spell? dev-lang/php[curl,spell])
net-print/cups-1.3.11-r2 (dev-lang/php)
virtual/httpd-php-5.3 (=dev-lang/php-5.3*[apache2])
                      (=dev-lang/php-5.3*[cgi])
www-apps/davical-0.9.9.4 (=dev-lang/php-5*)
                         (>=dev-lang/php-5.3[pdo,postgres,xml])
www-apps/davical-1.1.1 (=dev-lang/php-5*)
www-apps/postfixadmin-2.3.5 (dev-lang/php[unicode,imap,postgres?,xmlrpc?])
                            (mysql? dev-lang/php[mysql])


Thanks for the pointer.
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Tue Jan 29, 2013 8:58 am    Post subject: Re: php-toolkit wanting to install but no ebuild Reply with quote

Hi,

This is illogical to me but I decided to update all packages listed in:
equery depends php-5.3.3-r1 even though "emerge -s" indicates that it is not installed.

Code:
emerge -pav roundcube
[blocks B      ] dev-lang/php:5 ("dev-lang/php:5" is blocking dev-lang/php-5.3.18)
...
([b]dev-lang/php-5.3.3-r1::gentoo, installed[/b]) pulled in by
    dev-lang/php:5 required by @selected


which led me to follow
http://www.gentoo.org/proj/en/php/php-upgrading.xml - all was well on the system

I unmerged all packages from Overlays and removed the Overlays

Code:
revdep-rebuild -p
emerge: there are no ebuilds to satisfy "dev-lang/php:5"


It seems that my issue revolves around dev-lang/php:5 and that php-toolkit is a side issue ?


The following is difficult for me to make sense of:

Code:
equery d php:5
[ Searching for packages depending on php:5... ]
dev-db/phpmyadmin-3.3.8.1 (dev-lang/php[crypt,ctype,filter,session,unicode])
                          (dev-lang/php[mysql])
                          (>=dev-lang/php-5.3)
dev-db/phpmyadmin-3.5.3 (dev-lang/php[crypt,ctype,filter,json,session,unicode])                                                                         
                        (dev-lang/php[mysql])                                                                                                           
dev-lang/php-5.3.3-r1 (=dev-lang/php-5.3.3-r1[-libedit])
                      (=dev-lang/php-5.3.3-r1[gd])
                      (=dev-lang/php-5.3.3-r1[hash])
                      (=dev-lang/php-5.3.3-r1[xml])
                      (=dev-lang/php-5.3.3-r1[zlib,-gd-external])
dev-php/PEAR-Archive_Tar-1.3.9 (>=dev-lang/php-5.3)
dev-php/PEAR-Console_Getopt-1.3.1 (>=dev-lang/php-5.3)
dev-php/PEAR-PEAR-1.9.4 (dev-lang/php[cli,xml,zlib])
                        (>=dev-lang/php-5.3)
dev-php/PEAR-Structures_Graph-1.0.4 (>=dev-lang/php-5.3)
dev-php/PEAR-XML_Util-1.2.1-r2 (>=dev-lang/php-5.3)
virtual/httpd-php-5.3 (=dev-lang/php-5.3*[apache2])
                      (=dev-lang/php-5.3*[cgi])
www-apps/postfixadmin-2.3.5 (dev-lang/php[unicode,imap,postgres?,xmlrpc?])
                            (mysql? dev-lang/php[mysql])


Thanks for your assistance.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5431

PostPosted: Tue Jan 29, 2013 11:06 am    Post subject: Reply with quote

The most of the confusion here is is simply cause you've failed to mention, that your system hasn't been updated in quite awhile (somewhere around two years).
You need to unmerge dev-lang/php-5.3.3-r1, so that a supported 5.3 version can be emerged - that is if you need 5.3 slot.
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Tue Jan 29, 2013 11:30 am    Post subject: Reply with quote

VoidMage wrote:
The most of the confusion here is is simply cause you've failed to mention, that your system hasn't been updated in quite awhile (somewhere around two years).
You need to unmerge dev-lang/php-5.3.3-r1, so that a supported 5.3 version can be emerged - that is if you need 5.3 slot.


Thank you.

I do not need php-5.3.3-r1 yet something does.
I am trying to remove this dependency yet cannot find which package is insisting on it.

dev-lang/php-5.3.3-r1 is no longer an available ebuild and emerging by "path" fails.

Regards.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5431

PostPosted: Tue Jan 29, 2013 1:19 pm    Post subject: Reply with quote

palchen wrote:
I do not need php-5.3.3-r1 yet something does.
I am trying to remove this dependency yet cannot find which package is insisting on it.


The above doesn't make much sense.
The output you've posted says php-5.3.3-r1 is installed, I'm saying that you should unmerge that version, so what does the existence of the ebuild have to do with it ?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4613
Location: Saint Amant, Acadiana

PostPosted: Tue Jan 29, 2013 1:23 pm    Post subject: Reply with quote

I said the same thing two days ago, just wondering how many people have to say it?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
palchen
n00b
n00b


Joined: 29 Dec 2007
Posts: 10

PostPosted: Tue Jan 29, 2013 1:45 pm    Post subject: [Solved] Re: php-toolkit wanting to install but no ebuild Reply with quote

Jaglover wrote:
I said the same thing two days ago, just wondering how many people have to say it?


Thank you very much.

My ignorance wrt multiple versions of php being able to run on a machine may me ignore this,
I assumed that as 5.4 was installed, no other versions were - apologies.

Thanks for you patience and help.

Have fun.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum