Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[overlay] unity-gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 12, 13, 14 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Jan 11, 2013 9:44 pm    Post subject: Reply with quote

Small question about 'auto mount' of USB-sticks in Unity.
Every time I plugin a USB-Stick under Unity, a program with the 'free disk space' is opened instead of nautilus. Also the created launcher icon opens this disk usage program. How can I change the behaviour to open the nautilus?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Jan 12, 2013 2:02 am    Post subject: Reply with quote

renegart wrote:
Small question about 'auto mount' of USB-sticks in Unity.
Every time I plugin a USB-Stick under Unity, a program with the 'free disk space' is opened instead of nautilus. Also the created launcher icon opens this disk usage program. How can I change the behaviour to open the nautilus?

What is this program called ?
Do you get the same behaviour when plugging a usb stick in while inside a Gnome session ?
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sat Jan 12, 2013 9:17 am    Post subject: Reply with quote

shiznix wrote:
renegart wrote:
Small question about 'auto mount' of USB-sticks in Unity.
Every time I plugin a USB-Stick under Unity, a program with the 'free disk space' is opened instead of nautilus. Also the created launcher icon opens this disk usage program. How can I change the behaviour to open the nautilus?

What is this program called ?
Do you get the same behaviour when plugging a usb stick in while inside a Gnome session ?


Yes, same with a gnome session. The info dialog identifies the program as 'Baobab'.
I don't find anything in the settings panel to change that behaviour.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Jan 12, 2013 9:18 pm    Post subject: Reply with quote

I can't reproduce this even with baobab emerged.
But you might look in System Settings > Details > Removeable Media and Default Applications.

If you still get no joy, check your desktop user's ~/.local/share/applications/mimeapps.list file.
Specifically the 'inode/directory=' mimetype entry.

Thanks for the ebuild updates for appmenu-firefox and appmenu-thunderbird, I've merged your pull request ;)
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sun Jan 13, 2013 1:28 pm    Post subject: Reply with quote

shiznix wrote:
I can't reproduce this even with baobab emerged.
But you might look in System Settings > Details > Removeable Media and Default Applications.

If you still get no joy, check your desktop user's ~/.local/share/applications/mimeapps.list file.
Specifically the 'inode/directory=' mimetype entry.


I've found a solution at https://bbs.archlinux.org/viewtopic.php?id=151907
I don't know if this is a topic for a patch.

shiznix wrote:
Thanks for the ebuild updates for appmenu-firefox and appmenu-thunderbird, I've merged your pull request ;)

You*re wellcome ;)
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sun Jan 13, 2013 4:17 pm    Post subject: Reply with quote

mirall/owncloud:
I've installed 'mirall' as ownCloud client which is accessible over a try-icon when running.

I see the icon in a gnome session but not in a Unity session.
The program depends on Qt. Do I need to install some additional package to see icons of Qt programs in the tray?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Jan 13, 2013 8:38 pm    Post subject: Reply with quote

renegart wrote:
mirall/owncloud:
I've installed 'mirall' as ownCloud client which is accessible over a try-icon when running.

I see the icon in a gnome session but not in a Unity session.
The program depends on Qt. Do I need to install some additional package to see icons of Qt programs in the tray?

Add the program to com.canonical.Unity.Panel systray-whitelist entry using dconf-editor.
Or use the following to allow all programs access to the systray:
Code:
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Mon Jan 14, 2013 7:31 am    Post subject: Reply with quote

shiznix wrote:
renegart wrote:
mirall/owncloud:
I've installed 'mirall' as ownCloud client which is accessible over a try-icon when running.

I see the icon in a gnome session but not in a Unity session.
The program depends on Qt. Do I need to install some additional package to see icons of Qt programs in the tray?

Add the program to com.canonical.Unity.Panel systray-whitelist entry using dconf-editor.
Or use the following to allow all programs access to the systray:
Code:
gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"


Had worked. Thx.

I'm wondering if that is a new behaviour/setting of Unity?
My home directory (and the settings) on my netbook were created with Ubuntu and those things had worked before.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Wed Jan 16, 2013 2:24 am    Post subject: Reply with quote

@renegart
Not sure if it's a new setting, I've only been using Unity for a short time since Unity5 precise release.
But I have seen this method used on Ubuntu proper going by the Ubuntu forums.


Lots of commits and some minor dependency fixes, thanks to all those reporting on here, github and IRC.

I've now finally got empathy instant messaging integration working along with Ubuntu's online accounts.

If you want to try it, enable the 'chat' USE flag for unity-meta.
It's optional as it does add quite a lot of other packages and it's not crucial for the overall desktop experience.
I've only got Facebook and IRC tested so far as they're the only type of messaging I use but it 'should' work with most of the other more commonly used protocols.

You might have to log out and back in for the messages indicator (small envelope on the top panel) to appear and will only appear when an IM app. such as empathy is running.

Any issues please let me know, thanks! :D
Back to top
View user's profile Send private message
Cybertox
n00b
n00b


Joined: 06 Jan 2013
Posts: 3

PostPosted: Thu Jan 17, 2013 11:33 pm    Post subject: Reply with quote

Hello!
I've got circular dependencies when trying to install unity-meta, something like this:

Code:

Cybertox # emerge -av unity-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!


[ebuild  N     ] unity-base/unity-meta-6.10.0::unity-gentoo  0 kB
[ebuild  N     ]  net-im/empathy-99.3.6.2::unity-gentoo  USE="geocode geoloc map v4l -debug -gnome -gnome-online-accounts -sendto -spell {-test}" 3,398 kB
[ebuild  N     ]   net-libs/account-plugins-0.8::unity-gentoo  USE="-debug" 391 kB
[nomerge       ] unity-base/unity-meta-6.10.0::unity-gentoo
[nomerge       ]  unity-base/unity-lens-photos-0.8::unity-gentoo
[nomerge       ]   dev-libs/libsignon-glib-1.6::unity-gentoo  USE="-debug"
[ebuild  N     ]    unity-base/signon-8.43::unity-gentoo  USE="-doc" 192 kB
[ebuild  N     ]     unity-base/signon-keyring-extension-0.3::unity-gentoo  USE="-doc" 15 kB
[ebuild  N     ]  unity-base/unity-lens-photos-0.8::unity-gentoo  58 kB
[nomerge       ] net-libs/account-plugins-0.8::unity-gentoo  USE="-debug"
[ebuild  N     ]  unity-base/gnome-control-center-signon-0.0.18::unity-gentoo  USE="-debug" 468 kB
[ebuild  N     ]   dev-libs/libsignon-glib-1.6::unity-gentoo  USE="-debug" 407 kB

Total: 8 packages (8 new), Size of downloads: 4,925 kB

 * Error: circular dependencies:

(unity-base/signon-8.43::unity-gentoo, ebuild scheduled for merge) depends on
 (unity-base/signon-keyring-extension-0.3::unity-gentoo, ebuild scheduled for merge) (buildtime)
  (unity-base/signon-8.43::unity-gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/webkit-gtk:3

  (net-libs/webkit-gtk-1.8.3-r300::gentoo, ebuild scheduled for merge) pulled in by
    <net-libs/webkit-gtk-1.10:3[introspection] required by (media-sound/rhythmbox-2.97::gentoo, ebuild scheduled for merge)

  (net-libs/webkit-gtk-1.10.2-r300::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

Could anybody help me to solve it?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Jan 18, 2013 4:36 am    Post subject: Reply with quote

The circular dep. on signon packages has been fixed.

The webkit-gtk problem is due to rhythmbox needing <net-libs/webkit-gtk-1.10:3 when it has the 'html' USE flag enabled.

You can either downgrade webkit-gtk from your installed version 1.10.2-r300 down to 1.8.3-r300, or you can disable the 'html' USE flag for rhythmbox.
Downgrading webkit-gtk is probably the preferred method as rhythmbox will be able to use it's features.
Back to top
View user's profile Send private message
Cybertox
n00b
n00b


Joined: 06 Jan 2013
Posts: 3

PostPosted: Fri Jan 18, 2013 7:36 am    Post subject: Reply with quote

shiznix wrote:
The circular dep. on signon packages has been fixed.

The webkit-gtk problem is due to rhythmbox needing <net-libs/webkit-gtk-1.10:3 when it has the 'html' USE flag enabled.

You can either downgrade webkit-gtk from your installed version 1.10.2-r300 down to 1.8.3-r300, or you can disable the 'html' USE flag for rhythmbox.
Downgrading webkit-gtk is probably the preferred method as rhythmbox will be able to use it's features.

Thanks a lot! Signon packages i have installed. But now another problem has appeared. After syncing overlays (layman -S) I've got the next:
Code:

Cybertox # emerge -av unity-meta

These are the packages that would be merged, in order:

Calculating dependencies | * A file is not listed in the Manifest: '/var/lib/layman/unity-gentoo/unity-base/unity-meta/unity-meta-6.10.0.ebuild'
 * Missing digest for '/var/lib/layman/unity-gentoo/unity-base/unity-meta/unity-meta-6.10.0.ebuild'
... done!

!!! All ebuilds that could satisfy "unity-meta" have been masked.
!!! One of the following masked packages is required to complete your request:
- unity-base/unity-meta-6.12.0::unity-gentoo (masked by: corruption)
- unity-base/unity-meta-6.10.0::unity-gentoo (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Jan 18, 2013 8:42 am    Post subject: Reply with quote

Fixed now, should have used 'git add -u <folder>' instead of 'git add <folder>' so it tracked the deletion of unity-base/unity-meta/unity-meta-6.10.0.ebuild

Thanks for reporting, still getting the nuances of git commits on this side so thanks for being patient too :)
Back to top
View user's profile Send private message
Rukiri
n00b
n00b


Joined: 28 Oct 2011
Posts: 56

PostPosted: Sat Jan 19, 2013 9:50 am    Post subject: Reply with quote

Pygobject can't be emerged as of 3.4, I've tried everything to fix it but eventually gave up.
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Jan 19, 2013 11:07 pm    Post subject: Reply with quote

Rukiri wrote:
Pygobject can't be emerged as of 3.4, I've tried everything to fix it but eventually gave up.

I have dev-python/pygobject-3.4.2 installed here, can you pastebin a full build.log ?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Mon Jan 21, 2013 12:05 am    Post subject: Reply with quote

Alrighty Webapps integration is now in the overlay.
For those wondering what webapps are this video explains it better than words -> https://www.youtube.com/watch?v=L2YNR1KU1Xs

To use it enable the 'webapps' USE flag for unity-meta and emerge.

One important note is that while adding these packages in I realised the old unity-webapps package was misnamed and should have been called libunity-webapps.
You may need to 'emerge -C unity-webapps' first to avoid file collisions between the new libunity-webapps package and the old unity-webapps package.

Webapps only works in Chromium or Firefox and one of those must be set as your default browser.

The overlay doesn't have Chromium support yet as it needs to be patched with Ubuntu's patchset and I haven't yet worked out Chromium's odd build system (GYP + scons).
Webapps doesn't work with google-chrome as the patches can't be applied due to it's closed source.

No patches are required for firefox and webapps works with firefox-bin also.
Once the packages are installed you'll probably need to log out of X and back in again so that the webapps services are started.
You'll also need to open Firefox and enable the new extensions in Tools > Addons > Extensions then restart Firefox.

Visiting any of the supported URLs in Firefox should now prompt you to install the webapp service for that URL.
Choosing 'Yes' will have that site integrate with the dash launcher, HUD and indicators (mostly the messages indicator).
You can enable/disable the different webapps later using the Unsettings application in System Settings > Unsettings.


Thanks :D


Last edited by shiznix on Thu Jan 24, 2013 10:35 am; edited 1 time in total
Back to top
View user's profile Send private message
Rukiri
n00b
n00b


Joined: 28 Oct 2011
Posts: 56

PostPosted: Mon Jan 21, 2013 5:59 pm    Post subject: Reply with quote

shiznix wrote:
Rukiri wrote:
Pygobject can't be emerged as of 3.4, I've tried everything to fix it but eventually gave up.

I have dev-python/pygobject-3.4.2 installed here, can you pastebin a full build.log ?

Here you go.
http://pastebin.com/kP331Sjb
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Tue Jan 22, 2013 3:46 am    Post subject: Reply with quote

Rukiri wrote:
Here you go.
http://pastebin.com/kP331Sjb

I can't reproduce it, and the cause of the error isn't immediately obvious but research suggests that function format gets recognised by python via libffi.

So as a catch all to try and fix you could try:
Code:
emerge -1 libffi
python-updater

EDIT: I neglected to recommend to also file a bug on bugs.gentoo.org as this is a package that comes from the main portage tree and is kind of crucial to a whole host of other software, not just unity-gentoo packages, thanks.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Jan 25, 2013 5:38 pm    Post subject: Reply with quote

Hi,
since a few days portage wants to re-emerge following packages during updates:

[ebuild rR ~] net-im/empathy-99.3.6.0.3
[ebuild rR ~] media-video/cheese-3.6.2
[ebuild rR ~] media-libs/clutter-gst-1.9.92
[ebuild rR ~] media-libs/clutter-gtk-1.4.2
[ebuild rR ~] media-libs/clutter-1.12.2

Any idea why?
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Fri Jan 25, 2013 11:16 pm    Post subject: Reply with quote

renegart wrote:
Hi,
since a few days portage wants to re-emerge following packages during updates:

[ebuild rR ~] net-im/empathy-99.3.6.0.3
[ebuild rR ~] media-video/cheese-3.6.2
[ebuild rR ~] media-libs/clutter-gst-1.9.92
[ebuild rR ~] media-libs/clutter-gtk-1.4.2
[ebuild rR ~] media-libs/clutter-1.12.2

Any idea why?

Have you let it perform the reinstall of those packages, or does it constantly want to reinstall those packages even after they have been reinstalled ?

From 'man emerge':
r reinstall (forced for some reason, possibly due to slot or sub-slot)

Possibly triggered by this:
--rebuild-if-new-slot [ y | n ]
Automatically rebuild or reinstall packages when slot/sub-slot := operator dependencies can be satisfied by a newer slot, so that older packages slots will become
eligible for removal by the --depclean action as soon as possible. This option only affects packages that specify slot/sub-slot := dependencies which are supported
beginning with EAPI 5. Since this option requires checking of reverse dependencies, it enables --complete-graph mode whenever a new slot is installed. This option
is enabled by default.

And all of those package versions you listed above use EAPI 5 and have slot/sub-slot := dependencies in their DEPEND list.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sat Jan 26, 2013 7:16 am    Post subject: Reply with quote

shiznix wrote:
renegart wrote:
Hi,
since a few days portage wants to re-emerge following packages during updates:

[ebuild rR ~] net-im/empathy-99.3.6.0.3
[ebuild rR ~] media-video/cheese-3.6.2
[ebuild rR ~] media-libs/clutter-gst-1.9.92
[ebuild rR ~] media-libs/clutter-gtk-1.4.2
[ebuild rR ~] media-libs/clutter-1.12.2

Any idea why?

Have you let it perform the reinstall of those packages, or does it constantly want to reinstall those packages even after they have been reinstalled ?

From 'man emerge':
r reinstall (forced for some reason, possibly due to slot or sub-slot)

Possibly triggered by this:
--rebuild-if-new-slot [ y | n ]
Automatically rebuild or reinstall packages when slot/sub-slot := operator dependencies can be satisfied by a newer slot, so that older packages slots will become
eligible for removal by the --depclean action as soon as possible. This option only affects packages that specify slot/sub-slot := dependencies which are supported
beginning with EAPI 5. Since this option requires checking of reverse dependencies, it enables --complete-graph mode whenever a new slot is installed. This option
is enabled by default.

And all of those package versions you listed above use EAPI 5 and have slot/sub-slot := dependencies in their DEPEND list.


Portage will rebuild it with every run even it was built with last update.

can you please check with
Code:
emerge -pDut @world
if it's also the case on your side. I think it began with introducing 'empathy-99.3.6.*'
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sat Jan 26, 2013 9:42 pm    Post subject: Reply with quote

renegart wrote:
Portage will rebuild it with every run even it was built with last update.

can you please check with
Code:
emerge -pDut @world
if it's also the case on your side. I think it began with introducing 'empathy-99.3.6.*'

I've checked here with that command and even though I have empathy-99.3.6.0.3 installed here I don't have the same rebuild problem.
I also have all those other packages you listed and the same versions installed (with the exception of media-libs/clutter-gst-2.0.0).

empathy-99.3.6.0.3 was introduced around the same time EAPI 5 was also introduced and is simply a copy of /usr/portage/net-im/empathy/empathy-3.6.2-r2.ebuild with the Ubuntu patchset applied and some extra configure switches at build time, so I can't see if this could be the source of the bug.

But as a test, you could try temporarily uninstalling empathy, do an emerge -pDut @world and see if the package rebuild problem still occurs.

Could you perhaps also pastebin a complete output of 'emerge -pDut @world' so that it might show what packages are pulling in what.

Let us know how it goes, thanks :D
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sun Jan 27, 2013 8:44 am    Post subject: Reply with quote

shiznix wrote:
renegart wrote:
Portage will rebuild it with every run even it was built with last update.

can you please check with
Code:
emerge -pDut @world
if it's also the case on your side. I think it began with introducing 'empathy-99.3.6.*'

I've checked here with that command and even though I have empathy-99.3.6.0.3 installed here I don't have the same rebuild problem.
I also have all those other packages you listed and the same versions installed (with the exception of media-libs/clutter-gst-2.0.0).

empathy-99.3.6.0.3 was introduced around the same time EAPI 5 was also introduced and is simply a copy of /usr/portage/net-im/empathy/empathy-3.6.2-r2.ebuild with the Ubuntu patchset applied and some extra configure switches at build time, so I can't see if this could be the source of the bug.

But as a test, you could try temporarily uninstalling empathy, do an emerge -pDut @world and see if the package rebuild problem still occurs.

Could you perhaps also pastebin a complete output of 'emerge -pDut @world' so that it might show what packages are pulling in what.

Let us know how it goes, thanks :D


I've un-installed all packages. On first run, portage re-installed everything. The next runs it will re-merge the whole stuff again and again.

The tree is following:
Code:

[ebuild  rR   ~] net-im/empathy-99.3.6.0.3
[ebuild  rR   ~]  media-video/cheese-3.6.2
[ebuild  rR   ~]   media-libs/clutter-gst-2.0.0
[ebuild  rR   ~]   media-libs/clutter-gtk-1.4.2
[ebuild  rR   ~]    media-libs/clutter-1.12.2


maybe it's a problem with the 'cheese' package...
Back to top
View user's profile Send private message
shiznix
Guru
Guru


Joined: 29 Jun 2003
Posts: 358
Location: Adelaide, Australia

PostPosted: Sun Jan 27, 2013 9:15 am    Post subject: Reply with quote

What output do you get when you do:
Code:
emerge -C empathy
emerge -pDut @world
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Sun Jan 27, 2013 9:45 am    Post subject: Reply with quote

shiznix wrote:
What output do you get when you do:
Code:
emerge -C empathy
emerge -pDut @world


Code:

Calculating dependencies... done!
[nomerge       ] gnome-base/gnome-3.6.2
[nomerge       ]  gnome-base/gnome-core-apps-3.6.2
[ebuild  N    ~]   net-im/empathy-99.3.6.0.3  USE="gnome v4l {-test}"
[ebuild  rR   ~] media-video/cheese-3.6.2
[ebuild  rR   ~]  media-libs/clutter-gst-2.0.0
[ebuild  rR   ~]  media-libs/clutter-gtk-1.4.2
[ebuild  rR   ~]   media-libs/clutter-1.12.2


EDIT:
Can it be that you have a typo in the version string of 'empathy'?
The portage tree contains a package 'net-im/empathy-3.6.3'. Should your package have the name 'net-im/empathy-99.3.6.3.0?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 12, 13, 14 ... 24, 25, 26  Next
Page 13 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum