Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Easiest way to rebuild packages after Java switch
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
leifbk
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 286
Location: Bærum, Norway

PostPosted: Thu Jan 24, 2013 11:01 am    Post subject: Easiest way to rebuild packages after Java switch Reply with quote

Some years ago I had to switch from Icedtea to Sun Java because the Norwegian Netbank implementation didn't work with Icedtea, probably a bug compatibility issue ;)

Yesterday I experimented with the masked Oracle Java 7, with depressing results. I should have known better, but I ran an unfortunate "eclean -d distfiles" after the upgrade. The stable Sun/Oracle version, dev-java/sun-jre-bin-1.6.0.37 is no longer available for download, and the masked dev-java/oracle-jre-bin-1.7.0.11 isn't working with my Norwegian Netbank. Out of desperation I installed Icedtea, rebuilt Firefox, and lo and behold, the Netbank is working again. But there are obviously other packages that needs to be rebuilt, and revdep-rebuild doesn't spot changes in the Java configuration. Most packages are probably spotted with this command:

Code:
balapapa ~ # equery d virtual/jre
 * These packages depend on virtual/jre:
app-office/libreoffice-3.6.4.3 (java ? >=virtual/jre-1.6)
dev-java/java-config-2.1.12-r1 (>=virtual/jre-1.5)
dev-lang/R-2.10.1 (java ? >=virtual/jre-1.5)
dev-libs/protobuf-2.4.0a (java ? >=virtual/jre-1.5)
media-libs/libjpeg-turbo-1.2.1 (java ? >=virtual/jre-1.5)
net-dns/libidn-1.25 (java ? >=virtual/jre-1.4)
net-print/cups-1.5.2-r4 (java ? >=virtual/jre-1.6)
sys-devel/gettext-0.18.1.1-r3 (java ? >=virtual/jre-1.4)
sys-libs/db-4.8.30 (java ? >=virtual/jre-1.5)


I could of course massage this output, but is there a better method? Firefox is not on the list, even if I know from experience that it has to be rebuilt.
_________________
The Yggdrasil Genealogy Project
Back to top
View user's profile Send private message
[n00b@localhost]
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 212
Location: London, UK

PostPosted: Thu Jan 24, 2013 4:20 pm    Post subject: Reply with quote

You should try "equery d virtual/jdk" as well to catch packages that need to be built with the current JDK as well as those that depend on the current JRE at runtime.
Back to top
View user's profile Send private message
leifbk
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 286
Location: Bærum, Norway

PostPosted: Thu Jan 24, 2013 8:58 pm    Post subject: Reply with quote

[n00b@localhost] wrote:
You should try "equery d virtual/jdk" as well to catch packages that need to be built with the current JDK as well as those that depend on the current JRE at runtime.


I did, but the output is essentially the same, so I didn't care to mention it. Another interesting command is showing every package that has a "java" use flag (I've set it globally in make.conf):

Code:
balapapa ~ # emerge -epv world | grep " java "
[ebuild   R    ] sys-devel/gettext-0.18.1.1-r3  USE="acl cxx java nls openmp -cvs -doc -emacs -git -static-libs" 0 kB
[ebuild   R    ] sys-libs/db-4.8.30:4.8  USE="cxx java -doc -examples -tcl {-test}" 0 kB
[ebuild   R    ] net-print/cups-1.5.2-r4  USE="X acl dbus filters java jpeg ldap pam perl png python ssl threads tiff usb -avahi -debug -gnutls -kerberos (-selinux) -slp -static-libs -xinetd" LINGUAS="no -da -de -es -eu -fi -fr -id -it -ja -ko -nl -pl -pt -pt_BR -ru -sv -zh -zh_TW" 0 kB
[ebuild   R    ] dev-libs/cyrus-sasl-2.1.25-r3:2  USE="berkdb gdbm java pam postgres ssl -authdaemond -kerberos -ldapdb -mysql -openldap -sample -sqlite -srp -static-libs -urandom" 0 kB
[ebuild   R    ] dev-lang/R-2.10.1  USE="X cairo java jpeg nls perl png readline -bash-completion -doc -lapack -minimal -threads -tk" 0 kB
[ebuild   R    ] app-office/libreoffice-3.6.4.3  USE="branding cups dbus gnome gstreamer gtk java kde opengl postgres vba webdav (-aqua) -binfilter -binfilterdebug -eds -jemalloc -mysql -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" 0 kB


But it won't show packages which depend unconditionally on Java.
_________________
The Yggdrasil Genealogy Project
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum