Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema con le USE flags[RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Wed Jan 23, 2013 1:06 pm    Post subject: Problema con le USE flags[RISOLTO] Reply with quote

c'è qualcuno che mi puo dare una mano con questo problema che mi blocca l'aggiornamento
Code:
Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=media-gfx/sane-backends-1.0.20" has unmet requirements.
- media-gfx/sane-backends-1.0.23::gentoo USE="ipv6 (multilib) usb -avahi -doc -gphoto2 -threads -v4l -xinetd" SANE_BACKENDS="abaton agfafocus apple artec artec_eplus48u as6e avision bh canon canon630u canon_dr canon_pp cardscan coolscan coolscan2 coolscan3 dc210 dc240 dc25 dell1600n_net dmc epjitsu epson epson2 fujitsu genesys gt68xx hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s hs2p (ibm) kodak kodakaio kvs1025 kvs20xx kvs40xx leo lexmark ma1509 magicolor matsushita microtek microtek2 mustek mustek_pp mustek_usb mustek_usb2 nec net niash p5 pie pixma plustek plustek_pp qcam ricoh rts8891 s9036 sceptre sharp sm3600 sm3840 snapscan sp15c st400 stv680 tamarack teco1 teco2 teco3 test u12 umax umax1220u umax_pp xerox_mfp -pnm"

  The following REQUIRED_USE flag constraints are unsatisfied:
    sane_backends_mustek_usb2? ( threads ) sane_backends_kvs40xx? ( threads )

(dependency required by "media-gfx/simple-scan-3.4.2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Last edited by Massimog on Thu Jan 24, 2013 11:37 am; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 290
Location: Italy

PostPosted: Wed Jan 23, 2013 3:10 pm    Post subject: Reply with quote

Sembra che per attivare mustek_usb2 o anche kvs40xx nei SANE_BACKENDS sia necessario attivare la USE threads.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2909
Location: Parma (Italy)

PostPosted: Wed Jan 23, 2013 3:11 pm    Post subject: Reply with quote

portage wrote:
The following REQUIRED_USE flag constraints are unsatisfied:
sane_backends_mustek_usb2? ( threads ) sane_backends_kvs40xx? ( threads )


volendo attivare quei due supporti (mustek_usb2 e kvs40xx) bisogna attivare la use threads per sane-backends.

vedi tu se ti servono oppure no e decidi di conseguenza.

p.s. in un sistema moderno mi sembra molto strano che la use threads sia disattivata, sicuro di avere fatto una scelta consapevole (e saggia) a riguardo?
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Massimog
Tux's lil' helper
Tux's lil' helper


Joined: 04 Nov 2011
Posts: 106
Location: Osimo(AN)

PostPosted: Thu Jan 24, 2013 11:36 am    Post subject: Reply with quote

ho inserito threads in make.conf e funziona, anche se non so perche non c'era
grazie
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 444

PostPosted: Thu Jan 24, 2013 2:50 pm    Post subject: Reply with quote

È normale che non ci sia, dovrebbero averla di predefinito i programmi che ne fanno buon uso. Per esempio se compili dev-lang/tcl con threads alla fine ti dà un warning.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum