Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[MySQL] impossible de démarrer Mysql [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
256JMaN
n00b
n00b


Joined: 20 May 2006
Posts: 36

PostPosted: Wed Jan 23, 2013 12:20 pm    Post subject: [MySQL] impossible de démarrer Mysql [resolu] Reply with quote

Bonjour a tous ! (et bonne année au passage :-))

Je viens vers vous car depuis quelques jours je constate une bizarrerie, surement due a une modification hasardeuse de ma part sur mon serveur Gentoo.

Après un uptime d'une 60aines de jours, constatant des dysfonctionnement sur mon système (le fichier pid de munin qui se créer n'importe ou et le script init qui n'arrive pas a le retrouver), j'ai redémarré mon serveur. Et la je constate que Mysql ne veux pas démarrer, voici l'erreur :

Code:
root@SRV-MASTER ~ # /etc/init.d/mysql start
 * Starting mysql ...
mkdir: impossible de créer le répertoire « @GENTOO_PORTAGE_EPREFIX@/var/run/mysqld »: Aucun fichier ou dossier de ce type
 * Directory @GENTOO_PORTAGE_EPREFIX@/var/run/mysqld for pidfile does not exist and cannot be created
 * ERROR: mysql failed to start
root@SRV-MASTER ~ #

et la partie de mon fichier my.cnf ou je retrouve cette variable :
Code:

[mysqld]
character-set-server            = utf8
user                                            = mysql
port                                            = 3306
socket                                          = @GENTOO_PORTAGE_EPREFIX@/var/run/mysqld/mysqld.sock
pid-file                                        = @GENTOO_PORTAGE_EPREFIX@/var/run/mysqld/mysqld.pid
log-error                                       = @GENTOO_PORTAGE_EPREFIX@/var/log/mysql/mysqld.err
basedir                                         = @GENTOO_PORTAGE_EPREFIX@/usr
datadir                                         = /var/lib/mysql
skip-external-locking
key_buffer                                      = 16M
max_allowed_packet                      = 1M
table_open_cache                        = 64
sort_buffer_size                        = 512K
net_buffer_length                       = 8K
read_buffer_size                        = 256K
read_rnd_buffer_size            = 512K
myisam_sort_buffer_size         = 8M
language                                        = @GENTOO_PORTAGE_EPREFIX@/usr/share/mysql/english



Bien-sur, je pense qu'en éditant ce fichier j'arriverais a démarrer MySQL, mais j'imagine que l'incompréhension de cette variable est la source de mon problème avec munin et peut être d'autres problèmes que je n'ai pas encore découvert

Je ne sais pas si j'ai raté quelque chose (une modification a faire sur mon système après un upgrade) ou si par mégarde j'ai supprimé un fichier qui permet au système de comprendre cette variable, en tout cas je n'arrive pas a rectifier cette erreur ...

voici mon PATH

Code:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.6.3:/opt/nvidia-cg-toolkit/bin:/var/qmail/bin


Peut être que cela vous sera utile


Last edited by 256JMaN on Wed Jan 23, 2013 3:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5474
Location: ~Brussels - Belgique

PostPosted: Wed Jan 23, 2013 2:34 pm    Post subject: Reply with quote

Bonjour,

Es-tu en "prefix" ou une "vraie Gentoo native" ?
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5474
Location: ~Brussels - Belgique

PostPosted: Wed Jan 23, 2013 2:36 pm    Post subject: Reply with quote

Topic 948592 (solved)

En gros, tu édites my.cnf en enlevant ce @GENTOO_PORTAGE_EPREFIX
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
256JMaN
n00b
n00b


Joined: 20 May 2006
Posts: 36

PostPosted: Wed Jan 23, 2013 3:56 pm    Post subject: Reply with quote

Merci de ta réponse.
Désolé j'ai ouvert ce sujet pour rien, apres avoir ecris ce sujet je me suis dit que je n'avais pas essayé de bouger mon répertoire /etc/mysql en /etc/mysql.old et lancer un emerge mysql ... et bingo ! mysql redémarre a nouveau et le fichier my.cnf ne contient plus ces variable.

Donc ta solution est la bonne et plus rapide que ce que j'ai fait ;-)

je ne comprend pas trop comment c'est arrivé, mauis tout fonctionne maintenant !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum