Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
masked by eapi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 235

PostPosted: Tue Jan 22, 2013 4:35 am    Post subject: masked by eapi Reply with quote

hi,
What I should say in /etc/make.conf to enable this mask?
Code:
!!! All ebuilds that could satisfy "gnome-base/gconf" have been masked.
!!! One of the following masked packages is required to complete your request:
- gnome-base/gconf-3.2.5::gentoo (masked by: EAPI 5)
- gnome-base/gconf-2.32.4::gentoo (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1470

PostPosted: Tue Jan 22, 2013 4:56 am    Post subject: Re: masked by eapi Reply with quote

syn0ptik wrote:
The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.[/code]


Try Doing
Code:
emerge -1v portage

_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 235

PostPosted: Tue Jan 22, 2013 5:33 am    Post subject: Reply with quote

no, that's wrong I loose one option in make.conf after delete :(
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1478
Location: St. Wendel

PostPosted: Tue Jan 22, 2013 8:52 am    Post subject: Reply with quote

Simple as that, you can not install a package with higher EAPI then your portage supports.

Which function do you fear to loose?

Py
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 235

PostPosted: Tue Jan 22, 2013 9:54 am    Post subject: Reply with quote

Quote:
Simple as that, you can not install a package with higher EAPI then your portage supports.

yes, I need syntax where ever I can adjust eapi for necessary level.
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1478
Location: St. Wendel

PostPosted: Tue Jan 22, 2013 10:04 am    Post subject: Reply with quote

Again, there ist not such a Syntax.
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2363
Location: UK

PostPosted: Tue Jan 22, 2013 7:19 pm    Post subject: Reply with quote

syn0ptik wrote:
Quote:
Simple as that, you can not install a package with higher EAPI then your portage supports.

yes, I need syntax where ever I can adjust eapi for necessary level.

It's easy: just create a local overlay, then rewrite every ebuild you want to install via that obsolete portage version you insist on using. Should be no problem for someone with such special requirements; here's TFM to get you started.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 235

PostPosted: Wed Jan 23, 2013 12:00 am    Post subject: Reply with quote

it's not bash related programming. It should be pointed in one place, I forgive where.
But I found this...
after i made
Code:
#eselect profile set 13
#cat /etc/portage/make.profile/eapi
5
#emerge -vap gnome-base/gconf
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/default/linux/amd64/13.0/eapi'
!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.


Code:
after it goes
eselect profile set 4
cat /etc/portage/make.profile/eapi
2

and it goes as in first post

if I change it by myself it not permit installing anyway.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7774
Location: Somewhere over Atlanta, Georgia

PostPosted: Wed Jan 23, 2013 12:52 am    Post subject: Reply with quote

Please post the output of
Code:
emerge --version
- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 235

PostPosted: Wed Jan 23, 2013 6:07 am    Post subject: Reply with quote

it's new stage 20120614 and frash portages tree after sync.
Code:
# emerge --version
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3,glibc-2.15-r3, 2.6.38 x86_64)

p.s. for admins
as I post here...
http://forums.gentoo.org/viewtopic-t-948336-highlight-.html
in the last stage,I can't ran initr.d scripts.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9011
Location: beyond the rim

PostPosted: Wed Jan 23, 2013 7:55 am    Post subject: Reply with quote

As has been said already, this is NOT a configuration or bash issue. Your installed version of sys-apps/portage simply cannot work with ebuilds using EAPI-5. Solution: Install a version of sys-apps/portage that does support EAPI-5. Modifying random files will only cause new problems as you have seen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum