Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Lipcap and JVM privilege errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tuxtor
n00b
n00b


Joined: 22 Apr 2007
Posts: 41
Location: Guatemala

PostPosted: Sun Jan 06, 2013 7:26 am    Post subject: [SOLVED] Lipcap and JVM privilege errors Reply with quote

Hi people, currently I'm developing a java app using libpcap through a wrapper (jnetpcap), my application is fine, however I'm not able to run it from the IDE (netbeans) because I need root privileges. Otherwise I got a Java error: 255 from the JVM.

Is there any UNIX group with more elevated privileges to do this? Running the IDE as root seems to work, however I'm not feeling comfortable with this and I need some configurations from my normal user session.


Last edited by tuxtor on Mon Jan 21, 2013 3:55 am; edited 1 time in total
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 420

PostPosted: Sun Jan 06, 2013 9:09 am    Post subject: Reply with quote

There a bug on Netbeans open for this with a workaround so you can run it with something like sudo.
Back to top
View user's profile Send private message
tuxtor
n00b
n00b


Joined: 22 Apr 2007
Posts: 41
Location: Guatemala

PostPosted: Mon Jan 21, 2013 3:53 am    Post subject: [SOLVED] Lipcap and JVM privilege errors Reply with quote

Yes, seems like the easiest solution is to run it as root.

Just for the record, there is another workarround using linux capabilities, it sounds a little bit dangerous but it worked for me

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7157699
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum