Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mate, Cinnamon and XFCE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
GSnake
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2012
Posts: 100
Location: Italy

PostPosted: Sat Jan 19, 2013 2:56 pm    Post subject: Mate, Cinnamon and XFCE Reply with quote

Hello guys I'd like to install Mate Cinnamon and XFCE. I currently use XFCE but I'd like to try the other two since I'm quite curious :-P

So I tried to do a classic emerge mate / cinnamon (for MATE I've added the mate-overlay first) but when I try to emerge cinnamon I've got this:
Code:
emerge cinnamon
Calculating dependencies... done!

The following keyword changes are necessary to proceed:
#required by cinnamon (argument)
=gnome-extra/cinnamon-1.6.7-r1 ~amd64

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.8.999[introspection]" has unmet requirements.
- net-misc/networkmanager-0.9.6.4::gentoo USE="bluetooth dhcpcd gnutls introspection (multilib) nss ppp wext -avahi -connection-sharing -dhclient -doc -modemmanager -resolvconf -systemd -vala -wimax"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-extra/cinnamon-1.6.7-r1[networkmanager]" [ebuild])
(dependency required by "cinnamon" [argument])


Why can I have either nss or gnutls?
Back to top
View user's profile Send private message
Stinky_Foot
n00b
n00b


Joined: 31 Jul 2012
Posts: 27
Location: Piauí, Brazil

PostPosted: Sat Jan 19, 2013 3:17 pm    Post subject: Reply with quote

I think that you can have both, but what emerge says is that you may put as an USE flag at least one of those, no?
Back to top
View user's profile Send private message
GSnake
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2012
Posts: 100
Location: Italy

PostPosted: Sat Jan 19, 2013 3:28 pm    Post subject: Reply with quote

Ahhh so I can maintain them both BUT I have to compile them with one of those two options... right?

EDIT: Solved with USE="nss -gnutls" emerge cinnamon but... I get blocked packages.
Code:
USE="nss -gnutls" emerge --autounmask-write cinnamon
Calculating dependencies... done!
[ebuild  N     ] dev-python/python-exec-0.1.1  PYTHON_TARGETS="(jython2_5) (pypy1_9) (pypy2_0) (python2_5) (python2_6) (python2_7) (python3_1) (python3_2) (-pypy1_8) (-python3_3)"
[ebuild  N     ] dev-libs/libdaemon-0.14-r1  USE="-doc -examples -static-libs"
[ebuild  N     ] sys-auth/nss-myhostname-0.3
[ebuild  N     ] dev-libs/libical-0.48  USE="-examples"
[ebuild     U ~] dev-libs/gobject-introspection-common-1.34.2 [1.32.1]
[ebuild  N     ] net-misc/mobile-broadband-provider-info-20120614
[ebuild  N     ] dev-libs/vala-common-0.18.0
[ebuild  N     ] dev-libs/libksba-1.2.0  USE="-static-libs"
[ebuild  N     ] dev-libs/libassuan-2.0.3  USE="-static-libs"
[ebuild  NS    ] app-text/docbook-sgml-dtd-4.1-r3 [3.0-r3]
[ebuild  NS    ] app-text/docbook-sgml-dtd-3.1-r3 [3.0-r3]
[ebuild  NS    ] app-text/docbook-sgml-dtd-4.0-r3 [3.0-r3]
[ebuild  N     ] app-text/docbook-xml-simple-dtd-4.1.2.4-r2
[ebuild  N     ] dev-libs/pth-2.0.7-r3  USE="-debug -static-libs"
[ebuild  N     ] app-crypt/p11-kit-0.13  USE="-debug"
[ebuild  N     ] media-fonts/cantarell-0.0.9  USE="X"
[ebuild  N    ~] dev-libs/libpwquality-1.2.0-r2  USE="pam -python -static-libs" PYTHON_TARGETS="python2_7"
[ebuild     U  ] sys-apps/hwids-20130114 [20121119] USE="udev%*"
[ebuild  N     ] dev-perl/SGMLSpm-1.03-r6
[ebuild  N     ] sys-libs/libcap-ng-0.6.6  USE="-python -static-libs"
[ebuild  N     ] app-admin/eselect-pinentry-0.3
[ebuild  N     ] app-text/docbook-xml-simple-dtd-1.0-r1
[ebuild  N     ] dev-python/pycurl-7.19.0-r1  USE="ssl -examples" CURL_SSL="openssl -gnutls -nss"
[ebuild     U ~] dev-libs/atk-2.6.0 [2.4.0]
[ebuild  N     ] app-crypt/pinentry-0.8.2  USE="ncurses -caps -gtk -qt4 -static"
[ebuild  N     ] dev-libs/json-glib-0.14.2  USE="introspection -debug"
[ebuild     U ~] gnome-base/gsettings-desktop-schemas-3.6.1 [3.4.2]
[ebuild  N    ~] app-accessibility/at-spi2-core-2.6.3  USE="introspection"
[ebuild  N     ] dev-lang/vala-0.18.0  USE="vapigen {-test}"
[ebuild  N     ] app-crypt/gnupg-2.0.19  USE="bzip2 nls readline -adns -doc -ldap (-selinux) -smartcard -static -usb"
[ebuild  N     ] net-libs/rest-0.7.12  USE="introspection -doc -gnome {-test}"
[ebuild  N    ~] dev-libs/libgee-0.8.3  USE="introspection"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.2-r2 [4.1.2-r6, 4.3-r1, 4.4-r2]
[ebuild  N    ~] app-accessibility/at-spi2-atk-2.6.2  USE="{-test}"
[ebuild     U ~] dev-libs/glib-2.34.3 [2.32.4-r1]
[ebuild  N     ] x11-apps/mesa-progs-8.0.1
[ebuild  N     ] dev-python/imaging-1.1.7-r1  USE="X -doc -examples -lcms -scanner -tk"
[ebuild  N     ] app-text/docbook-sgml-utils-0.6.14-r1  USE="-jadetex"
[ebuild  N     ] app-text/xmlto-0.0.24-r1  USE="-latex"
[ebuild  N     ] x11-themes/gnome-icon-theme-symbolic-3.4.0
[ebuild     U ~] dev-libs/gobject-introspection-1.34.2-r1 [1.32.1] PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*"
[ebuild  N    ~] media-libs/cogl-1.12.2  USE="introspection opengl pango -debug -doc -examples -gles2 {-test}"
[ebuild  N    ~] dev-libs/gjs-1.34.0  USE="-examples {-test}"
[ebuild  N    ~] media-libs/clutter-1.12.2  USE="introspection -debug -doc -gtk {-test}"
[ebuild     U ~] dev-python/dbus-python-1.1.1-r1 [1.1.1] PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% (-python3_3)"
[ebuild     U ~] dev-python/pycairo-1.10.0-r4 [1.10.0-r2] USE="-xcb%" PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)"
[ebuild  N     ] dev-python/beautifulsoup-4.1.3  USE="-doc {-test}"
[ebuild     U  ] dev-util/gdbus-codegen-2.32.4 [2.30.3] PYTHON_TARGETS="python2_7%* python3_2%* -python2_5% -python2_6% -python3_1%"
[ebuild     U ~] dev-python/pygobject-3.4.2-r1 [3.2.2] PYTHON_TARGETS="python2_7%* python3_2%* -python2_6% -python3_1% (-python3_3)"
[ebuild  N     ] dev-python/lxml-2.3.4  USE="threads -doc -examples"
[ebuild  N    ~] dev-python/pyatspi-2.6.0-r1  PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3)"
[ebuild  N     ] dev-python/pycups-1.9.62  USE="-doc -examples"
[ebuild     U ~] x11-libs/gtk+-3.6.3-r2 [3.4.4] USE="-colord* (-egl)"
[ebuild  N     ] gnome-extra/zenity-2.32.1  USE="compat -debug -libnotify"
[uninstall     ] mate-extra/mate-dialogs-1.4.0
[blocks b      ] <=gnome-extra/zenity-2.32.1[compat] ("<=gnome-extra/zenity-2.32.1[compat]" is blocking mate-extra/mate-dialogs-1.4.0)
[ebuild  NS   ~] gnome-base/gnome-desktop-3.6.2 [2.32.1] USE="introspection -debug"
[ebuild  N    ~] gnome-base/gnome-menus-3.6.1-r2  USE="introspection python -debug {-test}" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U ~] gnome-base/libgnomekbd-3.6.0 [2.32.0-r1] USE="introspection%*"
[ebuild  N    ~] app-accessibility/caribou-0.4.6  PYTHON_TARGETS="python2_7 -python2_6"
[ebuild  NS    ] x11-libs/vte-0.32.2 [0.28.2-r204] USE="introspection -debug -doc -glade"
[ebuild  NS    ] net-libs/webkit-gtk-1.8.3-r300 [1.8.3-r200] USE="geoloc gstreamer introspection jit webgl (-aqua) -coverage -debug -doc -spell {-test} -webkit2"
[ebuild  N    ~] gnome-extra/nemo-1.1.2  USE="introspection -exif (-packagekit) {-test} -tracker -xmp"
[ebuild  N    ~] app-crypt/gcr-3.6.2  USE="introspection -debug {-test}"
[ebuild     U ~] gnome-base/gnome-keyring-3.6.2 [2.32.1-r1] USE="caps%* (-selinux)"
[blocks b      ] <gnome-base/gnome-keyring-3.3 ("<gnome-base/gnome-keyring-3.3" is blocking app-crypt/gcr-3.6.2)
[ebuild     U ~] gnome-base/libgnome-keyring-3.6.0 [2.32.0] USE="introspection%* -vala%"
[ebuild  N    ~] app-crypt/libsecret-0.12  USE="crypt introspection -debug {-test} -vala"
[ebuild  N    ~] net-libs/gnome-online-accounts-3.6.2  USE="introspection -debug -gnome -kerberos"
[ebuild  N     ] net-wireless/bluez-4.101-r5  USE="alsa consolekit cups readline -debug -gstreamer -pcmcia (-selinux) -test-programs -usb" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild  N     ] net-print/cups-pk-helper-0.2.4
[ebuild  N     ] app-admin/system-config-printer-common-1.3.11-r1  USE="policykit -doc"
[ebuild  N    ~] net-misc/networkmanager-0.9.6.4  USE="bluetooth dhcpcd introspection nss ppp wext -avahi -connection-sharing -dhclient -doc -gnutls -modemmanager -resolvconf -systemd -vala -wimax"
[ebuild  N    ~] app-i18n/ibus-1.4.99.20121006  USE="X gconf gtk3 introspection nls python -dconf -deprecated -gtk {-test} -vala"
[ebuild  N    ~] app-admin/openrc-settingsd-1.0.1  USE="-systemd"
[ebuild  N     ] app-admin/system-config-printer-gnome-1.3.11  USE="-gnome-keyring" LINGUAS="it -ar -as -bg -bn -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -fa -fi -fr -gu -he -hi -hr -hu -hy -id -is -ja -ka -kn -ko -lo -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sr@latin -sv -ta -te -th -tr -uk -vi -zh_CN -zh_TW"
[ebuild  N     ] x11-libs/colord-gtk-0.1.24  USE="introspection -doc -vala"
[ebuild  N     ] net-libs/libsocialweb-0.25.21  USE="introspection networkmanager -connman -gnome -vala"
[ebuild  N     ] app-mobilephone/obexd-0.46  USE="-eds -nokia -server -usb"
[ebuild  N    ~] net-wireless/gnome-bluetooth-3.6.1  USE="introspection -debug -sendto"
[ebuild  N     ] gnome-extra/nm-applet-0.9.4.1  USE="bluetooth"
[ebuild     U ~] gnome-base/gnome-settings-daemon-3.6.3 [2.32.1-r2] USE="colord%* cups%* i18n%* short-touchpad-timeout%* udev%* (-packagekit) -systemd% {-test%} -wacom%"
[ebuild  N    ~] x11-wm/muffin-1.1.2  USE="introspection {-test} -xinerama"
[ebuild  N    ~] gnome-extra/gnome-color-manager-3.6.0  USE="-clutter (-packagekit) -raw"
[ebuild  N    ~] gnome-base/gnome-session-3.6.2  USE="ipv6 -debug -doc -gconf -systemd"
[ebuild  N    ~] gnome-base/gnome-control-center-3.6.3-r1  USE="bluetooth colord cups gnome-online-accounts i18n networkmanager socialweb -debug -kerberos -systemd -v4l -wacom"
[ebuild  N    ~] gnome-extra/cinnamon-1.6.7-r1  USE="bluetooth networkmanager" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[blocks B      ] <x11-misc/colord-0.1.22 ("<x11-misc/colord-0.1.22" is blocking x11-libs/colord-gtk-0.1.24)
[blocks B      ] <gnome-base/gdm-2.91.94 ("<gnome-base/gdm-2.91.94" is blocking gnome-base/gnome-control-center-3.6.3-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)

  (dev-libs/glib-2.34.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.34.1:2 required by (dev-libs/gobject-introspection-1.34.2-r1::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

dev-libs/gobject-introspection:0

  (dev-libs/gobject-introspection-1.32.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/gobject-introspection-1.34.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

gnome-base/gsettings-desktop-schemas:0

  (gnome-base/gsettings-desktop-schemas-3.6.1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gsettings-desktop-schemas-3.5.91 required by (gnome-base/gnome-desktop-3.6.2::gentoo, ebuild scheduled for merge)
    (and 2 more with the same problem)

  (gnome-base/gsettings-desktop-schemas-3.4.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/gtk+:3

  (x11-libs/gtk+-3.6.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.5.13:3 required by (gnome-base/gnome-control-center-3.6.3-r1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (x11-libs/gtk+-3.4.4::gentoo, installed) pulled in by
    <x11-libs/gtk+-3.5:3 required by (x11-themes/gnome-themes-standard-3.4.2::gentoo, installed)

gnome-base/libgnome-keyring:0

  (gnome-base/libgnome-keyring-2.32.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (gnome-base/libgnome-keyring-3.6.0::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/libgnome-keyring-3.1.92 required by (gnome-base/gnome-keyring-3.6.2::gentoo, ebuild scheduled for merge)

dev-util/gdbus-codegen:0

  (dev-util/gdbus-codegen-2.32.4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-util/gdbus-codegen-2.31.0 required by (gnome-extra/nemo-1.1.2::gentoo, ebuild scheduled for merge)

  (dev-util/gdbus-codegen-2.30.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
OldTango
Guru
Guru


Joined: 21 Feb 2004
Posts: 497

PostPosted: Sun Feb 03, 2013 6:06 pm    Post subject: Re: Mate, Cinnamon and XFCE Reply with quote

GSnake wrote:
Hello guys I'd like to install Mate Cinnamon and XFCE. I currently use XFCE but I'd like to try the other two since I'm quite curious :-P

You could continue to emerge both Mate and Cinnamon and maintain the overlays as necessary. However resolving the slot conflicts might be difficult seeing that both Mate and Cinnamon are forks of completely different versions of Gnome. If you simply want to install them for testing purposes, you could install virtualbox and use it to install them and when your done simply remove them through virtualbox. Then you won't have to worry about the slot conflicts which would seem inevitable . Sorry I can't help you with the slot issue as the only machine I have for testing won't run Gnome3 without locking up the desktop every 5 minutes.

Linux Mint has all the options you are looking to test HERE. Just download the iso's and use virtualbox to run and install them.

I have installed for testing

Ubuntu-12.04 (Unity) I really dislike it. It seems to be designed more for a touch screen or a tablet, not a true desktop PC or Workstation.
Linux Mint (Mate) Has a nice look and feel much more like what I prefer to use.
Linux Mint (Xfce) Also a very nice look and feel. One I am seriously considering as a replacement for Gnome.
Linux Mint (Cinnamon) Much better than Gnome3 but it still has a lot of unnecessary crap and is difficult to work with.
Fedora18 (Default Gnome3) Looks nice, new and fresh but so far completely useless for my needs and purposes.

These are my personal opinions based on my likes, dislikes and computing needs. Everyone has their own opinions and should make their decisions based on what best meets their personal needs. Thats the Gentoo way right? :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum