Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amd k7 5700 trinity 7660 hd graphics driver [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1342
Location: indiana

PostPosted: Wed Jan 16, 2013 8:38 am    Post subject: amd k7 5700 trinity 7660 hd graphics driver [solved] Reply with quote

hi there,

having problems running the latest amd apu.

i tried with ati-drivers, modprobe fglrx gives no errors, but Xorg just starts with a blank screen.

then i tried "radeon" as video card but Xorg complains the card is not beeing supported.

maybe someone has a hint on how to get it running or how to trigger the problem ...


thanks a lot in advance for any suggestion regarding the issue!
_________________
I do not have a Superman complex, for I am God not Superman :D


Last edited by Mgiese on Sun Feb 03, 2013 7:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4958

PostPosted: Wed Jan 16, 2013 11:46 am    Post subject: Reply with quote

have you ran:
Code:
rm /etc/X11/xorg.conf
aticonfig --initial

?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4745
Location: Saint Amant, Acadiana

PostPosted: Wed Jan 16, 2013 12:04 pm    Post subject: Reply with quote

Black screen with no errors usually means X is happily running with no app started on top of it.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1342
Location: indiana

PostPosted: Thu Jan 17, 2013 3:12 am    Post subject: Reply with quote

Jaglover wrote:
Black screen with no errors usually means X is happily running with no app started on top of it.


i doubt that very much, since the whole pc hangs, i can not switch consoles nor can i do anything.
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4745
Location: Saint Amant, Acadiana

PostPosted: Thu Jan 17, 2013 11:10 am    Post subject: Reply with quote

The "hang" is very possible if input is misconfigured. Xorg tries to use evdev and drops keyboard and mouse. Look at your Xorg log to see if this is happening.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1342
Location: indiana

PostPosted: Sun Feb 03, 2013 7:10 pm    Post subject: Reply with quote

the pc does not hang as i mentioned ealier. i can switch to console and shutdown the system, but the screen (after xdm start) stays black with a non blinking curser.

i disabled radeon again, and did aticonfig --initial.

any more hints on that behaviour ?
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1342
Location: indiana

PostPosted: Sun Feb 03, 2013 7:26 pm    Post subject: Reply with quote

"eselect opengl set ati" did the trick.

thanks
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum