Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
overlay preference [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Tue Jan 15, 2013 6:26 pm    Post subject: overlay preference [SOLVED] Reply with quote

Hi,

there are old threads about this topic, I read them.
As it seems the situation changed lately, so I decided to start a new thread.
I am using portage 2.2 and have ACCEPT_KEYWORDS="amd64 ~amd64".

My goal is to be able to mask a package of a specified overlay.
Let's look at the following example:
Code:
$ eix -e less
[I] sys-apps/less
     Available versions:  436 441 (~)443 444 (~)445 (~)445-r1 (~)449 (~)450 451 (~)456 (~)457 (~)457[1] {+less-select +lesspipe original-gentoo pcre source unicode}
     Installed versions:  457[1](04:58:38 PM 12/21/2012)(less-select lesspipe pcre unicode -original-gentoo -source)
     Homepage:            http://www.greenwoodsoftware.com/less/ https://github.com/vaeth/less-select
     Description:         Excellent text file viewer, optionally with additional selection feature

[1] "mv" /usr/portage/local/layman/mv
$

In this case the same version of the package lives in the main portage tree and in an overlay.
I would like to be able to emerge version 457 from the main portage tree.
How do i do that?

Thanks in advance.


Last edited by alex.blackbit on Tue Jan 15, 2013 8:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4349

PostPosted: Tue Jan 15, 2013 8:13 pm    Post subject: Reply with quote

You can use
/etc/portage/package.mask wrote:
sys-apps/less::mv

However, for this particular package you will get exactly the same result as with the main gentoo tree if you deselect the lesspipe and less-select useflags (which however means that you loose these two nice features: You will not even recognize that you have less-select if you do not use the newly added option/perl-script, and Wolfgang Friebel's lesspipe is much better than the gentoo default).
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Tue Jan 15, 2013 8:32 pm    Post subject: Reply with quote

Thanks for your answer mv.
This was a general request and i took less just as an example.
The ebuilds from your overlay are fine.
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Wed Jan 16, 2013 2:11 pm    Post subject: Reply with quote

wow, a fork of ... LESS!!

What does this less offer that default lacks to deserver a fork?

any screenies?
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 4349

PostPosted: Wed Jan 16, 2013 3:11 pm    Post subject: Reply with quote

_______0 wrote:
wow, a fork of ... LESS!!

It's not a fork, it is just an additional option -Y patched in (with less-select) and an alternative implementation of the lesspipe.sh script (which is not part of less anyway but only of the gentoo ebuild).

The point of the -Y option is to make things like the provided less-select script work: With this script you can interactively select items from a directory listing, thus allowing a similar working flow as with Midnight commander when needed.
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Wed Jan 16, 2013 7:18 pm    Post subject: Reply with quote

ah, mm... I'd prefer non-bloated less then.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum