Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Amarok can't play mp3 files [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
strider2003
Tux's lil' helper
Tux's lil' helper


Joined: 14 Sep 2003
Posts: 145
Location: Spain

PostPosted: Sat Jan 12, 2013 10:31 am    Post subject: Amarok can't play mp3 files [Solved] Reply with quote

I'm using Amarok-2.6.90 and I can't play mp3 files with it. Amarok gives no error message, and it does not crash, but still mp3 files cannot be played.

Mplayer or Xine are working fine, so I don't have even a clue of what's going on :(

This is my emerge --info:
Code:

Portage 2.1.11.31 (default/linux/x86/10.0, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo-20121024 i686)
=================================================================
System uname: Linux-3.5.7-gentoo-20121024-i686-AMD_Phenom-tm-_9550_Quad-Core_Processor-with-gentoo-2.1
Timestamp of tree: Sat, 12 Jan 2013 02:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.5.4-r4, 2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo luman betagarden java-overlay multimedia x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.3 google-talkplugin PUEL"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/luman /var/lib/layman/betagarden /var/lib/layman/java-overlay /usr/local/portage/layman/multimedia /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa apache2 berkdb bluetooth bzip2 cairo cdr cli clucene consolekit cracklib crypt cups cxx dbus dri dvd dvdr ffmpeg fortran gdbm gif gpm gtk iconv icu imagemagick ipv6 java jpeg kde kipi loop-aes melt modules mudflap mysql ncurses nls nptl nsplugin ogg opengl openmp pam pcre png policykit pppd qt3support qt4 readline samba sdl semantic-desktop session sql ssl svg tcpd threads udev unicode usb v4l v4l2 vhosts vorbis x264 x86 xine xml zlib" ALSA_CARDS="hda-intel atiixp" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport" LINGUAS="es_ES es en_GB de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by strider2003 on Wed Jan 16, 2013 6:15 pm; edited 2 times in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Tue Jan 15, 2013 2:07 pm    Post subject: Reply with quote

Was it previously playing files? If so, what changed?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
strider2003
Tux's lil' helper
Tux's lil' helper


Joined: 14 Sep 2003
Posts: 145
Location: Spain

PostPosted: Wed Jan 16, 2013 7:44 am    Post subject: Reply with quote

At some point, it did play files without problem. Unfortunately, I don't use Amarok two often, and I have updated my system many times since the last time that I used it, so I can't know which version were the last to work.

How can I make a fresh install of Amarok? Which data should I delete in my home?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Wed Jan 16, 2013 3:00 pm    Post subject: Reply with quote

There's probably a dir named "amarok" in your home dir somewhere. Might start with a dot, might be in ~/.config. If you have mlocate, updatedb and locate amarok | grep (your_user).
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
strider2003
Tux's lil' helper
Tux's lil' helper


Joined: 14 Sep 2003
Posts: 145
Location: Spain

PostPosted: Wed Jan 16, 2013 5:45 pm    Post subject: Reply with quote

I was wrong. It's mp3 files what Amarok can't play. So I guess that it must be missing some dependency, but I don't know which one, since there is no error, and I can play mp3 files with mplayer or xine.
Back to top
View user's profile Send private message
strider2003
Tux's lil' helper
Tux's lil' helper


Joined: 14 Sep 2003
Posts: 145
Location: Spain

PostPosted: Wed Jan 16, 2013 6:14 pm    Post subject: Reply with quote

I have found the problem: media-plugins/gst-plugins-mad was missing.

Why is this plugin not a dependency??
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Wed Jan 16, 2013 8:55 pm    Post subject: Reply with quote

I took a look at the ebuild. That is a good question. You should file a bug report describing what you did and see if they make an official change in the ebuild.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
strider2003
Tux's lil' helper
Tux's lil' helper


Joined: 14 Sep 2003
Posts: 145
Location: Spain

PostPosted: Wed Jan 16, 2013 9:44 pm    Post subject: Reply with quote

I think this was my fault, and not a bug.

"mp3" was not in my USE flags. After adding "mp3" to USE and running emerge -auDNv system, gst-plugins-meta pulls gst-plugins-mad.

So, if I want amarok to play mp3, I just need to put "mp3" as a USE flag, which does not seem illogical :oops:
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Thu Jan 17, 2013 12:25 am    Post subject: Reply with quote

Well, it's working, so blast away with them tunes. :)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum