Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Funtoo] Installation d'une carte NVIDIA
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Tue Jan 15, 2013 10:43 am    Post subject: [Funtoo] Installation d'une carte NVIDIA Reply with quote

Bonjour à tous !

Voilà j'ai un petit soucis à la compilation de cairo-dock. En fait je vois l'erreur et je saurais la réparer :
Code:
erreur: #error "Only <glib.h> can be included directly."


Mais le truc c'est que quand je vais modifier la ligne en question, et que je relance emerge, emerge m'écrase ma modification et du coup j'ai toujours cette erreur.
Alors j'aurais aimer savoir comment faire pour éviter qu'il ne me l'écrase ?

Merci beaucoup !

Et éventuellement, j'ai également installer tint2 sous OpenBox... mais la transparence ne fonctionne pas et je ne sais pas pourquoi, vous auriez des pistes ? Je tiens à préciser que ma carte graphique a été très bien installée.
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.


Last edited by Max la menace on Sat Feb 02, 2013 7:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5472
Location: ~Brussels - Belgique

PostPosted: Tue Jan 15, 2013 11:12 am    Post subject: Reply with quote

Bonjour,

Regarde sur le bugzilla s'il n'y a pas un patch.

Sinon, tu devras créer un patch, le mettre dans /etc/portage/patches (ou quelque chose du genre), voire adapter l'ebuild localement pour inclure ta modification.

autre possibilité : faire la modification, puis
Code:
FEATURES="keepwork" emerge trucmuche

_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Tue Jan 15, 2013 2:42 pm    Post subject: Reply with quote

Salut et merci pour la réponse ! J'ai utilisé FEATURES="keepwork" et ça marche nickel !

Mais j'ai là aussi un soucis de transparence. Ils disent d'activer le composite ou compiz. Personnellement j'ai une préférence pour compiz alors j'ai voulu l'installer mais les paquets se bloque :
Code:
[blocks B      ] x11-libs/libcompizconfig ("x11-libs/libcompizconfig" is blocking x11-wm/compiz-0.9.8.6)
[blocks B      ] x11-libs/compiz-bcop ("x11-libs/compiz-bcop" is blocking x11-wm/compiz-0.9.8.6)
[blocks B      ] x11-plugins/compiz-plugins-extra ("x11-plugins/compiz-plugins-extra" is blocking x11-wm/compiz-0.9.8.6)
[blocks B      ] x11-apps/ccsm ("x11-apps/ccsm" is blocking x11-wm/compiz-0.9.8.6)
[blocks B      ] x11-plugins/compiz-plugins-main ("x11-plugins/compiz-plugins-main" is blocking x11-wm/compiz-0.9.8.6)
[blocks B      ] dev-python/compizconfig-python ("dev-python/compizconfig-python" is blocking x11-wm/compiz-0.9.8.6)
[blocks B      ] x11-wm/compiz-fusion ("x11-wm/compiz-fusion" is blocking x11-wm/compiz-0.9.8.6)


Il y a une solution ou faut juste attendre que les développeurs règlent le problème ?
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5472
Location: ~Brussels - Belgique

PostPosted: Wed Jan 16, 2013 8:44 am    Post subject: Reply with quote

Rien à voir. Tu as un paquet installé qui en bloque d'autres. Ou une dépendance automatique qui bloque d'autres paquets.
Apparemment, compiz est bloqué par des paquets installés ou dépendances demandés.

Fais un emerge -avt pour voir l'ordre des dépendances.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Sat Jan 26, 2013 11:11 am    Post subject: Reply with quote

Bonjour,

Désolé de pas avoir répondu plus tôt, j'étais un peu charrette.

Alors j'ai fini par installé KDE avec Compiz, et tout marche nickel. Mais en fouillant un peu j'ai fais un :
Code:
eselect opengl list


Et il s'avère qu'il était sur :
Code:
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *


Donc j'ai changé pour qu'il aille sur nvidia vu que j'ai une carte nvidia et les drivers d'installé. Mais après un redémarrage, j'ai plus de d'accélération 3D.
Code:
# glxinfo           
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".


Alors que j'ai bien recompilé nvidia-drivers après xorg-server...

Et j'ai regardé dans ma configuration du noyau, le driver 'nouveau' n'est pas installé. Par contre j'ai pas de fichier /etc/X11/xorg.conf et quand j'essaie d'en configurer un ben j'ai plus X. Alors j'y comprends pas grand chose... si vous aviez une idée ?

D'avance merci !
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sat Jan 26, 2013 12:33 pm    Post subject: Reply with quote

Un petit /var/log/Xorg.0.log peut-être ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Sat Jan 26, 2013 1:54 pm    Post subject: Reply with quote

Ha oui j'y ai plus pensé !

J'ai gardé les erreurs histoire d'avoir que l'essentiel :
Code:
# less /var/log/Xorg.0.log |grep EE
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    16.298] Initializing built-in extension MIT-SCREEN-SAVER
[    16.900] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    16.901] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    16.943] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 418
Location: La Louviere (Belgique)

PostPosted: Sat Jan 26, 2013 6:31 pm    Post subject: Reply with quote

Bonsoir,

Le driver 'Nouveau' du kernel ne doit pas être utiliser si tu utilise le driver proprio de Nvidia.

Enlever du kernel les références a 'nouveau', voir si la partie AGP est utile via lsmod (si cette partie en module)
Dans la partie framebuffer, tu peux tout décocher, a moins d'en avoir besoin

Quel est ta config dans make.conf

Idéalement : VIDEO_CARDS="nvidia'
Pas oublier le INPUT_DEVICES="evdev"
Revoir l'install de Xorg-drivers : emerge -uDNav xorg-drivers

Si tu avais installé le driver nouveau (video_cards) avec xorg-drivers, tu vas devoir le déinstaller, vérifier les dépendances (emerge depclean/revdep-rebuild)

Dans xorg.conf, malgré tout mes essais, j'ai du créer un xorg.conf avec uniquement la définition de la carte vga, xorg ne détectant pas ou initialisant mal la carte sans l'indice du port pci.

Dès que possible je remet mon desktop en route pour donner plus d'info avec carte nvidia.
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Sat Jan 26, 2013 7:08 pm    Post subject: Reply with quote

Bonjour,

Dans le kernel, comme dis précédemment, je n'ai rien installé pour avoir "nouveau".
J'ai bien VIDEO_CARDS sur "nvidia" et comme depuis le début de l'installation je veux les pilotes propriétaires, j'ai rien mis pour avoir "nouveau". Donc Xorg et bel est bien compilé pour marcher avec "nvidia".

Et pour xorg.conf j'ai aucun fichier de configuration... ça fonctionne bien sans... à part que j'ai pas la 3D
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 229
Location: S.O. France

PostPosted: Sat Jan 26, 2013 7:48 pm    Post subject: Reply with quote

On peut avoir le log complet de /var/log/Xorg.0.log

Moi j'en étais resté a un xorg obligatoire avec nvidia proprio.
T'as testé avec un truc du genre

Code:

Section "Module"
        Load "glx"
EndSection
Section "Device"
        Identifier      "Device0"
        Driver          "nvidia"
        VendorName      "NVIDIA Corporation"
EndSection
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 418
Location: La Louviere (Belgique)

PostPosted: Sun Jan 27, 2013 7:47 am    Post subject: Reply with quote

Bonjour,

Une autre idée qui me vient, a chaque changement du kernel il faut recompiler le driver nvidia pour avoir le module nv .... peut-être bêtement ca.
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Wed Jan 30, 2013 2:11 pm    Post subject: Reply with quote

Je pense que le probleme vient bien de Xorg que je n'arrive pas a configurer. J'ai trafiquer des trucs et des machins et j'ai les erreurs qui semblent changer...

J'ai essaye en reinstallant les drivers nvidia apres avoir recompiler le noyaux, ca n'a rien change.

Code:
(EE) NVIDIA(0): Failed to assign any connected display devices to X screen 0
(EE) NVIDIA 0(): Failed initialization of X screen 0
Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 229
Location: S.O. France

PostPosted: Wed Jan 30, 2013 4:43 pm    Post subject: Reply with quote

On peut avoir lspci, emerge --info et xorg.conf.

T'as essayé nvidia-xconfig ?
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Wed Jan 30, 2013 6:19 pm    Post subject: Reply with quote

Et bien nvidia-xconfig n'existe plus apparemment...

lspci
Code:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
04:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)


emerge -- info
Code:
Portage 2.3.5-r5 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.6.3, glibc-2.15-r3, 3.7.4 x86_64)
=================================================================
System uname: Linux-3.7.4-x86_64-Intel-R-_Core-TM-_i3-2350M_CPU_@_2.30GHz-with-gentoo-2.2.0
Timestamp of tree: Sat, 26 Jan 2013 06:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1000
dev-lang/python:          2.7.3-r1000, 3.2.3-r1000
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2.0-r4
sys-apps/openrc:          0.10.2-r7
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.5-r1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=5.0 --with-bdeps y"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirrors.linuxant.fr/distfiles.gentoo.org/ http://gentoo.modulix.net/gentoo/ ftp://mirror.ovh.net/gentoo-distfiles/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j5 -l5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X acl acpi alsa amd64 apache2 apm berkdb bzip2 cairo cdr cracklib crypt ctype cups cxx dbus dri dvd dvdr dvdread flac gdbm gif gpm iconv icu ipv6 jpeg kde lame lm_sensors mad mmx modules mp3 mpeg mudflap multilib mysql ncurses nls nptl nvidia ogg opengl openmp pam pcre php pmu png policykit pppd python qt3support qt4 readline resolvconf session sse sse2 ssl tcpd tiff tokenizer truetype udev unicode vorbis wavpack xa xcomposite xml zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache
cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" PHP_TARGETS="php5-3" PYTHON_ABIS="2.7 3.2" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_
USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK


xorg.conf généré par Xorg -configure
Code:
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   Screen      2  "Screen2" RightOf "Screen1"
   Screen      3  "Screen3" RightOf "Screen2"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/misc/"
   FontPath     "/usr/share/fonts/TTF/"
   FontPath     "/usr/share/fonts/OTF/"
   FontPath     "/usr/share/fonts/Type1/"
   FontPath     "/usr/share/fonts/100dpi/"
   FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
   Load  "glx"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor1"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor2"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor3"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nvidia"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
   Identifier  "Card1"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
   Identifier  "Card2"
   Driver      "vesa"
   BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
   Identifier  "Card3"
   Driver      "vesa"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card1"
   Monitor    "Monitor1"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen2"
   Device     "Card2"
   Monitor    "Monitor2"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen3"
   Device     "Card3"
   Monitor    "Monitor3"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection


Et les paquets installés :
Code:
# eix -s nvidia
[I] media-video/nvidia-settings
     Available versions:  (~)173.14.31 260.19.29 (~)275.43 (~)290.10 295.20 (~)295.40 (~)302.11 304.60 (~)310.19 {examples}
     Installed versions:  310.19(16:51:04 24/01/2013)(-examples)
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA Linux X11 Settings Utility

[I] x11-drivers/nvidia-drivers
     Available versions:  96.43.20^s 96.43.23^s 173.14.35^s 173.14.36^s 295.71^s 295.75^s 304.60^s 304.64^s (~)310.19^s (~)313.18^s {+X acpi custom-cflags gtk multilib pax_kernel (+)tools KERNEL="FreeBSD linux"}
     Installed versions:  313.18^s(15:01:38 30/01/2013)(X acpi multilib tools -pax_kernel KERNEL="linux -FreeBSD")
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA X11 driver and GLX libraries


Code:
# eix -s xorg
[I] x11-base/xorg-drivers
     Available versions:  1.9 1.10 1.11 1.12 1.13 {INPUT_DEVICES="acecad aiptek elographics evdev fpit hyperpen joystick keyboard mouse mutouch penmount synaptics tslib vmmouse void wacom" VIDEO_CARDS="apm ark ast chips cirrus dummy epson fbdev fglrx geode glint i128 i740 impact intel mach64 mga modesetting neomagic newport nouveau nv nvidia omap omapfb qxl r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb sunbw2 suncg14 suncg3 suncg6 sunffb sunleo suntcx tdfx tga trident tseng v4l vesa via virtualbox vmware voodoo"}
     Installed versions:  1.13(15:01:57 30/01/2013)(INPUT_DEVICES="evdev -acecad -aiptek -elographics -fpit -hyperpen -joystick -keyboard -mouse -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="intel nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 -mach64 -mga -modesetting -neomagic -newport -nouveau -nv -omap -omapfb -qxl -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb -sunbw2 -suncg14 -suncg3 -suncg6 -sunffb -sunleo -suntcx -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware -voodoo")
     Homepage:            http://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers

[I] x11-base/xorg-server
     Available versions:  1.9.5-r1 1.10.6-r1 1.11.4-r1 1.12.4 1.13.1 (~)1.13.1.901 [M](~)1.13.99.901 {dmx doc ipv6 kdrive minimal nptl selinux static-libs +suid tslib +udev xnest xorg xvfb}
     Installed versions:  1.13.1.901(15:00:54 30/01/2013)(ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal -selinux -static-libs -tslib -xnest -xvfb)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers


Je continue de chercher de mon côté... mais si jamais vous avez une idée plus lumineuse que les mienne, faites moi signe !
Merci !
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 418
Location: La Louviere (Belgique)

PostPosted: Thu Jan 31, 2013 8:02 am    Post subject: Reply with quote

Bonjour,

Optimus .... aie pas la joie, de plus c'est une partie que je ne connais pas ...
Peut-être qu'avec le wiki http://wiki.gentoo.org/wiki/NVIDIA_Optimus_and_HDMI_Output_Configuration
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Sat Feb 02, 2013 7:11 pm    Post subject: Reply with quote

J'ai regardé ton lien! Ils partent du principe que la carte est déjà installée et qu'on veuille faire fonctionner les HDMI.
Ou alors j'ai loupé un épisode ! :p

J'vais tester avec les drivers sur le site de NVIDIA quand j'aurais le temps... peut-être que ça fonctionnera mieux. Je vous tiendrais au courant !
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 229
Location: S.O. France

PostPosted: Sat Feb 02, 2013 9:41 pm    Post subject: Reply with quote

Un petit peu de lecture je peux pas t'aider plus

http://en.gentoo-wiki.com/wiki/X.Org/nVidia_Optimus
https://github.com/Bumblebee-Project
Back to top
View user's profile Send private message
Max la menace
n00b
n00b


Joined: 23 Oct 2009
Posts: 59
Location: Montpellier (34)

PostPosted: Mon Feb 04, 2013 5:08 pm    Post subject: Reply with quote

Salut,

Merci sebB pour tes liens... je crois que ça fonctionne... je ne pensais pas que le fait que la technologie Optimus soit utilisée (en vrai je savais même pas qu'elle existait... :q) changeait à ce point la donne dans la configuration de la carte...

Je ferrais quelques essaies et je vous tiens au courant !
_________________
Dieu créa l'Homme ! Et l'Homme créa Linux.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum