Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] TV Karte wird gefunden, aber kein Device erstellt
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5347
Location: Langen (Hessen), Germany

PostPosted: Mon Jan 14, 2013 7:43 pm    Post subject: [Solved] TV Karte wird gefunden, aber kein Device erstellt Reply with quote

Hallo,

ich hab seit Jahren zwei TV-Karten eingebaut:
Win TV NOVA
Technisat SkyStar2 DVB

Seit gestern wird die Nova nicht mehr erkannt.

lspci zeigt beide dennoch an:
03:00.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
03:01.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)

Es wird einfach kein Device erstellt.
Ich habe einen neuen Kernel installiert, aber die Problematik bleibt.

Hat jemand eine Idee?
Wie könnte ich ausschließen, dass sie defekt ist?

Am System habe ich nichts gemacht...

Danke!
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Tue Jan 15, 2013 8:13 am; edited 1 time in total
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 557

PostPosted: Mon Jan 14, 2013 9:43 pm    Post subject: Re: TV Karte wird gefunden, aber kein Device erstellt Reply with quote

Hi
Finswimmer wrote:
Hallo,

ich hab seit Jahren zwei TV-Karten eingebaut:
Win TV NOVA
Technisat SkyStar2 DVB

Seit gestern wird die Nova nicht mehr erkannt.

lspci zeigt beide dennoch an:
03:00.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
03:01.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)

Es wird einfach kein Device erstellt.
Ich habe einen neuen Kernel installiert, aber die Problematik bleibt.

Hat jemand eine Idee?
Wie könnte ich ausschließen, dass sie defekt ist?

Am System habe ich nichts gemacht...

Danke!
Tobi

Ich würde mal auf ein Module Problem tippen. Laut Google scheint das bei der Karte öfter Problem geben.
Bin gerade über das Thread gestolpert vielleicht hilft das beim der Problem Eingrenzung.
http://www.linuxmintusers.de/index.php?topic=5740.0

MfG
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5347
Location: Langen (Hessen), Germany

PostPosted: Tue Jan 15, 2013 7:29 am    Post subject: Reply with quote

Da scheint es um einen speziellen Patch für diese Karte zu gehen.
Mich wundert, dass ich nichts an der Software geändert habe.
Ich hatte ein neues Mainboard eingebaut, aber danach ging alles: Extra über MythTV beide Karten getestet.

Und auf einmal will sie nicht...
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5347
Location: Langen (Hessen), Germany

PostPosted: Tue Jan 15, 2013 8:13 am    Post subject: Reply with quote

Komisch.
Unter Ubuntu ging die Karte mit dem Modul budget_ci.
Das hatte ich unter Gentoo nicht und auch mein alter Kernel nicht.

Nachdem ich das Modul nun für den neuen Kernel kompiliert habe, ging es einwandfrei.
Nun stelle ich mir die Frage, wie ich der Meinung sein konnte, dass
1. ich das Modul budget_ci nicht brauche
2. es im alten Kernel nicht aktiviert war
und
3. ich nichts geändert habe...?!

Fragen über Fragen.

Aber gut...
Nun gehts wieder :)
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 557

PostPosted: Tue Jan 15, 2013 9:07 am    Post subject: Reply with quote

Hi
Finswimmer wrote:
Komisch.
Unter Ubuntu ging die Karte mit dem Modul budget_ci.
Das hatte ich unter Gentoo nicht und auch mein alter Kernel nicht.

Nachdem ich das Modul nun für den neuen Kernel kompiliert habe, ging es einwandfrei.
Nun stelle ich mir die Frage, wie ich der Meinung sein konnte, dass
1. ich das Modul budget_ci nicht brauche
2. es im alten Kernel nicht aktiviert war
und
3. ich nichts geändert habe...?!

Fragen über Fragen.

Aber gut...
Nun gehts wieder :)

Das ist in Linux so ne sachem mit den dvb Treibern. Habe hier so eine Hybrid Stick. Entweder hat sich der Treiber Entwickler und die Kernel
Entwickler in den Köpfen, und eine Seite ist dann erst einmal beleidigt...
Plötzlich heisst der Treiber dann anders bis er dann auf einmal überhaupt nicht mehr im Kernel ist und zum guten Schluss der Treiber Entwickler
die entwicklung ganz einstellt, und man sich den Patch nun bei anderen dist suchen muss die den Stick noch unterstützen. Und da sage noch
mal einer Linux ist nicht Benutzer freundlich, vor allen dinge weil ich vor dem Kauf extra noch geschaut habe welche dvb Hardware zu 100%
unterstützt wird... Der Stick ist übrigens ein Terratec Cinergy XS Hybrid den ich wohl wenn ich meine Media Box erneuern werde wegen mangels
Treiber entsorgen darf. In diesem Sinne.

Was ich eigentlich sagen wollte, kann ja möglich sein das der Treiber früher woanders "drin" war oder anders hiess, wie oben beschrieben kommt
das schon einmal vor.

MfG
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3782

PostPosted: Tue Jan 15, 2013 10:47 am    Post subject: Reply with quote

fuchur wrote:
Terratec Cinergy XS Hybrid

Einen Terratec CinergyStick (weiß nicht, ob es das selbe ist), habe ich vor ein paar Wochen ebenfalls gekauft, wegen der angeblich tollen Unterstützung. Hat aber (was natürlich von außen nicht zu erkennen war) eine andere USB-Nummer und benötigt einen ganz anderen Treiber; Patches kursieren im Internet für kernel 3.0, aber im kernel 3.1 wird er angeblich unterstützt - tatsächlich wird er auch angezeigt, und w_scan findet Kanäle, nur sobald ich etwas anschauen will, kommt eine dubiose Fehlermeldung und nichts passiert... allzu optimistisch bin ich aber nicht, dass sich da nur in den offiziellen Treiber ein Fehler eingeschlichen hat.
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 557

PostPosted: Tue Jan 15, 2013 2:39 pm    Post subject: Reply with quote

Hi
mv wrote:
fuchur wrote:
Terratec Cinergy XS Hybrid

Einen Terratec CinergyStick (weiß nicht, ob es das selbe ist), habe ich vor ein paar Wochen ebenfalls gekauft, wegen der angeblich tollen Unterstützung. Hat aber (was natürlich von außen nicht zu erkennen war) eine andere USB-Nummer und benötigt einen ganz anderen Treiber; Patches kursieren im Internet für kernel 3.0, aber im kernel 3.1 wird er angeblich unterstützt - tatsächlich wird er auch angezeigt, und w_scan findet Kanäle, nur sobald ich etwas anschauen will, kommt eine dubiose Fehlermeldung und nichts passiert... allzu optimistisch bin ich aber nicht, dass sich da nur in den offiziellen Treiber ein Fehler eingeschlichen hat.

Vielleicht hilft es dir weiter. Bei meinem Stick benötige ich das em28xx-dvb Module das habe ich aus dem Ubuntu deb em28xx-new. Ist aber schon mehrere
Jahre her. Da ich denn Stick aber nur auf meiner Media Box nutze habe ich aber seit dem nicht mehr probiert ob er sich auch mit dem einem aktuellen Kernel baue
lässt. Gehe mit der Box momentan nicht ins Netz und mache auch keine updates.
Wenn ich demnächst meinen Multimedia PC durch einen "Raspberry" ersetze (mein all in one Heimrouter/Server/proxy/usw. PC wurde schon Weihnachten durch
eine Raspberry ersetzt und läuft hervorragend, ach was sage ich traumhaft) werde ich den Stick auch ersetzen, aber dann mit Hardware die schon länger im Kernel
unterstützt wir, so eine pleite brauch ich nicht noch mal ...

MfG
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3782

PostPosted: Tue Jan 15, 2013 5:40 pm    Post subject: Reply with quote

fuchur wrote:
HBei meinem Stick benötige ich das em28xx-dvb Module das habe ich aus dem Ubuntu deb em28xx-new.

In kernel-3.7 gibt es ein Unterverzeichnis em28xx - ich vermute, die Unterstützung dürfte also inzwischen kein Problem mehr sein. Leider hat TerraTec anscheinend die Interna vollkommen ausgetauscht (natürlich ohne, dass das irgendwie auf der Packung sichtbar wäre...) und ich benötige nun einen ganz anderen Treiber (RTL28XXU); vielleicht mache ich aber auch irgendetwas grundsätzlich falsch - ich hatte noch nie dvbt auf Linux: Mein Problem samt genauer Fehlermeldung ist in diesem Thread genauer beschrieben.
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 557

PostPosted: Tue Jan 15, 2013 7:33 pm    Post subject: Reply with quote

Hi
mv wrote:
fuchur wrote:
HBei meinem Stick benötige ich das em28xx-dvb Module das habe ich aus dem Ubuntu deb em28xx-new.

In kernel-3.7 gibt es ein Unterverzeichnis em28xx - ich vermute, die Unterstützung dürfte also inzwischen kein Problem mehr sein.
...

Ja, das gibt es schon lange. Aber ich habe ein Hybrid Stick. Das Module em28xx ist nur für Analog. Ich benötige aber für dvb das Module
em28xx-dvb und das ist in meinem Kernel 3.5.XXX nicht vorhanden, hat sich das geändert?

Zu deinem Problem und Thread, das ein zigste was man noch mal Probieren sollte ist ob es von irgend einer aktuellen Live DVD funktioniert, gibt
ja genug die mit allem möglichen vollgepackt sind.

MfG
Back to top
View user's profile Send private message
mv
Advocate
Advocate


Joined: 20 Apr 2005
Posts: 3782

PostPosted: Tue Jan 15, 2013 7:38 pm    Post subject: Reply with quote

fuchur wrote:
Das Module em28xx ist nur für Analog. Ich benötige aber für dvb das Module
em28xx-dvb

head -n6 ./linux-3.7.1-hardened-r2/drivers/media/usb/em28xx/em28xx-dvb.c wrote:
/*
DVB device driver for em28xx

(c) 2008-2011 Mauro Carvalho Chehab <mchehab@infradead.org>

(c) 2008 Devin Heitmueller <devin.heitmueller@gmail.com>
Edit: make nconfig zeigt nach F8 auch, wo man "VIDEO_EM28XX_DVB" aktiviert.

Live-DVDs für kernel-3.7 gibt es wohl noch nicht allzu viele, und ich habe selber zum Testen auch schon Kernel gebacken, in denen ich alles aktiviert habe, von dem ich mir vorstellen könnte, dass vielleicht nur vergessen wurde, die Abhängigkeit einzutragen...

Noch'n Edit: Etwas beunruhigend ist aber, dass VIDEO_EM28XX_DVB nur von DVB_USB aber nicht von DVB_USB_V2 abhängt. Zwar gibt es Letzteres erst ab kernel-3.7, aber es könnte sein, dass das alte Framework irgendwann wie OSS oder das alte ATA-System quasi nicht mehr gepflegt wird und irgendwann herausfliegt. Andererseits gibt es etliche DVB1-Treiber, die wohl noch nicht im neuen Framework enthalten sind, und wie meine Erfahrung zeigt, ist dieses vielleicht ja noch gar nicht ausgereift genug (die Patches für kernel-3.6 im Internet scheinen noch nicht auf DVB_USB_V2 zu basieren).
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 557

PostPosted: Tue Jan 15, 2013 9:31 pm    Post subject: Reply with quote

Hi
mv wrote:
fuchur wrote:
Das Module em28xx ist nur für Analog. Ich benötige aber für dvb das Module
em28xx-dvb

head -n6 ./linux-3.7.1-hardened-r2/drivers/media/usb/em28xx/em28xx-dvb.c wrote:
/*
DVB device driver for em28xx

(c) 2008-2011 Mauro Carvalho Chehab <mchehab@infradead.org>

(c) 2008 Devin Heitmueller <devin.heitmueller@gmail.com>
Edit: make nconfig zeigt nach F8 auch, wo man "VIDEO_EM28XX_DVB" aktiviert.
...

Ich nimm immer "/" zum suchen. So, habe mich gerade noch einmal damit auseinander gesetzt. Meine info war falsch em28xx-dvb ist wohl schon länger
im Kernel bloss unterstützt der nicht meine Stick (kein Signal, gerade noch einmal probiert). Ich kann mich jetzt dunkel erinnern das ich da "rumpatchen"
oder per hg eine andere Quelle comelieren musste. Das erste Post in diesem Tread beschreibt die Problem mit dem Stick eigentlich:
http://forum.ubuntuusers.de/topic/em28xx-unter-maverick-2-6-/
Da kann auch noch etwas anderes gewesen sein, kriege das nicht mehr so genau auf die Reihe ist nämlich schon eine Zeit her, weiss aber noch dass das
ein richtiges Gefummel war, und darauf habe ich nun wirklich keine Lust mehr. Und die Probleme mit dem Stick sind erst aufgetreten als sich ein paar
Entwickler nicht einig geworden sind wer wem das Räppelchen weggenommen hat :(.

MfG
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum