Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drivers/xf86-video-neomagic - wrong dependency
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
venc
n00b
n00b


Joined: 28 May 2012
Posts: 7

PostPosted: Wed Dec 26, 2012 10:22 am    Post subject: x11-drivers/xf86-video-neomagic - wrong dependency Reply with quote

Hi there,

I have my old laptop equipped with Neomagic multimedia chipset. Now I can't upgrade X server because of bad dependency of neomagic x driver. Emerge stops with this message:
Code:

WARNING: One or more updates have been skipped due to a dependency conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.13.0-r1::gentoo, ebuild scheduled for merge) conflicts with
    <x11-base/xorg-server-1.12.99 required by (x11-drivers/xf86-video-neomagic-1.2.7::gentoo, installed)


It depends on both versions (1.12.4 and 1.13). See the dependency graph:
Code:

* dependency graph for x11-drivers/xf86-video-neomagic-1.2.7
 `--  x11-drivers/xf86-video-neomagic-1.2.7  x86
   `--  x11-base/xorg-server-1.12.4  (<x11-base/xorg-server-1.12.99) x86     <<<HERE<<
   `--  sys-devel/automake-1.11.6  (>=sys-devel/automake-1.11.1) x86
   `--  sys-devel/automake-1.12.6  (>=sys-devel/automake-1.12) [~x86 keyword]
   `--  sys-devel/autoconf-2.69  (>=sys-devel/autoconf-2.68) x86
   `--  sys-devel/libtool-2.4-r1  (sys-devel/libtool) x86
   `--  sys-devel/m4-1.4.16  (sys-devel/m4) x86
   `--  x11-misc/util-macros-1.17  (>=x11-misc/util-macros-1.17) x86
   `--  media-fonts/font-util-1.3.0  (>=media-fonts/font-util-1.2.0) x86
   `--  virtual/pkgconfig-0  (virtual/pkgconfig) x86
   `--  x11-proto/fontsproto-2.1.2  (x11-proto/fontsproto) x86
   `--  x11-proto/randrproto-1.4.0  (x11-proto/randrproto) x86
   `--  x11-proto/renderproto-0.11.1  (x11-proto/renderproto) x86
   `--  x11-proto/videoproto-2.3.1  (x11-proto/videoproto) x86
   `--  x11-proto/xextproto-7.2.1  (x11-proto/xextproto) x86
   `--  x11-proto/xineramaproto-1.2.1  (x11-proto/xineramaproto) x86
   `--  x11-proto/xproto-7.0.23-r1  (x11-proto/xproto) x86
   `--  x11-base/xorg-server-1.13.0-r1  (x11-base/xorg-server) x86  [xorg]     <<<AND HERE<<
   `--  x11-libs/libpciaccess-0.13.1  (x11-libs/libpciaccess) x86


I tried to solve it with masking either of those x server versions in /etc/portage/package.mask, but that didn't work. Shall I fill a bug in portage bug trace?

Thanks for any help
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1668
Location: Berlin, Germany

PostPosted: Thu Dec 27, 2012 9:54 am    Post subject: Reply with quote

Code:
 WARNING: One or more updates have been skipped due to a dependency conflict:
That is not a fatal error, just emerge says that xorg-server won't be upgraded. emerge will upgrade the other packages in your list.
Back to top
View user's profile Send private message
venc
n00b
n00b


Joined: 28 May 2012
Posts: 7

PostPosted: Tue Jan 15, 2013 7:31 am    Post subject: Reply with quote

I know that this state is not fatal, but why should I tolerate wrong dependency :?: I just want to know what's wrong and what can I do to make it better.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1668
Location: Berlin, Germany

PostPosted: Tue Jan 15, 2013 10:31 am    Post subject: Reply with quote

You cannot do anything but wait until a version for xf86-video-neomagic becomes available that works with xorg-server-1.13.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum