Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dm-crypt stuck at start and shutdown [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 332
Location: Belgium

PostPosted: Fri Jan 11, 2013 6:04 pm    Post subject: dm-crypt stuck at start and shutdown [SOLVED] Reply with quote

I've done a lot of update until my last reboot.

Now after typing my password in dm-crypt, I'm getting a message

bio: create slab <bio-1> at 1

Then dm-crypt is stuck until I press CTRL-C...


Same story at shutdown, the script is stuck when it tries to remove the dm-crypt mapping.

Any idea what could have caused that?
_________________
Olivier PELERIN


Last edited by OPelerin on Mon Jan 14, 2013 9:00 am; edited 1 time in total
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2458
Location: Germany

PostPosted: Sat Jan 12, 2013 3:04 pm    Post subject: Reply with quote

if you updated udev to 197, you need to re-emerge anything that has stuff in /usr/lib/udev (equery belongs /usr/lib/udev/ for a list)
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1952
Location: Poland

PostPosted: Sat Jan 12, 2013 7:11 pm    Post subject: Reply with quote

einfo for udev-197 is very, very cryptic on this subject. Good job I would say. Even I, a long time Gentoo user, got burned by it.
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 332
Location: Belgium

PostPosted: Mon Jan 14, 2013 9:00 am    Post subject: Reply with quote

that was it!. I'ts now working


Thanks!
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2458
Location: Germany

PostPosted: Mon Jan 14, 2013 10:04 pm    Post subject: Reply with quote

mbar wrote:
einfo for udev-197 is very, very cryptic on this subject. Good job I would say. Even I, a long time Gentoo user, got burned by it.


I got burned too. The problem was I didn't even get to see the einfo. I usually add --keep-going to my emerge world deep bdeps update, because there usually are failing packages which aren't really that important (e.g. currently timidity++ fails for me). 'sides, failing packages don't mean breakage, it just means I didn't get that particular update.

However the problem is that although emerge keeps going, it does not show einfo summary at the end from before the failure.

So I got the udev update, then timidity++ failed, emerge kept going, and didn't show me the udev einfo again.



A good package manager would've taken care of these updates by itself though. revdep-rebuild is bad enough (does not catch everything), but breaking udev and causing system hang. People who don't have Live CDs around (I have a dozen of em on my USB stick) can't easily recover.
Back to top
View user's profile Send private message
klz
n00b
n00b


Joined: 07 Jun 2011
Posts: 25

PostPosted: Mon Jun 03, 2013 6:33 pm    Post subject: Reply with quote

this (rebuilding the belongs of udev) also was the solution for me!

pfff, finally!!

I didnt see that step in the gentoo-udev-wiki-how-to-page or whatever it was
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum