Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Where is the gcc-4.7.0 thread?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Mon Jan 14, 2013 7:27 am    Post subject: Reply with quote

genstorm:
I am running firefox ~17.0.1 with -lto and gcc 4.7.1 I had problems then it
compiles fine only after I remove 170 packages! with an emerge --depclean then revdep-rebuild then python-updater.
revdep-rebuild only put 3 packages back.
It was related some old lib of firefox causing file collisions since it is no longer needed.
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Tue Jan 15, 2013 8:47 pm    Post subject: Reply with quote

But have you emerged firefox with custom-cflags enabled? Here it's definitely been no file collision, but the mentioned gcc-4.7 regression.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1234

PostPosted: Sun Jan 20, 2013 7:17 am    Post subject: Reply with quote

genstorm wrote:
Trying to make this the gcc-4.7 thread, here is a list of packages that currently don't build for me using gcc-4.7.2_pre9999, but are fine with 4.7.1:

Code:
app-emulation/virtualbox-{4.1.20-r1, 4.2.0_rc2}
sys-devel/dev86-{0.16.18, 0.16.19}

PS: I haven't tried to rebuild system let alone world, there's still a long list in the gcc-4.7 tracker, albeit just a very minimal overlap with my world file.

EDIT: Currently rebuilding `emerge -e @system` with gcc-4.7.2_pre9999 - all 539 packages built fine.

EDIT2: The virtualbox issue might be just some Makefile.kmk trouble with the gcc version detection


I just built a new 64 bit system no changes in my list however i added virtualbox
app-emulation/virtualbox-4.2.6 did not build with gcc 4.7.1 for me with lto on 64bit did not try on 32 bit yet.
Have you had any more luck with it since your post?
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Sun Jan 20, 2013 9:13 am    Post subject: Reply with quote

I don't have access to my laptop right now, but as far as I remember it only failed in configure due to the pre_9999 package. No trouble with 4.7.2 final and any of the >= 4.2.0 packages, also 64-bit.

EDIT: Yep, 4.2.6 just built fine using gcc-4.7.2 - maybe it would be worth a try to upgrade.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum