Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
megaraid_sas with Intel SRCSAS18E, kernel >2.6.31
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
thanny
n00b
n00b


Joined: 15 Aug 2005
Posts: 44

PostPosted: Sun Jan 13, 2013 10:41 am    Post subject: megaraid_sas with Intel SRCSAS18E, kernel >2.6.31 Reply with quote

One of my servers has a pair of Intel SRCSAS18E RAID controllers, and it has been running kernel 2.6.31 for quite some time. I decided to replace 320GB drives with 2TB drives, and planned on moving from jfs to either ext4 or xfs. To get the latest file system code, I emerged the sources for 3.6.11 and built that.

After a brand new ext4 volume failed to mount, I stripped away layers (lvm and software RAID) until I found something very peculiar. After formatting a partition, RAID device, or lvm volume with either ext4 or xfs, then immediately running fsck on it, the result was complete integrity failure. The first mount attempt would always fail. After it succeeded, attempts to write data to the file system, resulted in copious errors in the syslog.

After trying some different 3.6.11 kernel options to no avail, I rebooted the server back into 2.6.31 to try again. I had to rebuild it with GPT support, but after that, I was able to format a partition and get no errors afterwards. Recreated the software stripe of the two hardware arrays, added some lvm volumes, formatted them, and fsck reported no problems.

So I have to conclude that the megaraid_sas driver in 3.6.11 is broken, at least with respect to the Intel SRCSAS18E card.

Does anyone have any idea when this problem might have appeared? I figure there are probably fixes or enhancements to ext4 in later kernel versions that I'll want, but I'm not keen on building each available version in turn to see when the driver breaks. Especially since I'm an hour away from the server, and getting a clean kernel build to boot on the first try doesn't always happen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum