Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[upgrade] souci passage de gcc-4.5.4 à gcc-4.6.3 [resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
bpier
n00b
n00b


Joined: 10 Mar 2012
Posts: 18
Location: Montpellier, France

PostPosted: Sun Jan 13, 2013 10:00 am    Post subject: [upgrade] souci passage de gcc-4.5.4 à gcc-4.6.3 [resolu] Reply with quote

Lors de la dernière mise à jour de ma gentoo, gcc-4.5.4 a été upgradé vers gcc-4.6.3. C'est la première fois que je suis confronté à une MAJ majeure de gcc. J'ai donc fait un emerge --depclean, virer gcc-4.5.4, puis fait un gcc-config -l pour choisir le profil du nouveau $GHOST afin de prendre en compte gcc-4.6.3. Enfin, j'ai fait un emerge -eav system, puis un emerge -eav world.
Je précise que sont installés sur ma distrib les paquets Arduino et crossdev / avr, pour pouvoir compiler sur Arduino.
Cela étant dit, l'upgrade me laisse perplexe : pas mal de paquets ne répondent plus, comme par exemple gnome-terminal. J'ai beau le lancer, rienne se passe. Ce n'est pas le seul paquet dans ce cas. Alors, comment résoudre ce problème ? Merci Pierre
_________________
Core Quad Q6600, motherboard Gigabyte GA-EP41-UD3L, RAM 4Go, Nvidia 7950 GT, Echo Layla24, multiboot Archlinux x86/ AVLinux6/Gentoo stage3 x86. Mon site DIY & guitar effects : http://www.bruynooghe.fr


Last edited by bpier on Sun Jan 20, 2013 1:49 pm; edited 4 times in total
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Sun Jan 13, 2013 10:29 am    Post subject: Re: [upgrade] souci passage de gcc-4.5.4 à gcc-4.6.3 Reply with quote

bpier wrote:
Enfin, j'ai fait un emerge -eav system, puis un emerge -eav world.


C'était inutile. Un simple "fix_libtool_files.sh 4.5.4" suffisait pour les quelques packages qui hardcodent des paths de gcc. M'enfin bon, pas grave ta méthode prend juste plus de temps :mrgreen:

Quote:
Cela étant dit, l'upgrade me laisse perplexe : pas mal de paquets ne répondent plus, comme par exemple gnome-terminal. J'ai beau le lancer, rienne se passe. Ce n'est pas le seul paquet dans ce cas. Alors, comment résoudre ce problème ? Merci Pierre


C'est un peu vague. Il manque des infos pour deviner ce qui se passe.
Aucun message d'erreur au lancement ? C'est un peu étonnant. Si aucun message, que donne la sortie de "strace gnome-terminal" par exemple ?
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
bpier
n00b
n00b


Joined: 10 Mar 2012
Posts: 18
Location: Montpellier, France

PostPosted: Sun Jan 13, 2013 10:34 am    Post subject: Reply with quote

Quote:
C'est un peu vague. Il manque des infos pour deviner ce qui se passe.
Aucun message d'erreur au lancement ? C'est un peu étonnant. Si aucun message, que donne la sortie de "strace gnome-terminal" par exemple ?

Non, aucun message d'erreur dans le terminal (LXTerminal), rien, nada. Etant au boulot à l'heure qu'il est (eh oui, je bosse ce dimanche), je regarde ce midi (à l'heure du repas) ce donne un ps ax. Pour voir.

EDIT => test du midi (12h) : gnome-terminal se lance, parfait ; qjackctl aussi. J'ai néanmoins sur gnome-terminal, un message d'erreur, celui-là :
Quote:
/usr/bin/make_services: error while loading shared libraries: libobjc.so.2: cannot open shared object file: No such file or directory
/usr/bin/gdnc: error while loading shared libraries: libobjc.so.2: cannot open shared object file: No such file or directory

Faudra que je résolve ça. Mais ce n'est pas gagné. Car j'ai fait un revdep-rebuild --library libobjc.so.2, ça a lancé une compilation qui a planté au premier paquet : gnustep-base/gnustep-base.... :oops: Mais mon problème ressemble à ça : http://forums.gentoo.org/viewtopic-t-935474-start-0.html. Je regarderai ce soir. Mais d'ici là si quelqu'un a eu problème similaire, je suis preneur de conseil. D'autant que le seul fichier que j'ai dans /usr/lib/gcc/i686xxx/4.6.3/, c'est libobjc.so.3

Voilà le résultat d'un gcc-config -l sur ma bécane : http://www.bruynooghe.fr/public/divers/Arduino_Gentoo/Capture-root_bpier_-home-bpier.png

NOUVEL EDIT => J'ai recompilé sys-devel/gcc-4.6.3 et cross-avr/gcc-4.6.3, voilà le résultat :
Quote:
* Messages for package sys-devel/gcc-4.6.3:

*
* LTO support is still experimental and unstable.
* Any bugs resulting from the use of LTO will not be fixed.
*
* If you have issues with packages unable to locate libstdc++.la,
* then try running 'fix_libtool_files.sh' on the old gcc versions.
* You might want to review the GCC upgrade guide when moving between
* major versions (like 4.2 to 4.3):
* http://www.gentoo.org/doc/en/gcc-upgrading.xml

* Messages for package cross-avr/gcc-4.6.3:

*
* LTO support is still experimental and unstable.
* Any bugs resulting from the use of LTO will not be fixed.
*
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* Regenerating GNU info directory index...
* Processed 7 info files.
bpier bpier #


Et puis à l'issue d'un revdep-rebuild :
Quote:

/usr/lib/libgnustep-gui.so: undefined reference to `object_getClass'
collect2: ld a retourné 1 code d'état d'exécution
make[4]: *** [obj/set_show_service] Erreur 1
make[3]: *** [internal-tool-all_] Erreur 2
make[2]: *** [set_show_service.all.tool.variables] Erreur 2
make[2]: *** Attente des tâches non terminées....
/usr/lib/gcc/i686-pc-linux-gnu/4.6.3/../../../../i686-pc-linux-gnu/bin/ld: warning: libobjc.so.2, needed by /usr/lib/libgnustep-gui.so, not found (try using -rpath or -rpath-link)
/usr/lib/libgnustep-gui.so: undefined reference to `object_getClass'
collect2: ld a retourné 1 code d'état d'exécution
make[4]: *** [obj/gcloseall] Erreur 1
make[3]: *** [internal-tool-all_] Erreur 2
/usr/lib/gcc/i686-pc-linux-gnu/4.6.3/../../../../i686-pc-linux-gnu/bin/ld: warning: libobjc.so.2, needed by /usr/lib/libgnustep-gui.so, not found (try using -rpath or -rpath-link)
/usr/lib/libgnustep-gui.so: undefined reference to `object_getClass'
collect2: make[2]: *** [gcloseall.all.tool.variables] Erreur 2
ld a retourné 1 code d'état d'exécution
make[4]: *** [obj/gopen] Erreur 1
make[3]: *** [internal-tool-all_] Erreur 2
make[2]: *** [gopen.all.tool.variables] Erreur 2
i686-pc-linux-gnu-gcc -rdynamic -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--as-needed -pthread -fgnu-runtime -o obj/make_services \
./obj/make_services.obj/make_services.m.o \
-Wl,-O1 -Wl,--as-needed -L/usr/lib -licui18n -licuuc -licudata -L/usr/lib -lpng15 -L/usr/lib -L../Source/./obj -L../Model/./obj -L/usr/lib/./obj -L/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/work/GNUstep/Library/Libraries -L/usr/local/lib -L/usr/lib -lgnustep-base -lpthread -l:libobjc.so.3 -lm
make[1]: *** [internal-all] Erreur 2
make[1] : on quitte le répertoire « /var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/work/gnustep-gui-0.22.0/Tools »
make: *** [internal-all] Erreur 2
* ERROR: gnustep-base/gnustep-gui-0.22.0 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=gnustep-base/gnustep-gui-0.22.0'`,
* the complete build log and the output of `emerge -pqv '=gnustep-base/gnustep-gui-0.22.0'`.
* The complete build log is located at '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/temp/environment'.
* Working directory: '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/work/gnustep-gui-0.22.0'
* S: '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/work/gnustep-gui-0.22.0'

>>> Failed to emerge gnustep-base/gnustep-gui-0.22.0, Log file:

>>> '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/temp/build.log'

* Messages for package gnustep-base/gnustep-gui-0.22.0:

* ERROR: gnustep-base/gnustep-gui-0.22.0 failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=gnustep-base/gnustep-gui-0.22.0'`,
* the complete build log and the output of `emerge -pqv '=gnustep-base/gnustep-gui-0.22.0'`.
* The complete build log is located at '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/temp/environment'.
* Working directory: '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/work/gnustep-gui-0.22.0'
* S: '/var/tmp/portage/gnustep-base/gnustep-gui-0.22.0/work/gnustep-gui-0.22.0'
* revdep-rebuild failed to emerge all packages.
* you have the following choices:
* - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
* - Use /etc/portage/package.keywords to unmask a newer version of the package.
* (and remove 5_order.rr to be evaluated again)
* - Modify the above emerge command and run it manually.
* - Compile or unmerge unsatisfied packages manually,
* remove temporary files, and try again.
* (you can edit package/ebuild list first)
* To remove temporary files, please run:
* rm /var/cache/revdep-rebuild/*.rr
bpier bpier #


Bref, ça échoue sur la compilation de gnustep-gui-0.22.0. Apparemment, je ne suis pas le seul.


EDIT ET RESOLUTION => J'ai fini par virer tous les paquets gnustep, fait un nettoyage (en fait un rm /usr/lib/GNUstep/Bundles/Cddb.bundle/Resources/Info-gnustep.plist), puis j'ai relancé la compilation de gnustep-base, gnustep-gui, etc.
Tout s'est installé correctement. Enfin, en lançant un eix-sync, puis emerge --update --newuse --deep --with-bdeps=y @world, emerge a recompilé sys-devel/gcc-4.6.3 et cross-avr/gcc-4.6.3. Pour bétonner, j'ai bouclé le tout en tapant en console et en # un ./fix_libtool_files.sh 4.6.3 dans /usr/share/gcc-data/i686-pc-linux-gnu/4.6.3/. Dernier point : un revdep-rebuild se chargera de recompiler gnustep-libs/cddb qui restait attaché à libobjc.so.2. Voilà. Je mets un [résolu] sur ce post.
_________________
Core Quad Q6600, motherboard Gigabyte GA-EP41-UD3L, RAM 4Go, Nvidia 7950 GT, Echo Layla24, multiboot Archlinux x86/ AVLinux6/Gentoo stage3 x86. Mon site DIY & guitar effects : http://www.bruynooghe.fr
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum