Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wine in chroot needs X??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Sat Jan 12, 2013 12:55 am    Post subject: wine in chroot needs X?? Reply with quote

somehow wine told to use -xorg USE flag in mesa. But... even though is chroot does it need xorg or uses the non-chroot X?? And would I need card drivers too?

thanks.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Sat Jan 12, 2013 2:48 am    Post subject: Reply with quote

Somehow? Instead of letting us guess what problem you see, please provide the output of emerge which shows the issue.
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Sun Jan 13, 2013 2:03 pm    Post subject: Reply with quote

mainly this in chroot:

Code:
xterm
No protocol specified
xterm: Xt error: Can't open display: :0.0
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Mon Jan 14, 2013 12:30 am    Post subject: Reply with quote

one more clue from winecfg:

Code:
No protocol specified
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.


help, wanna play a game.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1513

PostPosted: Mon Jan 14, 2013 12:33 am    Post subject: Reply with quote

xhost +local: && winecfg? I don't know if that is enough to get past the chroot. I just use a separate user cleverly named 'wine' and change the permissions on the executable so only that user can run wine programs.

EDIT: You need to run xhost before you chroot. Its in x11-apps/xhost if you don't already have it installed.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Mon Jan 14, 2013 12:48 am    Post subject: Reply with quote

thanks, will double check.

strangely this works:

no host

Code:
Xnest -ac :1


in chroot
Code:
export DISPLAY=localhost:1
xterm


Does Xnest add overhead?

glxgears nor glxinfo run:

Code:
glxinfo 
name of display: localhost:1
Error: couldn't find RGB GLX visual or fbconfig

glxgears
Error: couldn't get an RGB, Double-buffered visual
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Mon Jan 14, 2013 12:54 am    Post subject: Reply with quote

The Doctor wrote:
xhost +local: && winecfg?


u da boss!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum