Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg + ati + xinerama issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
JarekG
Apprentice
Apprentice


Joined: 26 Jan 2005
Posts: 160
Location: Poland | Birmingham [UK]

PostPosted: Thu Jan 10, 2013 1:51 pm    Post subject: xorg + ati + xinerama issue Reply with quote

Hi,

I have a quick one for you. I have managed to do dual monitor setting with the ATI card on my Gentoo and I'm also able to drag and drop things across monitors however the one thing which makes me mad a bit is the full screen. When I set window to full screen mode (or expand to the full screen - not F11) the window goes to both monitors. The thing I don't know how to do is to recognize "edges" on both displays so I don't want 1 window in full screen mode to be allocated on both monitors. I need that work within the single display.

Any ideas what I have missed ?

Thank you in advance.

Regards,
Jarek
_________________
Pozdrawiam
Jarosław Grząbel
HERE I AM
Back to top
View user's profile Send private message
gorkypl
Guru
Guru


Joined: 04 Oct 2010
Posts: 443
Location: Kraków, PL

PostPosted: Fri Jan 11, 2013 11:10 pm    Post subject: Reply with quote

How are your screens configured? I mean xorg.conf
_________________
BTW, TWM FTW!
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Sat Jan 12, 2013 12:42 am    Post subject: Reply with quote

which DE/WM??

it should work fine with that combination.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1654
Location: Berlin, Germany

PostPosted: Sat Jan 12, 2013 2:45 am    Post subject: Reply with quote

Probably your window manager needs to be built with USE="xinerama".
Back to top
View user's profile Send private message
JarekG
Apprentice
Apprentice


Joined: 26 Jan 2005
Posts: 160
Location: Poland | Birmingham [UK]

PostPosted: Thu Jan 17, 2013 5:18 pm    Post subject: Reply with quote

That's the problem I know nothing about the configuration becuase xorg.conf doesn't exist anymore.

When I did Xorg -configure and use some ATI tools (cannot remember names now sorry) it generated a config but in dual-head mode so I cannot grab windows between screens.

When I enabled xinerama it did what I wanted but... as I said when for example I maximize a console window or a web browser window it goes widely to both screens. Whereas on CentOS (I'm currently on temporarily) can handle it and if I maximize the window to be maximized it only extends that within the current screen only and I can grab and drop windows between screens.

If there would be a way to export my current xorg.conf from CentOS (which doesn't exist) I would be sorted :/.
_________________
Pozdrawiam
Jarosław Grząbel
HERE I AM
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2441
Location: Silver City, NM

PostPosted: Thu Jan 17, 2013 8:12 pm    Post subject: Reply with quote

The word "xinerama" applies to two related but different things. One is having the Xorg server xinerama enabled so that the display spans two monitors like you describe. The second is the awareness in users apps that the Xorg server is spanning two monitors so they know to maximize on a single monitor.

You've got the first working but not the second. To get the second to work, you need to add "xinerama" to your list of USE flags in make.conf and then do an "emerge -av -uDN world". You can get a list of what installed packages use the xinerama USE flag with "equery hasuse xinerama". Here is the list from my system:
Code:
$ equery hasuse xinerama
 * Searching for USE flag xinerama ...
[IP-] [  ] gnome-base/gdm-2.20.11-r1:0
[IP-] [  ] media-gfx/feh-2.5:0
[IP-] [  ] media-libs/libsdl-1.2.15-r2:0
[IP-] [  ] media-libs/xine-lib-1.2.2:1
[IP-] [  ] media-video/mplayer-1.1-r1:0
[IP-] [  ] x11-apps/xdpyinfo-1.3.0-r1:0
[IP-] [  ] x11-libs/fltk-1.3.0-r1:1
[IP-] [  ] x11-libs/gtk+-2.24.12:2
[IP-] [  ] x11-libs/gtk+-3.4.4:3
[IP-] [  ] x11-libs/qt-gui-4.8.4:4
[IP-] [  ] x11-libs/xosd-2.2.14-r1:0
[IP-] [  ] x11-misc/ipager-1.1.0:0
[IP-] [  ] x11-misc/xscreensaver-5.20:0
[IP-] [  ] x11-wm/dwm-6.0:0
[IP-] [  ] x11-wm/enlightenment-0.16.9999:0
[IP-] [  ] x11-wm/fluxbox-1.3.2:0
[IP-] [  ] x11-wm/icewm-1.2.37:0
[IP-] [  ] x11-wm/pekwm-0.1.11:0
Back to top
View user's profile Send private message
JarekG
Apprentice
Apprentice


Joined: 26 Jan 2005
Posts: 160
Location: Poland | Birmingham [UK]

PostPosted: Tue Jan 22, 2013 11:40 am    Post subject: Reply with quote

Thanks! That did the job! :).
_________________
Pozdrawiam
Jarosław Grząbel
HERE I AM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum