Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]fail to emerge polkit-0.107-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Thu Jan 10, 2013 2:26 pm    Post subject: [SOLVED]fail to emerge polkit-0.107-r1 Reply with quote

hi,
I recognized that I had installed gtk+ without the doc use-flag and since I'm learning to program with gtk+ I need it now. So I've tried to recompile x11-libs/gtk+ with:
Code:
echo "x11-libs/gtk+ x11-libs/gtk+ X colord cups debug examples introspection test vim-syntax

then portage told that I have to change the following use-flags:
Code:
The following USE changes are necessary to proceed:
#required by sys-auth/polkit-0.107-r1, required by x11-misc/colord-0.1.26, required by x11-libs/gtk+-3.4.4[colord], required by gnome-extra/polkit-gnome-0.105
>=sys-auth/consolekit-0.4.5_p20120320-r1 policykit
#required by x11-misc/colord-0.1.26[udev], required by x11-libs/gtk+-3.4.4[colord], required by gnome-extra/polkit-gnome-0.105, required by sys-auth/polkit-0.107-r1[gtk], required by sys-auth/consolekit-0.4.5_p20120320-r1[policykit], required by sys-auth/pambase-20101024-r2[consolekit], required by net-misc/openssh-5.9_p1-r4[pam], required by @selected, required by @world (argument)
=virtual/udev-171 gudev
#required by sys-auth/polkit-0.107-r1[pam], required by x11-misc/colord-0.1.26, required by x11-libs/gtk+-3.4.4[colord], required by gnome-extra/polkit-gnome-0.105
=sys-auth/pambase-20101024-r2 consolekit
#required by virtual/udev-171, required by dev-libs/libgusb-0.1.4, required by x11-misc/colord-0.1.26[gusb], required by x11-libs/gtk+-3.4.4[colord], required by gnome-extra/polkit-gnome-0.105, required by sys-auth/polkit-0.107-r1[gtk], required by sys-auth/consolekit-0.4.5_p20120320-r1[policykit], required by sys-auth/pambase-20101024-r2[consolekit], required by net-misc/openssh-5.9_p1-r4[pam], required by @selected, required by @world (argument)
=sys-fs/udev-171-r9 gudev
So I added all of them to my /etc/portage/make.conf file and tried to recompile gtk+
then
Code:
>> Failed to emerge sys-auth/polkit-0.107-r1, Log file:

output of /var/tmp/portage/sys-auth/polkit-0.107-r1/temp/build.log:
http://bpaste.net/show/69294/

output of emerge --info '=sys-auth/polkit-0.107-r1':
http://bpaste.net/show/69291/

output of emerge -pqv '=sys-auth/polkit-0.107-r1':
http://bpaste.net/show/69292/


Last edited by LoTeK on Thu Jan 17, 2013 4:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5497

PostPosted: Thu Jan 10, 2013 4:51 pm    Post subject: Reply with quote

Docs should have been installed regardless of the 'doc' flag.

As for the error, the first guess would be a failed perl upgrade in the past (that is perl-cleaner hasn't been run).
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2127
Location: Finland

PostPosted: Thu Jan 10, 2013 7:40 pm    Post subject: Reply with quote

Quote:

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


Run this to overcome the above problem:

Code:

# emerge -1 dev-perl/XML-Parser
# perl-cleaner --all
Back to top
View user's profile Send private message
LoTeK
Apprentice
Apprentice


Joined: 26 Jul 2012
Posts: 270

PostPosted: Thu Jan 17, 2013 4:02 pm    Post subject: Reply with quote

I've run
Code:
# emerge -1 dev-perl/XML-Parser
# perl-cleaner --all
and it worked (although I can't compile media-gfx/graphicsmagick-1.3.16-r1 now :), but I'll try a few things first..)

@VoidMage
I thought the 'doc' flag is here for enabling the installation of docs?! or do you mean only gtk+ docs? because when I enter "doc foo" in octave, it response with:
Code:
info: /usr/share/info/octave.info: No such file or directory
info: /usr/share/info/octave.info: No such file or directory
and I've compiled octave without the doc flag too...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum