Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to emerge Gnome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
viciantohun
n00b
n00b


Joined: 09 Jan 2013
Posts: 3

PostPosted: Thu Jan 10, 2013 1:25 am    Post subject: Failed to emerge Gnome Reply with quote

Hello Everybody,

today i have tried to install (emerge) the Gnome, but i have got the following error:


* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies... done!

!!! The ebuild selected to satisfy "x11-libs/gtk+:3" has unmet requirements.
- x11-libs/gtk+-3.4.4::gentoo USE="cups introspection (multilib) -X (-aqua) -colord -debug -examples (-packagekit) -test -vim-syntax (-wayland) -xinerama"

The following REQUIRED_USE flag constraints are unsatisfied:
any-of ( aqua wayland X )

The above constraints are a subset of the following complete expression:
any-of ( aqua wayland X ) xinerama? ( X )

(dependency required by "net-dns/avahi-0.6.30-r3[gtk3]" [ebuild])
(dependency required by "gnome-base/gnome-vfs-2.24.4-r1[avahi]" [ebuild])
(dependency required by "dev-python/gnome-vfs-python-2.28.1" [ebuild])
(dependency required by "dev-python/libgnome-python-2.28.1" [ebuild])
(dependency required by "gnome-extra/hamster-applet-2.32.1" [ebuild])
(dependency required by "gnome-base/gnome-2.32.1-r2" [ebuild])
(dependency required by "gnome" [argument])


Do you have any idea?
I have tried with:
USE="cups introspection (multilib) -X (-aqua) -colord -debug -examples (-packagekit) -test -vim-syntax (-wayland) -xinerama" emerge gnome but i have also get the same error.

/etc/portage/make.conf:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe -msse -msse2 -msse3 -mmmx -m3dnow"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2 gtk gtk3 gnome hal avahi cups"
MAKEOPTS="-j9"
GENTOO_MIRRORS="http://gentoo.inf.elte.hu/"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"

Thanks
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1543

PostPosted: Thu Jan 10, 2013 1:28 am    Post subject: Reply with quote

You need to enable X. Since you are installing gnome, it stands to reason that you will be using X, so you should do that globally.

EDIT: you seem to be using some really old docs. hal has been dead for over a year. Just make sure you set the right profile using eselect profile list and eselect profile set
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
fturco
Apprentice
Apprentice


Joined: 08 Dec 2010
Posts: 290
Location: Italy

PostPosted: Thu Jan 10, 2013 12:47 pm    Post subject: Re: Failed to emerge Gnome Reply with quote

viciantohun wrote:
* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Not related to your problem, but you may want to read the news with eselect, as emerge says.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum