Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HD6870] Black screen when using catalyst
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
grey_dot
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2012
Posts: 142

PostPosted: Tue Jan 08, 2013 8:49 pm    Post subject: [HD6870] Black screen when using catalyst Reply with quote

Hi,

About a month ago my graphics card (ATI Radeon HD6870) began turning off when running any heavy 3d app like Blender with a huge project, any resource-demanding game, etc. All of the displays (I got triple-monitor configuration) turn off like if I power down the machine, sound starts looping for a second or two, then continues normally. Symptoms are like overheating, except that providing additional cooling does not help, temperature doesn't go above 60C, and other systems (Windows, BSD) do not seem to suffer this. Using open source driver also solves the issue, but I need catalyst to use all of hardware features.

I use ~amd64 with vanilla kernel 3.7.1, ati-drivers 12.11_beta11, xorg-server 1.13.0-r1. Lspci output below:

Code:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Barts XT [Radeon HD 6800 Series] (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device 21fa
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 99
   Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
   Region 2: Memory at fea20000 (64-bit, non-prefetchable) [size=128K]
   Region 4: I/O ports at e000 [size=256]
   Expansion ROM at fea00000 [disabled] [size=128K]
   Capabilities: [50] Power Management version 3
      Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
      DevCap:   MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
         ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
      DevCtl:   Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
         RlxdOrd- ExtTag+ PhantFunc- AuxPwr- NoSnoop+
         MaxPayload 128 bytes, MaxReadReq 512 bytes
      DevSta:   CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
      LnkCap:   Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
         ClockPM- Surprise- LLActRep- BwNot-
      LnkCtl:   ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
         ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
      LnkSta:   Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
      DevCap2: Completion Timeout: Not Supported, TimeoutDis-, LTR-, OBFF Not Supported
      DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
      LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
          Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
          Compliance De-emphasis: -6dB
      LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
          EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
   Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
      Address: 00000000feeff00c  Data: 41e4
   Capabilities: [100 v1] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
   Capabilities: [150 v1] Advanced Error Reporting
      UESta:   DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
      UEMsk:   DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
      UESvrt:   DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
      CESta:   RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
      CEMsk:   RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
      AERCap:   First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
   Kernel driver in use: fglrx_pci
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Sat Jan 12, 2013 3:00 am    Post subject: Reply with quote

Quote:
began turning off when running any heavy 3d app
Hardware issue I would guess. Most likely your power supply is going bad.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum