Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
BTTV Tuner has no way to set tv freq
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
AlfaGTV
n00b
n00b


Joined: 26 Jul 2003
Posts: 33
Location: Belgium

PostPosted: Thu Jan 03, 2013 7:55 pm    Post subject: BTTV Tuner has no way to set tv freq Reply with quote

On new years day my hard disk containing my root partition broke :( So I've reinstalled Gentoo on a spare hard disk. I managed to get everything working except for my very old Pinnacle PCTV card. It's an old PCI card that I've been using for many years, it has always worked with Gentoo. But I can't get it to work again. I think I have all the right kernel modules but still I can not watch tv in tvtime.

lspci gives me this:
01:04.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
01:04.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

dmesg:

24.437944] bt87x0: Using board 1, analog, digital (rate 32000 Hz)
[ 24.748845] bttv: driver version 0.9.19 loaded
[ 24.748852] bttv: using 8 buffers with 2080k (520 pages) each for capture
[ 24.749085] bttv: Bt8xx card found (0)
[ 24.749116] bttv: 0: Bt878 (rev 17) at 0000:01:04.0, irq: 19, latency: 132, mmio: 0xb3000000
[ 24.749169] bttv: 0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012
[ 24.749171] bttv: 0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]
[ 21.013192] ACPI: Invalid Power Resource to register!
[ 24.749270] bttv: 0: i2c: checking for MSP34xx @ 0x80... <7>[ 24.749824] i2c i2c-2: NAK from device addr 0x40 msg #0
[ 24.749842] not found
[ 24.749844] bttv: 0: pinnacle/mt: id=1 info="PAL / mono" radio=no
[ 24.749846] bttv: 0: tuner type=33
[ 24.751758] i2c i2c-2: NAK from device addr 0x40 msg #0
[ 24.785473] i2c i2c-2: NAK from device addr 0x45 msg #0
[ 24.895213] i2c i2c-2: NAK from device addr 0x41 msg #0
[ 24.895783] i2c i2c-2: NAK from device addr 0x40 msg #0
[ 24.896370] i2c i2c-2: NAK from device addr 0x4c msg #0
[ 24.896936] i2c i2c-2: NAK from device addr 0x42 msg #0
[ 24.897525] i2c i2c-2: NAK from device addr 0x5a msg #0
[ 24.898108] i2c i2c-2: NAK from device addr 0x5b msg #0
[ 24.898673] i2c i2c-2: NAK from device addr 0x58 msg #0
[ 24.899259] i2c i2c-2: NAK from device addr 0x4b msg #0
[ 24.899277] bttv: 0: audio absent, no audio device found!
[ 25.092375] i2c i2c-2: NAK from device addr 0x42 msg #0
[ 25.411150] tda9887 2-0043: creating new instance
[ 25.411155] tda9887 2-0043: tda988[5/6/7] found
[ 25.411752] tuner 2-0043: Tuner 74 found with type(s) Radio TV.
[ 25.520396] Chip ID is not zero. It is not a TEA5767
[ 25.520408] tuner 2-0060: Tuner -1 found with type(s) Radio TV.
[ 25.521714] DVB: Unable to find symbol microtune_attach()
[ 25.522421] bttv: 0: registered device video1
[ 25.522470] bttv: 0: registered device vbi0
[ 25.522487] bttv: 0: Setting PLL: 28636363 => 35468950 (needs up to 100ms)
[ 25.544024] bttv: PLL set ok
[ 25.544617] tuner 2-0060: Tuner has no way to set tv freq
[ 25.545192] i2c i2c-2: NAK from device addr 0x1a msg #0
[ 25.545760] i2c i2c-2: NAK from device addr 0x18 msg #0
[ 25.546364] i2c i2c-2: NAK from device addr 0x64 msg #0
[ 25.546930] i2c i2c-2: NAK from device addr 0x30 msg #0
[ 25.547503] i2c i2c-2: NAK from device addr 0x71 msg #0
[ 25.549974] tuner 2-0060: Tuner has no way to set tv freq
[ 25.550620] tuner 2-0060: Tuner has no way to set tv freq
[ 25.551260] tuner 2-0060: Tuner has no way to set tv freq
[ 25.551866] tuner 2-0060: Tuner has no way to set tv freq

I have tried compiling bttv in the kernel and as a module, but it gives the same result. I have tried to manually load the module (modprobe bttv card=39 tuner=33) but nothing seems to help. Am I overlooking something?
_________________
Cuore Sportivo
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4560
Location: Saint Amant, Acadiana

PostPosted: Thu Jan 03, 2013 10:17 pm    Post subject: Reply with quote

I just switched from 3.6.8 to 3.7.1 and had similar issue with my Haupauge card. I learned things have moved in kernel config and choices have changed. In case you lost your old kernel config you could boot with some good generic liveCD (Knoppix, whatever) and learn from dmesg what you need to enable.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31342
Location: 56N 3W

PostPosted: Thu Jan 03, 2013 10:20 pm    Post subject: Reply with quote

AlfaGTV,

The videp chip driver is bt8x8 and the sound is bt878 audio, I think.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
AlfaGTV
n00b
n00b


Joined: 26 Jul 2003
Posts: 33
Location: Belgium

PostPosted: Fri Jan 04, 2013 4:50 pm    Post subject: Reply with quote

lsmod output:
Module Size Used by
nvidia 11212257 30
tda9887 8566 1
tda8290 12540 0
tuner 16436 2
tvaudio 24589 0
tda7432 4144 0
bttv 110260 0
i2c_algo_bit 6609 1 bttv
videobuf_dma_sg 7209 1 bttv
videobuf_core 14899 2 bttv,videobuf_dma_sg
btcx_risc 3156 1 bttv
tveeprom 13754 1 bttv
snd_bt87x 8759 2

Am I missing a module?
I'll try booting from the livecd later today and see what modules are loaded.
_________________
Cuore Sportivo
Back to top
View user's profile Send private message
AlfaGTV
n00b
n00b


Joined: 26 Jul 2003
Posts: 33
Location: Belgium

PostPosted: Sat Jan 05, 2013 3:19 pm    Post subject: Reply with quote

Did a make mrproper and tried a dozen different kernels. And suddenly it worked :)
lsmog gives this:
Module Size Used by
nvidia 11212257 30
tuner 16436 2
tvaudio 24461 0
tda7432 4144 0
msp3400 27388 0
bttv 109380 1
videobuf_dma_sg 7209 1 bttv
videobuf_core 14899 2 bttv,videobuf_dma_sg
btcx_risc 3156 1 bttv
snd_bt87x 8759 3
tveeprom 13754 1 bttv
_________________
Cuore Sportivo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum