Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg 1.13 - Segfault on server shutdown -- FIXED in 1.13.1
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fhaddad78
n00b
n00b


Joined: 21 May 2012
Posts: 68

PostPosted: Fri Dec 14, 2012 12:57 am    Post subject: Reply with quote

UPDATE:

Regarding dmesg:
I have resolved the ACPI warnings in dmesg. Apparently the Intel Watch Dog ICO_WDT driver was conflicting with the ACPI driver. After disabling ICO_WDT in the kernel, everything is fine.

Regarding Xorg.0.log:
All EE and WW messages have been resolved with the exception of the segfault on shutdown. However, I think the issue is related to QT and not Xorg 1.13 directly. Here is a bug report detailing a similar situation https://bugassistant.libreoffice.org/show_bug.cgi?id=57372. I'm going to spend some time trying to figure it out, but I think I'm getting closer to the source of the problem.
Back to top
View user's profile Send private message
Yuriy Skvortsov
n00b
n00b


Joined: 30 Dec 2012
Posts: 32
Location: Odessa, Ukraine

PostPosted: Sun Dec 30, 2012 4:08 pm    Post subject: Reply with quote

Hi! I've also got same trouble on a relatively fresh Gentoo install with Awesome. X Server segfaults when I quit Awesome but performes just OK when I hit ctrl_alt_bksp. If I can supply any useful information for this case - just let me know.
And yeah, Hello, Gentoo forums! - Its my first message here and my first conscious Gentoo install ;)
Back to top
View user's profile Send private message
fhaddad78
n00b
n00b


Joined: 21 May 2012
Posts: 68

PostPosted: Thu Jan 03, 2013 6:02 pm    Post subject: Reply with quote

As of xorg-server 1.13.1, the issue is resolved. I don't know specifically what was broke in 1.13.0 but the earth's orbit is now realigned.
Back to top
View user's profile Send private message
Yuriy Skvortsov
n00b
n00b


Joined: 30 Dec 2012
Posts: 32
Location: Odessa, Ukraine

PostPosted: Thu Jan 03, 2013 7:31 pm    Post subject: Reply with quote

Got same results with 1.13.1.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1691
Location: Berlin, Germany

PostPosted: Thu Jan 03, 2013 11:41 pm    Post subject: Reply with quote

In case you are interested, this is probably the change that fixed the crash: http://cgit.freedesktop.org/xorg/xserver/commit/?h=server-1.13-branch&id=36f9c2d1ddc8a35c0317db55044d05f07284ab38
Back to top
View user's profile Send private message
fhaddad78
n00b
n00b


Joined: 21 May 2012
Posts: 68

PostPosted: Thu Jan 03, 2013 11:45 pm    Post subject: Reply with quote

@chithanh thanks for that link.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum