Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wicd "ERROR:dbus.connection"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
microchiroptera
n00b
n00b


Joined: 23 Jul 2011
Posts: 25
Location: Russia

PostPosted: Thu Jan 03, 2013 4:15 pm    Post subject: Wicd "ERROR:dbus.connection" Reply with quote

When I try to connect to wired or wireless, wicd says "Not connected". I've ran wicd-client, and when I've clicked on "connect" button, I had this:
Code:
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/dbus/connection.py", line 230, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/wicd/gtk/gui.py", line 253, in handle_connection_results
    error(self.window, language[results], block=False)
KeyError: dbus.String(u'dhcp_failed')

Any ideas?
Back to top
View user's profile Send private message
roravun
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2012
Posts: 82

PostPosted: Thu Jan 03, 2013 4:29 pm    Post subject: Reply with quote

The output is not very verbose.
Disable NetworkManager and try to connect to a network manually. If you succeed, then you will at least know
the problem is in NetworkManager/DBus or wicd.
Back to top
View user's profile Send private message
microchiroptera
n00b
n00b


Joined: 23 Jul 2011
Posts: 25
Location: Russia

PostPosted: Thu Jan 03, 2013 4:31 pm    Post subject: Reply with quote

roravun wrote:
The output is not very verbose.
Disable NetworkManager and try to connect to a network manually. If you succeed, then you will at least know
the problem is in NetworkManager/DBus or wicd.


NetworkManager isn't installed and I can connect to, at least, wired network manually.
Back to top
View user's profile Send private message
roravun
Tux's lil' helper
Tux's lil' helper


Joined: 05 Sep 2012
Posts: 82

PostPosted: Thu Jan 03, 2013 4:40 pm    Post subject: Reply with quote

Quote:
NetworkManager isn't installed and I can connect to, at least, wired network manually.

Right, I think I have mixed it with nm-applet.

Well, you can't really debug a problem using what you have posted.
Try to enable debug/verbosity options in wicd/wicd-client or DBUS, that is all that comes to my mind.

Personally, I would recommend to revert to conf.d/network and wpa_gui, unless you have a very specific reason for using wicd, like maintaining always-changing configurations.
From my experience this is the most trouble free way to use your networking. At least you get clear error message instead of cryptic DBus dump.
Back to top
View user's profile Send private message
microchiroptera
n00b
n00b


Joined: 23 Jul 2011
Posts: 25
Location: Russia

PostPosted: Thu Jan 03, 2013 4:56 pm    Post subject: Reply with quote

roravun wrote:
Personally, I would recommend to revert to conf.d/network and wpa_gui, unless you have a very specific reason for using wicd, like maintaining always-changing configurations.
From my experience this is the most trouble free way to use your networking. At least you get clear error message instead of cryptic DBus dump.


Thank you for idea! With wpa_gui everything works fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum