Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Medion MD97600 WLAN ipw2200 und die Hotkey Problematik
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Thu Jan 03, 2013 12:53 am    Post subject: Medion MD97600 WLAN ipw2200 und die Hotkey Problematik Reply with quote

Hallo Gentooianer und welche die mir helfen können:

Ich habe hier einen leidigen ALDI-Laptop der Marke Medion vom Typ MD97600
Mein Problem mit diesem Schätzelein ist folgendes:

WLAN funktioniert nicht, da diese über einen Hotkey eingeschaltet werden muss.

Ich versuchte bereits mit Kubuntu 12.04 und Kubuntu 12.10 und dem acerhk Treiber die Geschichte zum Laufen zu bringen, beides mal nicht erfolgreich --> WLAN lässt sich nicht einschalten, oder Kernelpanic.
Jetzt versuche ich es mit Sabayon... möchte aber aus Gründen dort nicht auch noch einen Forenaccount anlegen müssen und da es ähnlich zu Gentoo ist dachte ich, ich frage mal hier.

rfkill list:
Code:
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes


ifconfig -a:
Code:
eth1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:16:6f:a4:5e:bc  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


iwconfig -a:
Code:
eth1      IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0 
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


lspci -k (beschnitten):
Code:
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
        Subsystem: Intel Corporation Device 2701
        Kernel driver in use: ipw2200
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)


lsmod:
Code:
ipw2200               100909  0
libipw                 17660  1 ipw2200
lib80211                2344  2 libipw,ipw2200
cfg80211              118108  2 libipw,ipw2200


Ich habe bereits versucht auf dem Sabayon Paket: http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-laptop/acerhk/?hideattic=0
zu installieren und in etwa diese Konstellation: http://wiki.ubuntuusers.de/Acer_Hotkeys

Diese Seite hatte ich bisher zu Hilfe genommen: http://rfswitch.sourceforge.net/?page=laptop_matrix

Inzwischen bin ich ratlos, unter Sabayon lässt sich der acerhk nicht installieren da mir beim Kompilieren jedesmal ein Fehler entgegengeworfen wird (#include <linux/config.h> wird nciht gefunden und ähnliches, der PAtch der dieses Beheben soll fördert einen anderen Fehler zutage der in den Sources auffällt...)

Vll habt ihr mir den richtigen Fingerzeig...

Überprüfen ob WLAN tut mache ich mit folgendem Befehl: ifconfig eth1 up && iwlist eth1 scan
Interessanterweiße kann ich mit einem USB-WLAN-Stick den ich anstecke über den NEtworkManager keine Verbindung aufbauen. Dieses Problem liegt aber mit Sicherheit an etwas anderem, das ich mir anschauen werde sobald die eingebaute WLAN-Karte funktioniert...
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 189

PostPosted: Thu Jan 03, 2013 11:07 am    Post subject: Reply with quote

Das hier

hxxx://www.opensuse-forum.de/gelöst-keine-w-lan-verbindung-mit-medion-notebook-möglich-hardware-treiber/themen-f9/t38-f11/

list sich etwas abenteuerlich, aber scheint eine Lösung zu sein.

EDIT: Link funktioniert nicht
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 418

PostPosted: Thu Jan 03, 2013 1:20 pm    Post subject: Reply with quote

Wenn der "config.h" Fehler kommt, musst Du sicherstellen, dass der "kernel-2.6.19-config.h.patch" eingespielt wird. Mich wundert es dass es im 0.5.35-er Ebuild nicht verwendet wird. in den älteren Ebuilds ist der Patch drin. Dort kannst Du es also abschauen. Wenn die 0.5.35 mit dem Patch nicht kompiliert, versuche es mal mit einer älteren Version. Dort hatte es ja irgend wann funktioniert.

Beachte, dass das Ebuild aus dem Portage bereits rausgeflogen ist. Also keine Garantie dass es geht. Es gab damit wohl irgend welche Probleme. Siehe https://bugs.gentoo.org/show_bug.cgi?id=277598

Eine Option wäre auf einen älteren Kernel zu gehen. =sys-kernel/vanilla-sources-2.6.32.60 ist noch im Portage. Aber ggf. bekommst Du dadurch andere Probleme.
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Thu Jan 03, 2013 2:57 pm    Post subject: Reply with quote

Hi

Ich hatte das ganze mal nach einem WLAN Karten Wechsel bei einem Toshiba Laptop.

Da war das Problem ganz einfach gelöst: Man nehme ein Stück Tesafilm und klebe einen bestimmten Pin vom Mini-PCI Anschluss der Karte ab. Schon ist die Karte immer aktiv und man kann Sie benutzen. Einziges Manko: Man kann WLAN nicht per Tastenkombination oder Schalter am Laptop abschalten. Ob das bei Mini-PCIex Karten auch noch geht weiß ich nicht. Das musst du mal googlen.

Sebastian
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum