Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vlc and adobe-flash
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 695

PostPosted: Thu Jan 03, 2013 9:10 am    Post subject: vlc and adobe-flash Reply with quote

When I do a update world, vlc got upgraded/reinstalled. Afterward, flash content in browser (google-chrome) are replaced by vlc plugin, including YouTube, which doesn't work.

Re-emerging adobe-flashplugin reverses this behavior.

It seems like that's not a proper solution and I don't understand the root cause. Anybody?
_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Thu Jan 03, 2013 2:19 pm    Post subject: Reply with quote

for temp workaround, disable nsplugin flag in vlc
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Odysseus
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 246
Location: Miami, FL. I miss San Francisco!!!

PostPosted: Tue Jan 08, 2013 9:44 pm    Post subject: Reply with quote

DaggyStyle wrote:
for temp workaround, disable nsplugin flag in vlc


There hasn't been a nsplugin useflag in vlc for quite sometime. If I'm not mistaken all vlc-2.x in portage are without this use flag. Instead with the 2.x versions one has to install media-plugins/npapi-vlc-2.0.0 for browser integration.

To the OP, I don't use Chrome or Chromium but have used Firefox for years. I had a similar problem as yours when vlc-2.x came into the tree, npapi-vlc seemed to cause vlc to become the default for all flash and didn't playback correctly.

I was able to resolve it by going to 'edit-preferences-applications' and setting the preferences for 'flash video' to 'libflashplayer.so'.

There must be a similar mechanism in Chrome / Chromium to set the application default for opening each mime-type. That will be where you can make the adjustment without having to do something as drastic as uninstalling npapi-vlc which is needed to playback non-flash content (that is if you don't use another web enabled media-player, such as mplayer).

I hope this helps.

Ciao
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4883

PostPosted: Wed Jan 09, 2013 6:11 am    Post subject: Reply with quote

right, didn't noticed the flag was removed, nothing to add anymore.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum