Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Gnome Shell unable to start Gnome 3.6.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Sun Dec 30, 2012 2:52 pm    Post subject: [SOLVED] Gnome Shell unable to start Gnome 3.6.2 Reply with quote

Recently I updated my world which pulled Gnome 3.6.x. Now I can't login to Gnome although fall back mode is working. Revdep rebuild is not showing anything. Preserved rebuild is empty. My :0-greeter.log is looking lie this:
Code:
Ostrzeżenie menedżera okien: Log level 16: Failed to load apps: Failed to look up menu_file for "applications.menu"

failed to create drawable
      JS LOG: GNOME Shell started at Sun Dec 30 2012 15:14:07 GMT+0100 (CET)
failed to create drawable
Ostrzeżenie menedżera okien: CurrentTime used to choose focus window; focus window may not be correct.
Ostrzeżenie menedżera okien: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
Ostrzeżenie menedżera okien: Log level 8: g_variant_compare: assertion `!g_variant_is_container (a)' failed
gnome-session[4287]: WARNING: Detected that screensaver has left the bus
gnome-session[4287]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

(gnome-settings-daemon:4380): GLib-GIO-WARNING **: Error releasing name org.gnome.SettingsDaemon: Połączenie jest zamknięte
Ostrzeżenie menedżera okien: Log level 8: g_source_remove: assertion `tag > 0' failed

:0-slave.log is empty.
I thought that maybe some settings from previous Gnome 3.4 that was working quite fine, are causing the problem, and I created a new user to test it, but the outcome is same, sorry something went wrong Log Off.

I was trying to rebuild Gnome-shell and dbus-glib without any effect. I have no idea what the hell is wrong, any help greatly appreciated.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11


Last edited by andrzejk on Sat Jan 19, 2013 8:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
jpc22
Apprentice
Apprentice


Joined: 29 Jan 2012
Posts: 190

PostPosted: Wed Jan 02, 2013 5:49 am    Post subject: Reply with quote

--oneshot will fetch the files again and compile a package again without using files relevant to that package that are already on your computer
--deep --with-bdeps=y will check for pretty much all dependencies
--newuse will emerge with current flags in case there has been any change to your make.conf since last gnome version.


# emerge --deep --with-bdeps=y --newuse --oneshot package

Your in for a clean recompilation, if the issue still persist there is a problem with something else than previous settings.
Back to top
View user's profile Send private message
Naib
Advocate
Advocate


Joined: 21 May 2004
Posts: 4117
Location: Removed by Neddy

PostPosted: Wed Jan 02, 2013 1:09 pm    Post subject: Reply with quote

are you using any non-stock themes or extensions?
I ran into 2 issues since the theme I was using became incompatible, likewise some extensions I had enabled were not supported.
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Wed Jan 02, 2013 11:24 pm    Post subject: Reply with quote

jpc22 wrote:

# emerge --deep --with-bdeps=y --newuse --oneshot package

Your in for a clean recompilation, if the issue still persist there is a problem with something else than previous settings.


Thanks for replay.
This pulled recompilation of gconf and imagemagick - ufortunatly this did not change my situation, for my user and new clean user the outcome is still the same:
SOMETHIN WENT WRONG (...) LOGG OFF.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11


Last edited by andrzejk on Wed Jan 02, 2013 11:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Wed Jan 02, 2013 11:30 pm    Post subject: Reply with quote

Naib wrote:
are you using any non-stock themes or extensions?
I ran into 2 issues since the theme I was using became incompatible, likewise some extensions I had enabled were not supported.


Thanks for replay.

Themes no - extensions yes but all of them were installed locally.
As I wrote I created a completely new user and added him to standard groups including video group and for this clean account the outcome is exactly the same - I made sure to disable all extensionst via: eselect gnome-shell-extensions before testing both accounts. This is wierd I think is time to leave Gnome 3 :-( :-(.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 478
Location: Scotland

PostPosted: Thu Jan 03, 2013 12:00 am    Post subject: Reply with quote

Can you post the output of
Code:
emerge --info

please?

I don't see why you should give up on gnome just yet.
We need to establish exactly what is causing this, otherwise we can't help.
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Thu Jan 03, 2013 7:32 am    Post subject: Reply with quote

My Emerge Info

Code:
Portage 2.2.0_alpha149 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.16.0, 3.6.6-gentoo x86_64)
=================================================================
System uname: Linux-3.6.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-2720QM_CPU_@_2.20GHz-with-gentoo-2.2
Timestamp of tree: Wed, 02 Jan 2013 13:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p39-r1
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo arcon rainyday kde zugaina gamerlay kardasa sunrise java-overlay quarks_gentoo_hardened_overlay mate-overlay DuPol mva desktop-effects hasufell vmware udev steam-overlay bumblebee manual
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/mateconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.wheel.sk/pub/linux/gentoo/ ftp://91.121.124.139/gentoo-distfiles/ http://gentoo.inf.elte.hu/ rsync://mirror.cambrium.nl/gentoo/            rsync://ftp.vectranet.pl/gentoo/ http://212.219.56.134/sites/www.ibiblio.org/gentoo/"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/arcon /var/lib/layman/rainyday /var/lib/layman/kde /var/lib/layman/zugaina /var/lib/layman/gamerlay /var/lib/layman/kardasa /var/lib/layman/sunrise /var/lib/layman/java-overlay /var/lib/layman/quarks /var/lib/layman/mate /var/lib/layman/DuPol /var/lib/layman/mva /var/lib/layman/desktop-effects /var/lib/layman/hasufell /var/lib/layman/vmware /var/lib/layman/udev /var/lib/layman/steam-overlay /var/lib/layman/bumblebee /usr/local/portage/manual"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="/ X a52 aac aalib accessibility acl acpi addressbook aim alsa amd64 artswrappersuid audiofile avahi bash-completion beagle berkdb bidi bluetooth bluray branding bs2b btrfs bzip2 cairo calendar caps ccache cdda cddb cdinstall cdr celt cjk cli colord consolekit cracklib crypt css cups curl custom-cflags custom-optimization cxx dbus dc1394 dga dhcpcd dia djvu dri dtmf dts dv dvb dvd dvdr dvdread dvi eds eix emboss encode exif ext3 ext4 fam fame fat fbsplash ffmpeg firefox flac flash flickr foomatic-db fortran freetype frei0r ftp fuse gadu galago gcj gconf gd gdbm geoip gg gif gimp gimpprint gles gles1 gles2 gmp gnome gnome-keyring gnome-online-accounts gnutls gphoto2 gpm gps graphviz groupwise gs gsm gstreamer gtk gtk3 h224 h281 h323 handbook hddtemp hfs http iconv icq id3tag ieee1394 imagemagick imap inotify iplayer ipod ipv6 irc irda jabber jack java javascript jbig jfs joystick jpeg jpeg2k kate kdeenablefinal kdehiddenvisibility kerberos kipi kvm lame lastfm lcd lcms libcaca libgda libmpeg2 libnotify libsamplerate live lm_sensors logrotate lzma lzo mad mail matroska midi mikmod mjpeg mms mmx mmxext mng mod modules mono mozdevelop mp3 mp3rtp mp4 mpeg mpg123 mplayer msn mtp mudflap multilib musepack musicbrainz nautilus ncurses network network-cron networkmanager nfs nls nptl nsplugin ntfs ntp ogg ogm openal openexr opengl openmp pam pango pcre pda pdf pidgin playlist png podcast policykit postscript ppds pppd projectm pulseaudio python qt3support qt4 quicktime rar raw rdesktop readline recode reiser4 reiserfs rss rtmp ruby samba sbc scanner schroedinger sdl semantic-desktop sendto session slp smp sndfile socialweb sox speech speex spell srt srtp sse sse2 sse3 sse4 sse4_1 sse4a sse5 ssl ssse3 startup-notification stats stream svg sysfs system-sqlite taglib tcpd telepathy telnet theora threads tiff timidity truetype twolame udev udisks unicode upnp upower usb v4l v4l2 vaapi vcd vdpau video videos visualization vlc vmware_guest_linux vmware_guest_winPre2k vmware_guest_windows vnc vorbis vpx vxd wav webkit wifi wmf wxwidgets x264 xcb xcomposite xfs xine xinerama xml xmp xpm xprint xrandr xscreensaver xulrunner xv xvid xvmc yahoo youtube zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" DRACUT_MODULES="gensplash lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev keyboard mouse synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer scripting-beanshell scripting-javascript wiki-publisher nlpsolver pdfimport" LINGUAS="pl en" NETBEANS_MODULES="php groovy enterprise apisupport cnd java javafx websvccommon" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 cris i386 m68k microblaze mips mips64 mips64el mipsel ppc ppc64 ppcemb sh4 sh4eb sparc sparc64" QEMU_USER_TARGETS="alpha cris i386 m68k microblaze mips mipsel ppc ppc64 ppc64abi32 sh4 sh4eb sparc sparc32plus sparc64 x86_64" RUBY_TARGETS="ruby18 ruby19 jruby" SANE_BACKENDS="epson epson2 hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s xerox_mfp" USERLAND="GNU" VIDEO_CARDS="fbdev intel i915 i965 vesa nvidia nouveau nv" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I would like to know the reason of this behavior, because the greeter log is not pointing me at any direction.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 478
Location: Scotland

PostPosted: Thu Jan 03, 2013 2:29 pm    Post subject: Reply with quote

Quote:
I made sure to disable all extensions

I once had to remove the bad extension from the folder, otherwise I encountered the same problem.
I think the problem extension was for the weather.
So, it is one thing to disable the extensions, and it is another thing to actually remove it from the extensions folder.
I would remove all extensions and try again.

Also, if there is no information in the greeter log, then that is not to blame.
Is there a .xsession-errors file in your home folder?
It may also be of use.

Cheers.
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Sat Jan 05, 2013 5:22 am    Post subject: Reply with quote

Thanks for replay
Thistled wrote:

I once had to remove the bad extension from the folder, otherwise I encountered the same problem.
I think the problem extension was for the weather.


As I wrote I tested on clear new account. What I did to make sure it's not extension problem was removing (unmerging) gnome-extra/gnome-shell-frippery. Clearing whole home catalog for my test user, and trying to log in.
The outcome is still the same, same msgs in greeter.log. Then I remove gnome-extra/gnome-shell-extensions clear the whole home catalog again and try to log in again - same result. I don't think is an extension problem - something else in my environment is crushing gnome.

Thistled wrote:

Is there a .xsession-errors file in your home folder?
It may also be of use.

Cheers.


I'm afraid there is no .xsession-errors in test user home catalog.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
megaflow
n00b
n00b


Joined: 11 Mar 2005
Posts: 60
Location: Maasmechelen

PostPosted: Sat Jan 05, 2013 10:51 am    Post subject: Reply with quote

Thistled wrote:

Is there a .xsession-errors file in your home folder?
It may also be of use.


No gnome now report in ~/.cache/gdm/session.log

p.s do u use openrc or systemd as init
_________________
----------------------------
Dell System XPS L702X/0XN71K,Intel(R) Core(TM) i7-2720QM
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Sun Jan 06, 2013 2:42 am    Post subject: Reply with quote

megaflow wrote:

No gnome now report in ~/.cache/gdm/session.log


Thanks for the tip. This file do have some info:

Code:
/etc/gdm/Xsession: Beginning session setup...
localuser:test_user being added to access control list
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session
GNOME_KEYRING_CONTROL=/home/test_user/.cache/keyring-Xav0mw
GNOME_KEYRING_CONTROL=/home/test_user/.cache/keyring-Xav0mw
GNOME_KEYRING_CONTROL=/home/test_user/.cache/keyring-Xav0mw
SSH_AUTH_SOCK=/home/test_user/.cache/keyring-Xav0mw/ssh
GPG_AGENT_INFO=/home/test_user/.cache/keyring-Xav0mw/gpg:0:1
GNOME_KEYRING_CONTROL=/home/test_user/.cache/keyring-Xav0mw
SSH_AUTH_SOCK=/home/test_user/.cache/keyring-Xav0mw/ssh
Initializing tracker-store...
Initializing tracker-miner-fs...
Tracker-Message: Setting up monitor for changes to config file:'/home/test_user/.config/tracker/tracker-store.cfg'
Tracker-Message: Setting up monitor for changes to config file:'/home/test_user/.config/tracker/tracker-store.cfg'
Starting log:
  File:'/home/test_user/.local/share/tracker/tracker-store.log'
Tracker-Message: Setting up monitor for changes to config file:'/home/test_user/.config/tracker/tracker-miner-fs.cfg'
Starting log:
  File:'/home/test_user/.local/share/tracker/tracker-miner-fs.log'

HP Linux Imaging and Printing System (ver. 3.12.11)
System Tray Status Service ver. 2.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Failed to play sound: File or data not found
/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
** Message: applet now removed from the notification area
Loading configuration plugins
blueman-applet version 1.23 starting
Stale PID, overwriting
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend

(tracker-miner-fs:7943): Tracker-WARNING **: Couldn't properly parse desktop file 'file:///usr/share/desktop-directories/vmware-ace-vms.directory': 'Desktop file doesn't contain type'
Ostrzeżenie menedżera okien: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
    JS ERROR: !!!   Exception was: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
    JS ERROR: !!!     message = '"GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/components/polkitAgent.js"'
    JS ERROR: !!!     lineNumber = '329'
    JS ERROR: !!!     stack = '"0 anonymous()@/usr/share/gnome-shell/js/ui/components/polkitAgent.js:329
1 wrapper()@/usr/share/gjs-1.0/lang.js:204
2 anonymous("name" = ""polkitAgent"")@/usr/share/gnome-shell/js/ui/components/__init__.js:56
3 wrapper(""polkitAgent"")@/usr/share/gjs-1.0/lang.js:204
4 anonymous("name" = ""polkitAgent"", 1, [object Array])@/usr/share/gnome-shell/js/ui/components/__init__.js:22
5 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:21
6 wrapper()@/usr/share/gjs-1.0/lang.js:204
7 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:13
8 wrapper()@/usr/share/gjs-1.0/lang.js:204
9 anonymous()@/usr/share/gjs-1.0/lang.js:145
10 anonymous()@/usr/share/gjs-1.0/lang.js:239
11 start()@/usr/share/gnome-shell/js/ui/main.js:150
12 <TOP LEVEL>@<main>:1
"'
Ostrzeżenie menedżera okien: Log level 32: Execution of main.js threw exception: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
gnome-session[7851]: WARNING: Detected that screensaver has left the bus
Ostrzeżenie menedżera okien: Log level 16: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
    JS ERROR: !!!   Exception was: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
    JS ERROR: !!!     message = '"GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/components/polkitAgent.js"'
    JS ERROR: !!!     lineNumber = '329'
    JS ERROR: !!!     stack = '"0 anonymous()@/usr/share/gnome-shell/js/ui/components/polkitAgent.js:329
1 wrapper()@/usr/share/gjs-1.0/lang.js:204
2 anonymous("name" = ""polkitAgent"")@/usr/share/gnome-shell/js/ui/components/__init__.js:56
3 wrapper(""polkitAgent"")@/usr/share/gjs-1.0/lang.js:204
4 anonymous("name" = ""polkitAgent"", 1, [object Array])@/usr/share/gnome-shell/js/ui/components/__init__.js:22
5 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:21
6 wrapper()@/usr/share/gjs-1.0/lang.js:204
7 anonymous()@/usr/share/gnome-shell/js/ui/components/__init__.js:13
8 wrapper()@/usr/share/gjs-1.0/lang.js:204
9 anonymous()@/usr/share/gjs-1.0/lang.js:145
10 anonymous()@/usr/share/gjs-1.0/lang.js:239
11 start()@/usr/share/gnome-shell/js/ui/main.js:150
12 <TOP LEVEL>@<main>:1
"'
Ostrzeżenie menedżera okien: Log level 32: Execution of main.js threw exception: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
gnome-session[7851]: WARNING: App 'gnome-shell.desktop' respawning too quickly
gnome-session[7851]: WARNING: Detected that screensaver has left the bus
gnome-session[7851]: WARNING: Client '/org/gnome/SessionManager/Client7' failed to reply before timeout
error:  No system tray detected on this system.  Unable to start, exiting.
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x100001f
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 25 (X_SendEvent)
  Resource id:  0x100001f
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x100001f
gnome-session[7851]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
gnome-session[7851]: Gtk-CRITICAL: gtk_main_quit: assertion `main_loops != NULL' failed
applet.py: Fatal IO error 11 (Zasoby chwilowo niedostępne) on X server :3.
blueman-applet: Fatal IO error 11 (Zasoby chwilowo niedostępne) on X server :3.
polkit-mate-authentication-agent-1: Fatal IO error 11 (Zasoby chwilowo niedostępne) on X server :3.

(nm-applet:7939): Gdk-WARNING **: nm-applet: Fatal IO error 11 (Zasoby chwilowo niedostępne) on X server :3.

Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend

(gdu-notification-daemon:7958): Gdk-WARNING **: gdu-notification-daemon: Fatal IO error 11 (Zasoby chwilowo niedostępne) on X server :3.


(evolution-alarm-notify:7947): Gdk-WARNING **: evolution-alarm-notify: Fatal IO error 11 (Zasoby chwilowo niedostępne) on X server :3.

g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Received signal:15->'Zakończony'

(tracker-miner-fs:7943): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: Połączenie jest zamknięte

(tracker-miner-fs:7943): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: Połączenie jest zamknięte

(tracker-miner-fs:7943): GLib-GIO-CRITICAL **: Error while sending AddMatch() message: Połączenie jest zamknięte
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Received signal:15->'Zakończony'
OK


OK


Hmm i just wonder does bumblebee may have smth to do with this problem?

megaflow wrote:

p.s do u use openrc or systemd as init


I use openrc
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
megaflow
n00b
n00b


Joined: 11 Mar 2005
Posts: 60
Location: Maasmechelen

PostPosted: Sun Jan 06, 2013 9:10 pm    Post subject: Reply with quote

I'm using bumblebee too and dont have any probs at all

but when u install gnome-shell. it give this messages
Quote:
"GNOME Shell is unstable under gallium-mode i915/i965 mesa drivers."
"Make sure that classic architecture for i915 and i965 drivers is"
"selected using 'eselect mesa'."


I had some trouble with gnome-shell today. ( i clean my make.conf use flags ) After rebuilding nm-applet the issue when away.
But the differently with your comp is i use systemd as init

i never success in getting openrc and networkmanager to get along - my wireless connection always hardlock gnome ( all gnome versions)
_________________
----------------------------
Dell System XPS L702X/0XN71K,Intel(R) Core(TM) i7-2720QM
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Mon Jan 07, 2013 10:19 am    Post subject: Reply with quote

megaflow wrote:
I'm using bumblebee too and dont have any probs at all


Good to know.

Quote:
"GNOME Shell is unstable under gallium-mode i915/i965 mesa drivers."
"Make sure that classic architecture for i915 and i965 drivers is"
"selected using 'eselect mesa'."


I sow this massage when I was installing Gnome 3.4 - and I made sure to switch to classic arch even for sw. So this is not it.

megaflow wrote:

I had some trouble with gnome-shell today. ( i clean my make.conf use flags ) After rebuilding nm-applet the issue when away.
But the differently with your comp is i use systemd as init did

i never success in getting openrc and networkmanager to get along - my wireless connection always hardlock gnome ( all gnome versions)


I rebuild whole networkmanger and nm-applet w/o success same results :(
I never had problems networkmanger was working with Gnome 2.x, Mate 1.4 and finally Gnome 3.4.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
miknix
n00b
n00b


Joined: 29 Jan 2007
Posts: 4

PostPosted: Sat Jan 12, 2013 7:44 pm    Post subject: got the same problem Reply with quote

andrzejk, this is probably late but did you try doing a emerge --depclean after emerging gnome-3.6? Without it, I got similar error messages (both :0-slave.log and .cache/gdm/session.log), in particular:
Code:

(...)
GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
    JS ERROR: !!!   Exception was: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
    JS ERROR: !!!     message = '"GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject"'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/components/polkitAgent.js"'
    JS ERROR: !!!     lineNumber = '329'
    JS ERROR: !!!     stack = '"0 anonymous()@/usr/share/gnome-shell/js/ui/components/polkitAgent.js:329
(...)


gnome-session would then crash with an "oops..". Looks like that some packages from gnome-2/gnome-3.4 that are not needed anymore in gnome-3.6 were the cause of problem.

I hope this helps other users.
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Sun Jan 13, 2013 10:05 pm    Post subject: Re: got the same problem Reply with quote

miknix wrote:
andrzejk, this is probably late but did you try doing a emerge --depclean


Hmm I did not but now I did. Depclean did not remove anything significant to gome enviroment, just old gentoo-sorces, java virtual, some json package. After trying to log in to gnome 3.6 same result as before :(. However I can not rule out the possibility that the Mate environment I still have installed is causing some problems to Gmome 3.6, I used Gnome 3.4 along side Mate w/o problem. Removing Mate at the moment is not possible this is currently my only computer and most important tool I use to earn some money. I think It's time to gave up. Seems Gmome 3.6 hates me. Sad thing I can not recall when was the last time I gave up on something on Linux. :(
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
miknix
n00b
n00b


Joined: 29 Jan 2007
Posts: 4

PostPosted: Mon Jan 14, 2013 12:14 am    Post subject: Reply with quote

andrzejk before installing gnome-3.6 I actually had installed mate from the sabayon overlay. Doing a emerge --depclean did in fact remove a bunch of the mate packages, so I would say that mate might be the problem.
Since mate is your current environment and you need it quickly, what about you use quickpkg to create binary packages of your emerged mate and related dependencies? That way you can unmerge mate to test gnome-3.6 and then use emerge to install the binary packages (as opposed to compiling them). If this is not acceptable I can build a list of potential directories which you can have a look at to identify possible mate software that is autostarted during session and causes policykit to go nuts.
What do you think?
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Mon Jan 14, 2013 4:34 pm    Post subject: Reply with quote

miknix wrote:
what about you use quickpkg to create binary packages of your emerged mate and related dependencies? That way you can unmerge mate to test gnome-3.6 and then use emerge to install the binary packages (as opposed to compiling them).


This is a good idea, I will try to do it, however I got flu so I don't think I will be able to do it before the end of the week. I will post the results, thanks.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
inkUA
n00b
n00b


Joined: 18 Jan 2013
Posts: 4

PostPosted: Fri Jan 18, 2013 7:48 pm    Post subject: Reply with quote

Hi,

I had a somewhat similar problem when gnome-shell did not start, but all the autostart applications worked and I was able to see a clean wallpaper and a mouse pointer.
Then I realized that I had run metacity --replace manually (for some reason it stopped being a default WM for my old GNOME 2), so I just removed this launcher and was able to use gnome-shell (uses WM mutter).

Not sure if this will help, but I guess it worth to check.
Back to top
View user's profile Send private message
andrzejk
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 139
Location: Warsaw, Poland

PostPosted: Sat Jan 19, 2013 8:22 pm    Post subject: Reply with quote

Today I finally manage to get out of bed, create the binary packages from mate set, and remove whole mate enviroment to see if this will help.
And it did after removing Mate and then deplcean - whole mate was removed from the system and Gnome shell loaded correctly.
Seems Gnome 3.6 have to be installed separately from Mate, 3.4 did not have this problem. Not sure if I will choose Gnome 3.x at the end it still lacks few things I got used to, but at least I can fully test it.
Thanks a lot for help guys.
_________________
Dell XPS Gentoo 3.12.2 GCC 4.8.2 KDE 4.11
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum