Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[NTP] heure reçue en avance de 30 min environ [RESOLU]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
RealNoob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2004
Posts: 75

PostPosted: Sun Dec 30, 2012 3:49 pm    Post subject: [NTP] heure reçue en avance de 30 min environ [RESOLU] Reply with quote

Bonjour,

Je n'ai plus allumé ma machine depuis plus d'un an (~460 jours pour être plus précis), maintenant, lorsque sntp récupère l'heure depuis l'un des serveurs configurer dans /etc/ntp.conf, elle est toujours en avance de +/- 30 min par rapport à la date réelle.

Je tiens aussi à signaler que le système n'est pas encore remis à jour, je veux régler ce problème avant de remettre le système à niveau.

Est-ce que quelqu'un a une idée de la source du problème?

Voici le contenu de /etc/ntp.conf:

Code:

# NOTES:
# DHCP clients can append or replace NTP configuration files.
# You should consult your DHCP client documentation about its
# default behaviour and how to change it.

# Name of the servers ntpd should sync with
# Please respect the access policy as stated by the responsible person.
#server         ntp.example.tld         iburst

server 0.be.pool.ntp.org
server 1.be.pool.ntp.org
server 2.be.pool.ntp.org
server 3.be.pool.ntp.org

# Common pool for random people
#server pool.ntp.org

# Pools for Gentoo users
server 0.gentoo.pool.ntp.org
server 1.gentoo.pool.ntp.org
server 2.gentoo.pool.ntp.org
server 3.gentoo.pool.ntp.org

##
# A list of available servers can be found here:
# http://www.pool.ntp.org/
# http://www.pool.ntp.org/#use
# A good way to get servers for your machine is:
# netselect -s 3 pool.ntp.org
##

# you should not need to modify the following paths
driftfile       /var/lib/ntp/ntp.drift

#server ntplocal.example.com prefer
#server timeserver.example.org

# Warning: Using default NTP settings will leave your NTP
# server accessible to all hosts on the Internet.

# If you want to deny all machines (including your own)
# from accessing the NTP server, uncomment:
restrict default ignore


# To deny other machines from changing the
# configuration but allow localhost:
restrict default nomodify nopeer
restrict 127.0.0.1


# To allow machines within your network to synchronize
# their clocks with your server, but ensure they are
# not allowed to configure the server or used as peers
# to synchronize against, uncomment this line.
#
#restrict 192.168.0.0 mask 255.255.255.0 nomodify nopeer notrap


Et voici le contenu de /etc/conf.d/hwclock
Code:

# Set CLOCK to "UTC" if your Hardware Clock is set to UTC (also known as
# Greenwich Mean Time).  If that clock is set to the local time, then
# set CLOCK to "local".  Note that if you dual boot with Windows, then
# you should set it to "local".
clock="UTC"

# If you want to set the Hardware Clock to the current System Time
# (software clock) during shutdown, then say "YES" here.
# You normally don't need to do this if you run a ntp daemon.
clock_systohc="YES"

# If you want to set the system time to the current hardware clock
# during bootup, then say "YES" here. You do not need this if you are
# running a modern kernel with CONFIG_RTC_HCTOSYS set to y.
# Also, be aware that if you set this to "NO", the system time will
# never be saved to the hardware clock unless you set
# clock_systohc="YES" above.
clock_hctosys="NO"
 
# If you wish to pass any other arguments to hwclock during bootup,
# you may do so here. Alpha users may wish to use --arc or --srm here.
clock_args=""

_________________
Luke, use the F.O.S.S.


Last edited by RealNoob on Sun Dec 30, 2012 6:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 3:57 pm    Post subject: Reply with quote

la simple commande "date" te sort quoi?

Au pif, comme ça, cela doit être une mauvaise définition de timezone. Quel est le contenu de ton /etc/timezone ?
Back to top
View user's profile Send private message
RealNoob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2004
Posts: 75

PostPosted: Sun Dec 30, 2012 4:07 pm    Post subject: Reply with quote

La commande 'date' me donne "dim déc 30 17:37:51 CET 2012" alors que l'heure devrait être "17:06".

Le contenu de /etc/timezone est 'Europe/Brussels'. Ce qui est la valeur attendue.
_________________
Luke, use the F.O.S.S.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 4:28 pm    Post subject: Reply with quote

Mmmmm....

et
Code:
ntpdate ntp1.belbone.be
?
Back to top
View user's profile Send private message
RealNoob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2004
Posts: 75

PostPosted: Sun Dec 30, 2012 4:34 pm    Post subject: Reply with quote

Code:
ntpdate ntp1.belbone.be

Résultat de la commande:
Code:
30 Dec 17:32:40 ntpdate[13307]: step time server 195.13.23.5 offset -1935.721495 sec

_________________
Luke, use the F.O.S.S.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 4:36 pm    Post subject: Reply with quote

ok, donc lui il voit bien qu'il y a un stuuuuut.

Tu refais la même commande avec -u comme option et il va mettre (violemment) à jour l'heure.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 4:41 pm    Post subject: Reply with quote

Petit détail. Tu as bien le service ntpd lancé?

Pour rappel, ce service, il va mettre l'heure à jour petit à petit (pas de saut dans le temps). Donc ça prend du temps de récupérer 30 minutes!
Back to top
View user's profile Send private message
RealNoob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2004
Posts: 75

PostPosted: Sun Dec 30, 2012 4:50 pm    Post subject: Reply with quote

Le service ntpd ce n'est pas pour faire de la machine un serveur de temps?
_________________
Luke, use the F.O.S.S.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 5:02 pm    Post subject: Reply with quote

C'est pour les deux! Tout dépend de la config.

Petit rappel:

Tu as 2 horloges: l'hardware et la software.
L'hardware, c'est "ton horloge bios". Dans systohc, c'est hc :)
La software, c'est celle que tu vois habituellement, la sortie de "date", par exemple. Bien évidemment, la software, elle n'existe pas quand ta machine est coupée.

Donc, au boot, ton système doit initialiser l'horloge système (ou software). De base, c'est copier/coller de la HC. Pour ça, c'est sympa d'avoir la HC +/- à jour, d'où la variable clock_systohc="true" qui va permettre, au shutdown, de mettre à jour le HC avec la softclock que l'on suppose ici à jour.

Alternativement, tu peux utiliser /etc/init.d/ntpclient qui va juste mettre à jour violemment la clock systeme au boot et rien d'autre!

Pour maintenant l'heure à jour par la suite, c'est le boulot de ntpd.
Back to top
View user's profile Send private message
RealNoob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2004
Posts: 75

PostPosted: Sun Dec 30, 2012 5:16 pm    Post subject: Reply with quote

Ce qui est étrange, si je te suis bien, c'est que normalement le démarrage au boot du service ntp-client aurait du arranger le problème, non?
_________________
Luke, use the F.O.S.S.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 5:43 pm    Post subject: Reply with quote

s'il est configuré à moitié correctement oui. Faudrait voir s'il n'y a pas un message d'erreur
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 419
Location: La Louviere (Belgique)

PostPosted: Sun Dec 30, 2012 6:22 pm    Post subject: Reply with quote

Bonsoir,

La diff temps existera tant que l'horloge du PC n'est pas mis à jour (offset -1935.721495 sec)

Perso dans /etc/conf.d/hwclock : la seule ligne que j'utilise est : clock="local"

Ayant eu des problèmes avec l'horloge (pas vraiment chercher non plus), j'ai force le lien /etc/locatime vers /usr/share/zoneinfo/Europe/Brussels

Espère que cela pourra t'aider
Back to top
View user's profile Send private message
RealNoob
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2004
Posts: 75

PostPosted: Sun Dec 30, 2012 6:29 pm    Post subject: Reply with quote

Finallement, j'ai activé ntpd et le problème c'est corrigé de lui-même après quelque minute.


Merci pour votre aide.


Bon réveillons et bonne année.
_________________
Luke, use the F.O.S.S.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Sun Dec 30, 2012 7:38 pm    Post subject: Reply with quote

USTruck wrote:
Bonsoir,

La diff temps existera tant que l'horloge du PC n'est pas mis à jour (offset -1935.721495 sec)

Perso dans /etc/conf.d/hwclock : la seule ligne que j'utilise est : clock="local"

Ayant eu des problèmes avec l'horloge (pas vraiment chercher non plus), j'ai force le lien /etc/locatime vers /usr/share/zoneinfo/Europe/Brussels

Espère que cela pourra t'aider


Le clock à "local", c'est pas top cool (mais indispensable si le système est en multiboot avec un windows)
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3756
Location: Lyon, France

PostPosted: Mon Dec 31, 2012 10:12 pm    Post subject: Reply with quote

Poussin wrote:
Le clock à "local", c'est pas top cool (mais indispensable si le système est en multiboot avec un windows)

Nan Windows peut être configuré pour fonctionner avec l'heure UTC, à coup de clé de registre qui va bien (trouvable en 2s avec Google). C'est ce que je fais chez moi. Faut juste faire gaffe parce qu'il parait que ça peut faire déconner certains applications, mais jusque là je n'ai eu aucun problème. :)
_________________
Google+ | Twitter
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum