Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Root Filesystem Mounting Read Only [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tabanus
Guru
Guru


Joined: 11 Jun 2004
Posts: 580
Location: UK

PostPosted: Sun Dec 30, 2012 1:36 am    Post subject: Root Filesystem Mounting Read Only [Solved] Reply with quote

I decided to re-install Gentoo to move from 32 to 64 bit. But now, the root file system is getting mounted read only. I can manually re-mount read-write at the end of the boot process, but I'd prefer a proper solution.

The error seems to come when starting the root service, and I get the error:

"root filesystem could not be mounted read/write"

The stage 3 that I installed had openrc-0.11.8. Downgrading to 0.11.6 made no difference

In my kernel config (gentoo-sources-3.7.1) I have

# CONFIG_DEVTMPFS is not set
CONFIG_TMPFS=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_TMPFS_XATTR=y

I tried initially with CONFIG_DEVTMPFS=y but it didn't work either.

Re-installing udev not helped either.
_________________
Never underestimate a hamster.


Last edited by tabanus on Sun Dec 30, 2012 3:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Dec 30, 2012 1:47 am    Post subject: Reply with quote

tabanus,

This might not solve your problem immediately, but these should be set: CONFIG_DEVTMPFS=y and CONFIG_DEVTMPFS_MOUNT=y
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
tabanus
Guru
Guru


Joined: 11 Jun 2004
Posts: 580
Location: UK

PostPosted: Sun Dec 30, 2012 2:53 am    Post subject: Reply with quote

BillWho wrote:
tabanus,

This might not solve your problem immediately, but these should be set: CONFIG_DEVTMPFS=y and CONFIG_DEVTMPFS_MOUNT=y


OK, I've re-set them, not made any difference though, and my old 32-bit install doesn't have this set.
_________________
Never underestimate a hamster.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 426

PostPosted: Sun Dec 30, 2012 3:25 am    Post subject: Reply with quote

tabanus wrote:
BillWho wrote:
tabanus,

This might not solve your problem immediately, but these should be set: CONFIG_DEVTMPFS=y and CONFIG_DEVTMPFS_MOUNT=y


OK, I've re-set them, not made any difference though, and my old 32-bit install doesn't have this set.


Under psuedo-filesystems in menuconfig make sure tmpfs is checked. I already went through the rounds with that problem just a few days ago. I had exactly the same symptoms you describe.

EDIT: i didnt read your opening post well enough. It seems you already have tmpfs set.
_________________
MB: Biostar TForce 6100 AM2 @ 250x10
CPU: AMD Athlon 64 3800+ X2 @ 2500mhz
MEM: G. Skill DDR2-800 2GB @ DDR2-1000
GPU: nVidia GeForce 7600 GT
OS: Gentoo Linux 2006.1
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Dec 30, 2012 4:21 am    Post subject: Reply with quote

tabanus,

wgetpaste dmesg and paste your fstab and menu.config or grub.cfg whichever one you're using.
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
tabanus
Guru
Guru


Joined: 11 Jun 2004
Posts: 580
Location: UK

PostPosted: Sun Dec 30, 2012 12:16 pm    Post subject: Reply with quote

duby2291 wrote:
Under psuedo-filesystems in menuconfig make sure tmpfs is checked. I already went through the rounds with that problem just a few days ago. I had exactly the same symptoms you describe.

EDIT: i didnt read your opening post well enough. It seems you already have tmpfs set.


Yep saw your message thread

BillWho wrote:
wgetpaste dmesg and paste your fstab and menu.config or grub.cfg whichever one you're using.


Kernel Config: http://pastebin.com/WKY02Pgq

dmesg: http://pastebin.com/KVpCwiwq

grub.conf:

Code:
default 0
timeout 2
splashimage=(hd0,0)/grub/splash.xpm.gz

title=64bit Gentoo
root (hd0,0)
kernel /boot/bzImage root=/dev/sda1

title=32bit Gentoo.
root (hd0,0)
kernel /boot/bzImage-32 root=/dev/sdb2



fstab:

Code:
# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

UUID="58659a40-b6a5-42ab-b253-b2ee4d4cea84"   /boot   ext2   noauto,noatime         1 2

/dev/sda1               /   ext4   noatime,data=writeback,discard   0 1

UUID="fa4a676a-b4e5-45bf-be7f-f29c9468b802"   /mnt/DVD   xfs   noatime         0 2

/dev/sdb6      none      swap      sw               0 0

UUID="844e50aa-bf73-49e3-90c8-46737b5aa948"   /home      ext4   noatime         0 2

/home/.portage      /usr/portage   none      bind               0 0

shm         /dev/shm   tmpfs      nodev,nosuid,noexec   0 0

tmpfs      /var/tmp/portage   tmpfs  size=3G         0 0

_________________
Never underestimate a hamster.
Back to top
View user's profile Send private message
gabrielg
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2012
Posts: 87

PostPosted: Sun Dec 30, 2012 1:08 pm    Post subject: Reply with quote

This one is suspicious, even though it doesn't hint to mounting anything read only:
Code:

EXT4-fs (sda1): Cannot change data mode on remount


Did you try fiddling with your data mode in /etc/fstab?

It might not help, but I used to pass this to the kernel:
Code:

rootfstype=ext4


I cannot remember whether this was a genkernel requirement only though.

Good luck!
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Sun Dec 30, 2012 2:21 pm    Post subject: Reply with quote

tabanus,

To take the process of elimination approach, try just defaults or noatime for your root mount options in fstab.

According to man mount, sufficient testing hasn't yet been done for discard although that could be outdated.

Also you can append rootfstype=ext4 as gabrielg suggested.
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
tabanus
Guru
Guru


Joined: 11 Jun 2004
Posts: 580
Location: UK

PostPosted: Sun Dec 30, 2012 3:00 pm    Post subject: Reply with quote

Thanks for the replies. Taking out data=writeback seems to have done the trick.

I think the difference with my old 32-bit install on this SSD is that I also did "tune2fs -o discard" to enable trim on the drive, and there appears to be some incompatibility with "data=writeback".

Not sure which I want most though, trim or no journalling.
_________________
Never underestimate a hamster.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum