Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SSD reinstall bootup failure SOLVED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
littlemanrkc
n00b
n00b


Joined: 21 Jul 2006
Posts: 8

PostPosted: Fri Dec 28, 2012 6:28 am    Post subject: SSD reinstall bootup failure SOLVED Reply with quote

I received a nice shiny new OCZ Agility 4 SSD drive for Christmas. My hope was to simply copy all of / (minus proc, dev, and sys) to the new hard drive, modify fstab, reinstall grub, and be up and running with the new drive (rather than reinstall everything from scratch). I can't seem to boot from this new drive after doing all this. I can boot from the old hard drive and mount the SSD just fine. When I reinstall grub from a chroot, no errors are reported and all drives are listed as I expect.

The errors I get during bootup are as follows:

Code:
EXT2-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
VFS: Mounted root (ext4 filesystem) readonly on device 8:2.
Freeing unused kernel memory: 496k freed
ata1.00: exception Emask 0x10 SAct 0x1 SErr 0x100000 action 0x6 frozen
ata1.00: irq_stat 0x08000000, interface fatal error
ata1: SError: { Dispar }
ata1.00: failed command: READ FPDMA QUEUED
ata1.00: cmd 60/08:00:00:09:82/01:00:0c:00:00/40 tag 0 ncq 135168 in
          res 40/00:04:00:09:82/00:00:0c:00:00/40 Emask 0x10 (ATA bus error)
ata1.00: status { DRDY }
ata1: hard resetting link
ata1: SATA link up to 6.0 Gbps (SStatus 133 SControl 370)
ata1.00: configured for UDMA/133
ata1: EH complete


It locks up following this. Normally OpenRC would kick in next. Any ideas what might be wrong? Thanks.


Last edited by littlemanrkc on Fri Jan 25, 2013 11:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5190

PostPosted: Fri Dec 28, 2012 2:12 pm    Post subject: Reply with quote

Well, I know you were hoping to avoid a complete install, but that would be the first thing I would do to make sure it's working.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
littlemanrkc
n00b
n00b


Joined: 21 Jul 2006
Posts: 8

PostPosted: Fri Jan 25, 2013 11:41 pm    Post subject: Reply with quote

The problem appears to be the SATA3 Marvell 88SE9123 controller. When I connect the hard drive to my SATA2 Intel ICH10 controller, everything works properly. My motherboard is an Asus P6X58D Premium. The Marvell controller works properly with my 2TB spinning hard drive; it just doesn't seem to work with the SSD.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum