Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems installing eclipse 3.7.1-r7 from overlay seden
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
theblackraven
n00b
n00b


Joined: 12 Oct 2005
Posts: 7

PostPosted: Wed Oct 17, 2012 5:53 am    Post subject: problems installing eclipse 3.7.1-r7 from overlay seden Reply with quote

hi,
i have a problem to install eclipse-sdk- 3.7.1-r7 from the overlay and i didn't find i solution with google.
here are the last rows of the logfile: http://pastebin.com/0NDQzfKp

greetings
Back to top
View user's profile Send private message
lindegur
Apprentice
Apprentice


Joined: 14 Aug 2004
Posts: 257
Location: Swiss mountains

PostPosted: Fri Dec 14, 2012 4:57 pm    Post subject: Reply with quote

I could emerge eclipse from seden overlay a couple of moths ago and was happy with it. :lol:
But now it does not emerge anymore. :cry:

Since I rather prefer to work with eclipse than struggle with emerging it, I'm going to try out the binary package from the java-overlay. At least it emerged fine and I started it without any crash. :lol:
So the next step is really to use it (on my android project) to see if it satisfies my needs. :roll:


Last edited by lindegur on Mon Dec 17, 2012 8:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1377
Location: Bardowick, Germany

PostPosted: Mon Dec 17, 2012 8:46 am    Post subject: Reply with quote

Well, it would emerge quite well if you did not try to use icedtea. Please use dev-java/sun-jdk:1.6.

Maybe I should add a warning or a blocker. Yes, I should do that.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1377
Location: Bardowick, Germany

PostPosted: Mon Dec 17, 2012 8:54 am    Post subject: Reply with quote

Yamakuzure wrote:
(...)Maybe I should add a warning or a blocker. Yes, I should do that.
Done:
Code:
[blocks B      ] dev-java/icedtea ("dev-java/icedtea" is blocking dev-util/eclipse-sdk-3.7.1-r8)
[blocks B      ] dev-java/icedtea-bin ("dev-java/icedtea-bin" is blocking dev-util/eclipse-sdk-3.7.1-r8)

_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
lindegur
Apprentice
Apprentice


Joined: 14 Aug 2004
Posts: 257
Location: Swiss mountains

PostPosted: Mon Dec 17, 2012 8:07 pm    Post subject: Reply with quote

Dear Yamakuzure first a big thank you for your quick response and support :wink:

In fact I somehow ended up with icedtea. But I switched back to dev-java/sun-jdk:1.6.
Then I updated the overlay to get dev-util/eclipse-sdk-3.7.1-r8::seden
Then I had to remove icedtea due to the blockage.

Unfortunately the emerge fails with
Code:
compile.libgnomeproxy:
     [exec] Building file: gnomeproxy.o
     [exec] Invoking: GCC C Compiler
     [exec] gcc -I/usr/include/gconf/2/ -I/usr/include/orbit-2.0/ -I/usr/include/glib-2.0/ -I/usr/lib/glib-2.0/include/ -I/opt/sun-jdk-1.6.0.37/include -I/opt/sun-jdk-1.6.0.37/include/linux -I/opt/sun-jdk-1.6.0.37/include -I/opt/sun-jdk-1.6.0.37/include/linux -O0 -fPIC -g3 -Wall -c -fmessage-length=0 -m32 -o gnomeproxy.o ../gnomeproxy.c
     [exec] In file included from ../gnomeproxy.c:16:0:
     [exec] /usr/include/glib-2.0/glib/gslist.h:28:2: error: #error "Only <glib.h> can be included directly."
     [exec] make: *** [compile] Error 1

BUILD FAILED
/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.xml:529: The following error occurred while executing this line:
/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build/build.xml:495: exec returned: 2

Total time: 3 minutes 43 seconds
 * ERROR: dev-util/eclipse-sdk-3.7.1-r8 failed (compile phase):
 *   eant failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 4415:  Called eant '-DbuildArch=x86'
 *   environment, line  841:  Called die
 * The specific snippet of code:
 *       ant ${antflags} "${@}" || die "eant failed"
 *
 * If you need support, post the output of `emerge --info '=dev-util/eclipse-sdk-3.7.1-r8'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/eclipse-sdk-3.7.1-r8'`.
 * This ebuild is from an overlay named 'seden': '/var/lib/layman/seden/'
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.37"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER="javac"
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build'
 * S: '/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/work/org.eclipse.linuxtools.eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d/eclipse-build'

>>> Failed to emerge dev-util/eclipse-sdk-3.7.1-r8, Log file:

>>>  '/var/tmp/portage/dev-util/eclipse-sdk-3.7.1-r8/temp/build.log'

 * GNU info directory index is up-to-date.
Back to top
View user's profile Send private message
cibonato
Apprentice
Apprentice


Joined: 25 Apr 2006
Posts: 200
Location: Macross City

PostPosted: Tue Dec 18, 2012 12:19 am    Post subject: Reply with quote

I got the very same message as lindegur and also there's no icedtea package in my system.

Greetings.
_________________
64 Bits, good good!
Back to top
View user's profile Send private message
cibonato
Apprentice
Apprentice


Joined: 25 Apr 2006
Posts: 200
Location: Macross City

PostPosted: Tue Dec 18, 2012 12:45 am    Post subject: Reply with quote

cibonato wrote:
I got the very same message as lindegur and also there's no icedtea package in my system.

Greetings.


Just a couple of things:

1) I am not use seden overlay, but actually flora overlay (it provides eclipse-sdk-3.7.1-r2)

2) I was able to compile this package using: $USE="-gnome" emerge dev-util/eclipse-sdk

But I couldn't say it is solved because right now my problems are regarding to some SWT libraries.

Here goes just a small fragment of the log:

Code:
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
        no swt-gtk-3738 in java.library.path
        no swt-gtk in java.library.path
        Can't load library: /home/cibonato/.swt/lib/linux/x86/libswt-gtk-3738.so
        Can't load library: /home/cibonato/.swt/lib/linux/x86/libswt-gtk.so


Greetings.
_________________
64 Bits, good good!
Back to top
View user's profile Send private message
cibonato
Apprentice
Apprentice


Joined: 25 Apr 2006
Posts: 200
Location: Macross City

PostPosted: Tue Dec 18, 2012 2:17 am    Post subject: Reply with quote

Now I would say I found a proper solution for this problem.

As I said before, I'm using overlay flora and it provides eclipse-sdk-3.7.1-r2 (I'm OK with this version). To be able to compile this version I had to chose -gnome in USE variable; so it was compiled using this comand:

Code:
USE="-gnome" emerge eclipse-sdk


After that I started having problems with SWT library; in a previous message you'll find a piece of the log. Digging a little bit around it is supposed Eclipse version and SWT must be the very same. So, I had to downgrad SWT to 3.7.1 and mask 3.7.2.

The option -gnome didn't seem to affect visual aspects of Eclipse so I'm happy with it. The compilation worked using sun-jdk-1.6.0.37 and oracle-jdk-bin-1.7.0.9 (this one is going to be ripped of soon).

And a last word regarding -gnome issue: https://bugs.eclipse.org/bugs/show_bug.cgi?id=385047

This link seems to clarify a little bit about the problem. Glib can be included only once and it seems Eclipse doesn't do that (I mean glib.h and gslist.h are being both included, but onle glib.h is mandatory), they said in the bug report: "glib doesn't allow for any other inclusions than glib.h. This was announced a long time ago, and finally introduced in recent versions of glib. glib already includes gslist"

There are some patches along the bugreport but it is for 4.x branch.

I hope it can help you and please let people know if it worked or not.

Greetings.
_________________
64 Bits, good good!
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1377
Location: Bardowick, Germany

PostPosted: Tue Dec 18, 2012 9:22 am    Post subject: Reply with quote

Ah, this clarifies a lot, thank you for sharing. I have a (as much as possible) gnome-free system, so I never ran into that problem. But I'd rather like to try to create an ebuild for eclipse-sdk-4.2 than trying to fix 3.7.x. However, I do not think this will be possible for me before 2013 (if the world doesn't explode or anything), because I have much on my plate at the moment, and Eclipse is nothing to whip up an ebuild for in a day or two, I'm afraid.

However, I think this can be patched rather easily, so I'll see what can be done for the old 3.7.1.

btw.: -r8 just means that I have changed the ebuild 8 times. Same goes with flora overlay, I guess. The important part is "3.7.1", so both are emerging the same version of Eclipse. ;)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 233

PostPosted: Tue Dec 18, 2012 9:19 pm    Post subject: Reply with quote

It is possible to make an ebuild for the 3.8 series?
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1377
Location: Bardowick, Germany

PostPosted: Wed Dec 19, 2012 9:24 am    Post subject: Reply with quote

cruzki123 wrote:
It is possible to make an ebuild for the 3.8 series?
Oh, that is at least easier than 4.2.x, which I started today. But my eclipse-sdk-4.2.0.ebuild currently can only fetch, unpack and prepare. It will take some time to get it finished.

As for the USE="-gnome" thing, I tried the following:
Code:
USE="gnome" ebuild /var/lib/layman/seden/dev-util/eclipse-sdk/eclipse-sdk-3.7.1-r8.ebuild install
and ended up with the following message:
Code:
>>> Completed installing eclipse-sdk-3.7.1-r8 into /home/portage/dev-util/eclipse-sdk-3.7.1-r8/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line
   usr/lib64/eclipse-3.7/eclipse
   usr/lib64/eclipse-3.7/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so
So using the ebuild directly does not seem to allow me to reproduce the "Only <glib.h> can be included directly."-issue. :-(
It seems the USE was ignored, libgnomeproxy is not built according to the log file.

I'll report back after I have done a full emerge of eclipse-sdk with USE flag "gnome" enabled, then.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1377
Location: Bardowick, Germany

PostPosted: Wed Dec 19, 2012 9:46 am    Post subject: Reply with quote

I just saw that while eclipse-3.7.1 is still available from http://download.eclipse.org/technology/linuxtools/eclipse-build, eclipse-3.8.0 has been moved to the archives with the note: "Older releases moved to archive.eclipse.org".

I am therefore a bit puzzled right now about whether it might be indeed useful to add an ebuild for 3.8.0?

Edith wants to note: My eclipse-sdk-4.2.0.ebuild now successfully prepares eclipse-4.2.0. But I am a bit of a coward now and happy that my debugging of 3.7.1 with gnome USE flag is preventing me to start compiling 4.2.0. :wink:

Edith is sorry:
Code:
sed-notebook ~ # USE="gnome" emerge --ask --update eclipse-sdk

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-util/eclipse-sdk-3.7.1-r8:3.7::seden [3.7.1-r7:3.7::seden] USE="doc gnome* -source" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] yes
>>> Verifying ebuild manifests
>>> Running pre-merge checks for dev-util/eclipse-sdk-3.7.1-r8
 * Checking for at least 1280 megabytes RAM ...                                                                   [ ok ]
 * Checking for at least 3072 megabytes disk space at "/home/portage/dev-util/eclipse-sdk-3.7.1-r8/temp" ...      [ ok ]
>>> Emerging (1 of 1) dev-util/eclipse-sdk-3.7.1-r8 from seden
>>> Installing (1 of 1) dev-util/eclipse-sdk-3.7.1-r8
>>> Jobs: 1 of 1 complete                           Load avg: 2.07, 2.88, 2.21

( ... snip ... )
 * Messages for package dev-util/eclipse-sdk-3.7.1-r8:

 * Package:    dev-util/eclipse-sdk-3.7.1-r8
 * Repository: seden
 * Maintainer: sven.eden@ggmx.de
 * USE:        amd64 consolekit doc elibc_glibc gnome kernel_linux multilib policykit userland_GNU
 * FEATURES:   ccache preserve-libs sandbox splitdebug userpriv usersandbox
 * Checking for at least 1280 megabytes RAM ...
 * Checking for at least 3072 megabytes disk space at "/home/portage/dev-util/eclipse-sdk-3.7.1-r8/temp" ...
 * Using: sun-jdk-1.6
 * Having the 'doc' USE flag enabled greatly increases the build time.
 * You might want to disable it for eclipse-sdk if you don't need it.
 * Using javac for compilation
 * Disabling all optional ANT_TASKS
 * Disabling all optional ANT_TASKS
 * Removing plugins of irrelevant platforms ...
 * Removing source plugins ...
 * Linking dependencies ...
( ... snip ... )
 * Applying hamcrest-junit-lib.patch ...
 * Applying gtk_makefile.patch ...
 * Applying iterators.patch ...
 * Disabling all optional ANT_TASKS
 * Relinking dependencies ...
( ... snip ... )
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
Sorry, I can't reproduce the problem. Maybe its gone due to some new upstream patches? The eclipse-build archive is taken from git, so mine might be more current and have a patch for the problem already.

The file you might want to try to delete is eclipse-build-9e028fbc74e844e96a6fd944d7d4f68909283a5d.tar.bz2 from your distfiles directory.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 233

PostPosted: Wed Dec 19, 2012 10:39 am    Post subject: Reply with quote

Yamakuzure wrote:
I just saw that while eclipse-3.7.1 is still available from http://download.eclipse.org/technology/linuxtools/eclipse-build, eclipse-3.8.0 has been moved to the archives with the note: "Older releases moved to archive.eclipse.org".

I am therefore a bit puzzled right now about whether it might be indeed useful to add an ebuild for 3.8.0?

Edith wants to note: My eclipse-sdk-4.2.0.ebuild now successfully prepares eclipse-4.2.0. But I am a bit of a coward now and happy that my debugging of 3.7.1 with gnome USE flag is preventing me to start compiling 4.2.0. :wink:


My experience is that 4.2 is SOOOOOOOO slow that you want to get out your eyes.

On the other hand, I haven't got any problem compiling and using eclipse with OpenJDK-1.7 (icedtea 7.2.3.3).
Back to top
View user's profile Send private message
lindegur
Apprentice
Apprentice


Joined: 14 Aug 2004
Posts: 257
Location: Swiss mountains

PostPosted: Sat Dec 22, 2012 7:27 am    Post subject: Reply with quote

Code:
USE="-gnome" emerge  =eclipse-sdk-3.7.1-r8

emerged fine :lol:
Having gnome, I started eclipse and was surprised that it came up promising. Within the next days I'm going to try working with it (developing android apps) :roll:
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1377
Location: Bardowick, Germany

PostPosted: Thu Dec 27, 2012 4:03 pm    Post subject: Reply with quote

Good that it works now.

And now that icedtea7 is available from the portage tree (dunno how long now, I never paid attention) it can be noted that Eclipse is perfectly fine with it. It is only icedtea6 that has a problem.

I'll fix the ebuild tomorrow.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
AstroFloyd
n00b
n00b


Joined: 18 Oct 2011
Posts: 8

PostPosted: Thu Dec 27, 2012 9:01 pm    Post subject: Reply with quote

Yamakuzure wrote:
I'll fix the ebuild tomorrow.
Great, thanks! :D
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 402
Location: münchen.de

PostPosted: Fri Dec 28, 2012 11:35 am    Post subject: Reply with quote

cruzki123 wrote:
My experience is that 4.2 is SOOOOOOOO slow that you want to get out your eyes.


The Juno release has a terribly slow UI - 4 cores, ssd but 3 to 10 seconds to switch an editor. There are many bug reports at eclipse bugzilla and even a wiki page. Using updates from the repository improved the situation for me. Now i am using the 4.2 weekly maintenance build which is again faster.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum