Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]System interpretiert CMOS-Uhr immer als UTC
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gilgwath
n00b
n00b


Joined: 09 Dec 2010
Posts: 12

PostPosted: Wed Dec 26, 2012 6:55 pm    Post subject: [SOLVED]System interpretiert CMOS-Uhr immer als UTC Reply with quote

Hallo Gentoo-Forum

Ich komm mir fast ein Bisschen doof vor wegen so etwas einen Thread auf zu machen, leider steh ich wirklich an der Wand bei diesem Problem. Tatsächlich wühle ich mich bereits seit 2 Tagen durch X Forenthreads und How-To's, aber leider ohne erfolg. Ganz kurz gefasst lässt sich mein System partout nicht dazu überreden mir nach dem Systemstart die richtige Zeit anzuzeigen. Doch zuerst einige Infos zu Systemkomponenten die evtl darin verwickelt sind.

  • Kernel: gentoo-sources-3.4.9 (selbst gebacken) + selbst gebautes initramfs
  • openrc-0.11.8
  • oberfläche: Xfce4.1
  • Dualboot mit Win7
  • Meine Zeitzone "Europe/Zurich" was GMT+1 entspricht


Im Zuge mehrer verschiedener How To's habe ich mehr Mals kontrolliert ob /etc/localtime und /etc/timezone richtig gesetzt sind. Darin liegt es nicht. Mein /etc/conf.d/hwclock sieht so aus:
Code:
SF-Gentoo simon # cat /etc/conf.d/hwclock
# Set CLOCK to "UTC" if your Hardware Clock is set to UTC (also known as
# Greenwich Mean Time).  If that clock is set to the local time, then
# set CLOCK to "local".  Note that if you dual boot with Windows, then
# you should set it to "local".

clock="local"

# If you want the hwclock script to set the system time (software clock)
# to match the current hardware clock during bootup, leave this
# commented out.
# However, you can set this to "NO" ifyou are running a modern kernel
# with CONFIG_RTC_HCTOSYS set to y and your hardware clock set to UTC.

clock_hctosys="NO"

# If you do not want to set the hardware clock to the current system
# time (software clock) during shutdown, set this to no.
#clock_systohc="YES"

# If you wish to pass any other arguments to hwclock during bootup,
# you may do so here. Alpha users may wish to use --arc or --srm here.

clock_args=""

clock muss auf "local" gsetzt sein da ich mit Win7 doalboote. Für mich heisst das, mein System darf die aus der CMOS-Uhr ausgelesene Zeit nicht verändern. Da clock_hctosys auf "NO" gsetzt ist müsste also das hwclock-Script welches sich in meinem boot-Runlevel befindet eigentlich gar nichts an der Systemzeit rum schrauben. Hab es deshalb einfach zum Testen mal aus dem boot-Runlevel entfernt. Leider immer noch eine Stunde zu viel auf der Uhr.

In meinem Kernel ist CONFIG_RTC_HCTOSYS gesetzt und mein Kernel liest auch die Zeit richtig aus der CMOS-Uhr wie folgender Befehl zeigt
Code:
SF-Gentoo simon # grep -i clock /var/log/kern.log
Dec 26 16:28:33 SF-Gentoo kernel: [    0.000000] hpet clockevent registered
Dec 26 16:28:33 SF-Gentoo kernel: [    0.379808] Switching to clocksource hpet
Dec 26 16:28:34 SF-Gentoo kernel: [    1.676022] Refined TSC clocksource calibration: 3411.127 MHz.
Dec 26 16:28:34 SF-Gentoo kernel: [    1.678978] Switching to clocksource tsc
Dec 26 16:28:34 SF-Gentoo kernel: [    1.954851] rtc_cmos 00:04: setting system clock to 2012-12-26 15:28:10 UTC (1356535690)


Ja der Kernel nimmt an dies sei UTC aber das dürfte für den Kernel kein Problem sein, da ja mein Setup bestimmt wie dieser Wert jetzt interpretiert werden soll oder? Und mein Setup sagt ja ganz klar und deutlich das die Zeit aus der CMOS-Uhr die lokale Zeit ist. Auf irgend eine Art scheint mein System durch und durch der Überzeugung zu sein, dass es auf den Wert in der CMOS-Uhr unbedingt eine Stunde addieren muss. Folgendes kleines Spielchen mit hwclock zeigt das ganz schön (wirkliche zeit ca. 18.43 und auch die welche in der CMOS-Uhr steht)
Code:
SF-Gentoo simon # hwclock -r
Mit 26 Dez 2012 19:42:30 CET  -0.937964 Sekunden
SF-Gentoo simon # hwclock -r --localtime
Mit 26 Dez 2012 18:43:54 CET  -0.672365 Sekunden
SF-Gentoo simon # hwclock -r --utc
Mit 26 Dez 2012 19:44:02 CET  -0.094217 Sekunden
SF-Gentoo simon # date
Mit Dez 26 19:47:29 CET 2012


Wenn ich meine CMOS-Uhr auf UTC setze dann funktioniert Übrigens alles ganz normal. Aber daran hat leider mein Windwos keine Freude :roll:

Kann mir irgendjemand helfen dieses Problem zu lösen? Ich bin echt an ende mit meinem Latein. :( Vielen Dank schon mal.

Edit1 27.12.12: Gelöst. Fix in meinem letzten Post.


Last edited by Gilgwath on Thu Dec 27, 2012 12:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 980

PostPosted: Wed Dec 26, 2012 9:25 pm    Post subject: Reply with quote

neuerdings kann auch windows utc. irgendein registry key. musst du mal guugln
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 563

PostPosted: Thu Dec 27, 2012 12:39 am    Post subject: Reply with quote

Hi

Gentoo hatte mal Probleme mit der Datei "/etc/adjtime" so das die Zeit nicht stimmte (auf jeden falls bei mir).
Kannst die ja mal umbenennen und dann nochmal probieren/booten (die wird automatisch neu angelegt) bei
mir hat es geholfen.

MfG
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1449
Location: St. Wendel

PostPosted: Thu Dec 27, 2012 8:12 am    Post subject: Reply with quote

Die /etc/adjtime hat damit ausnahmsweise mal nichts zu tun IMHO.

Welche Datei hasst den nach /etc/localtime kopiert/verlinkt?

Bye
Py
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Thu Dec 27, 2012 8:35 am    Post subject: Reply with quote

Hi

Stell clock_hctosys und clock_systohc auf YES. clock auf UTC. Dann mittels NTP einmal die Zeit richtig setzen.

Jetzt bootest du Windows und sagst in der Registry das es UTC benutzt. (Google, ist ganz leicht).

Jetzt nochmal Linux booten und die Zeit mittels NTP setzen wenn Sie nicht stimmt.

Ab jetzt sollte es überall passen. Ich mach das hier auch überall so.

Sebastian
Back to top
View user's profile Send private message
Gilgwath
n00b
n00b


Joined: 09 Dec 2010
Posts: 12

PostPosted: Thu Dec 27, 2012 12:29 pm    Post subject: Reply with quote

py-ro wrote:
Die /etc/adjtime hat damit ausnahmsweise mal nichts zu tun IMHO.

Welche Datei hasst den nach /etc/localtime kopiert/verlinkt?

Bye
Py


Ich habe /usr/shar/zoneinfo/Europe/Zürich nach /etc/localtime kopiert. Das File /etc/adjtime habe ich mal umbenamselt, seit her wurde es nicht wieder erstellt.

Der Fix mit UTC unter Windows scheint mir aber eine gute Sache zu sein. UTC ist eine gute Sache und dann soll auch Windows das schlucken :lol: Kurzes googeln hat folgendes zu Tage gefördert:

Windows-Registry bearbeiten: http://crashmag.net/configuring-windows-7-support-for-utc-bios-time

Weiterführende Infos zum Thema Windows und UTC http://www.cl.cam.ac.uk/~mgk25/mswish/ut-rtc.html
Bezieht sich eigentlich auf IBM-Notebooks aber der Kern der Sache ist trotzdem interessant. Laut diesem Artikel ist die Sache allerdings mit Vorsicht zu geniessen. Unter anderem hat MS folgende Warnung auf ihrer Supportseite veröffentlicht http://support.microsoft.com/kb/2687252/en-us Da ich Windows nur zum spielen einsetze dürfte mich das aber kaum betreffen.

Windows und Gentoo zeigen jetzt, da die CMOS-Uhr auf UTC steht, die richtige Zeit an. Danke an alle für den einfachen und nützlichen Workaround.

solved & and close pls =)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum