Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kinput2 canna
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Duke42
n00b
n00b


Joined: 11 Aug 2002
Posts: 33

PostPosted: Fri Aug 23, 2002 1:44 pm    Post subject: kinput2 canna Reply with quote

I can't this combinations to work.
I emerged canna, then kinput2, set everything up...
First, I get a warning I cannot read when starting kinput2. By pressing C-SPACE I get the nice hiragana "a", I can input hiragana but after pressing space I get a window displaying an error instead of the conversions. Also "cannastat" doesn't show any clients connected - it should be at least kinput2, I think.

Can anyone help?

Duke42.
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Fri Aug 23, 2002 6:53 pm    Post subject: Reply with quote

I haven't tried kinput2 yet on Gentoo. Do you have emacs installed? If so, you can try to see if canna will work in there, and that may help distinguish between a kinput problem and a canna problem.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
Duke42
n00b
n00b


Joined: 11 Aug 2002
Posts: 33

PostPosted: Sat Aug 24, 2002 4:09 pm    Post subject: canna works, what now? Reply with quote

canna works in XEmacs. So, what do I do now?
cannastat just gives me my XEmacs as client, what can I do to get kinput2 communicating with canna?
Back to top
View user's profile Send private message
mihochan
Apprentice
Apprentice


Joined: 16 Apr 2002
Posts: 296
Location: Melbourne again

PostPosted: Sun Aug 25, 2002 12:26 am    Post subject: Reply with quote

If you seach the forums someone has
produced an ebuild for these that worked
for me.
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Sun Aug 25, 2002 1:38 am    Post subject: Reply with quote

I have a page that might be of use on this. It goes through the steps for kinput2 and canna.

Basically, between Ryan Shaw and Stuart Bouyer, Gentoo is becoming one of the easiest distros to use for Japanese.
The Gentoo stuff is towards the end of the page.

Let me know if it helps

Scott
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Sun Aug 25, 2002 1:42 am    Post subject: Reply with quote

Oops, I was so eager to advertise my page, I missed the simple answer---which is mentioned on my page, btw. :)

You didn't start the canna server

Code:

/etc/init.d/canna start


To have it run at bootup
Code:

rc-update add canna default


Sorry, should have mentioned that, I missed it--I'll blame it on my wife asking me something as I was typing. :)

Scott
Back to top
View user's profile Send private message
Duke42
n00b
n00b


Joined: 11 Aug 2002
Posts: 33

PostPosted: Mon Aug 26, 2002 3:52 pm    Post subject: Reply with quote

I did start the cannaserver, "cannastat" gives:

Connected to unix
Canna Server (Ver. 3.5)
No clients

but kinput2 can't connect to canna. hmm, can anyone tell me if they have a user "canna" in their passwd? Because /etc/conf.d/canna says:

# Specify user to run as
CANNASERVER_OPTS="-u canna"

but I don't have such a user and cannaserver runs as "bin". Perhaps this is the problem?[/b]
Back to top
View user's profile Send private message
Duke42
n00b
n00b


Joined: 11 Aug 2002
Posts: 33

PostPosted: Mon Aug 26, 2002 4:50 pm    Post subject: solved! Reply with quote

I've got it... I should have known better, but... OK, the problem was my .Xresources. There I have:
Kinput2*useOverrideShellForMode: true
Kinput2*IMProtocol.locales: C, de_DE, ja, ja_JP, ja_JP.utf8, japanese, POSIX
Kinput2*sendbackKeyPress: true
Kinput2*conversionEngine: canna

I find it very nice to have kinput2 available without switching locales, anyways:
Kinput2*cannahost: localhost
caused the trouble. I don't know why it did, but I'm deleting it now ;-).

Thanks everyone.

P.S.: in case someone wonders: I copied the file from my RH distro. It worked there.
Back to top
View user's profile Send private message
slugman
n00b
n00b


Joined: 05 Oct 2002
Posts: 24
Location: Michigan

PostPosted: Fri Oct 11, 2002 11:21 pm    Post subject: cannot get Kinput2 -canna on KDE 3.0.3 working Reply with quote

I cant seem to get the kinput2 program to respond despite following the guide set up
http://home.nyc.rr.com/computertaijutsu/jpninpt.html

I set the "canna" USE flag in the /etc/make.cofg then
"emerge kinput2"
this also merged in cannaserver
I then started the server by

Code:
/etc/init.d/canna start

no problems the server starts, next

Code:
kinput2 -canna &
cannastat


It displays
------------------------
Code:
Connected to unix
Canna Server (Ver. 3.5)
Total connecting clients 1
USER_NAME   ID  NO U_CX          C_TIME   U_TIME I_TIME HOST_NAME  CLIENT
mark         0   0    2  Fri 11  7:04pm        0      4 localhost. kinput2

-------------------------

However no hiragana 'a' window is poping up on my KDE desktop and I also can't get any Kanji input by using "shift-Space"

I've tried in Mozilla, Kmail, knosole, mlterm(using the script from the webpage above)

I had Kanji input working before on Mandrake 9.0 so i copied over the old .i18n
-----------
Code:
#start of ~/.i18n
#LC_CTYPE=en_US
#LANGUAGE=en_US:en
LC_MONETARY=en_US
LC_COLLATE=en_US
LC_NUMERIC=en_US
LC_TIME=en_US
LANG=en_US
LC_MESSAGES=en_US
LC_CTYPE=ja
 LANGUAGE=C
 LANG=ja_JP
 XIM=kinput2
 XIM_PROGRAM=kinput2
 XMODIFIERS="@im=kinput2"

---------------

I am not really sure what else to try
Back to top
View user's profile Send private message
plate
Bodhisattva
Bodhisattva


Joined: 25 Jul 2002
Posts: 1663
Location: Berlin

PostPosted: Fri Oct 11, 2002 11:54 pm    Post subject: Reply with quote

Looks to me as if your .i18n is not being read at all. I don't know how to fix that (if that's what is happening), but just to make sure everything else is working, have you tried using the wrapper script Scottro has on his page? Try firing up an individual application (like KMail or Mozilla) with
Code:
XMODIFIERS="@IM=kinput2" LANGUAGE=en_US LC_CTYPE=ja_JP

prepended and see what happens. I was sloppier than you (I don't even have an ~/.i18n) and it still works for me...
Back to top
View user's profile Send private message
scottro
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 141
Location: New York City

PostPosted: Sat Oct 12, 2002 1:02 am    Post subject: Reply with quote

The other thing I'm thinking (aside from using a page written by a moron) :) is that something in KDE is over-riding something.

Just for kicks, why don't you try doing something like firing up fluxbox or even twm, and running mlterm with that langx script.

I have no logical reason for blaming KDE, just that it seems as if you're doing everything correctly, therefore, I have to start guessing.

I should add, I suppose, that as is hopefully made clear on that page, I'm not the expert--I'm simply the gatherer of information given me by others.


Scott
Back to top
View user's profile Send private message
slugman
n00b
n00b


Joined: 05 Oct 2002
Posts: 24
Location: Michigan

PostPosted: Sat Oct 12, 2002 1:07 am    Post subject: Reply with quote

I tried his script with mozilla, kmail, mlterm, still dosen't work...
Back to top
View user's profile Send private message
robataka
n00b
n00b


Joined: 19 Oct 2002
Posts: 6

PostPosted: Sun Oct 20, 2002 12:18 am    Post subject: Kinput2 & Canna - my story Reply with quote

Hi,

Don't know if you still need the help, but I had similar problems
and thought that I would let you know what I did. At the same time,
since I work almost soley in Japanese, my setup has kinput activiated
all the time in X/KDE, so you may not be interested.

First of all, the first time through I emerged canna/kinput2, canna wouldn't start with an error that it couldn't be started as root or some
such error message. Commenting out CANNAOPTS='-u canna' brought
up canna with no problems. But then I couldn't get kinput2 to connect
to canna. I tried all sorts of different things, but still no go.

Then I took a look at the Japan KDE Users Group FAQ and followed that.
First I created an ~/.xinitrc that reads as follows;

export LC_ALL=ja_JP
export LANG=ja_JP.eucJP
export XMODIFIERS='@im=kinput2'
kinput2 -canna -cannaserver localhost &
startkde

I then emerge -C kinput2, emerge -C canna and deleted the /etc/canna directory. I then emerged kinput 2, I changed CANNAOPTS in conf.d/canna to read CANNAOPTS='inet' .

As far as I remember, that process got it to work for me - I don't think I left anything out.
Back to top
View user's profile Send private message
slugman
n00b
n00b


Joined: 05 Oct 2002
Posts: 24
Location: Michigan

PostPosted: Sun Oct 20, 2002 7:00 am    Post subject: Reply with quote

I managed to solve my problem. I guess what was happening is i had xdm set to automatically start upon reboot, i disabled this, changed my .xinitrc to the following. kinput2 worked upon issuing the
Code:
startx


anyone know why my .xinitrc file were not automatically loaded when i log in through xdm? i had my computer set to start X upon boot?

Code:

#~/.xinitrc
export LC_ALL=ja_JP
export LANG=ja_JP.eucJP
export XMODIFIERS='@im=kinput2'
kinput2 -canna &
startkde
Back to top
View user's profile Send private message
slugman
n00b
n00b


Joined: 05 Oct 2002
Posts: 24
Location: Michigan

PostPosted: Fri Mar 21, 2003 7:57 pm    Post subject: fixed dictionary problems Reply with quote

I just want to show what I had to get to change to fix a problem I was having with Kinput2 + canna

After emerging kinput2 using canna, I had the problem that I could type in hiragana and katakana, but for somereason i couldn't use any kanji, not even the simple ones.

I had to edit my ~/.canna file to the following

arround Line 56
Code:

#~/.canna

;Line 56
(use-dictionary
; "gcanna"
; "chimei"
; "iroha"
; "fuzokugo"
; "hojomwd"
; "hojoswd"
; "software"
; "keishiki"
; "zipcode"
; "zip99"
; "basho"
; "keisan"
; "pub"
; "scien"
; "sup"
; "bonobo"
; "kanasmpl"
 :bushu "bushu"
 :user  "user"
 "geo"
 "bushu"
 "chimei"
 "fuzokugo"
 "hojomwd"
 "hojoswd"
 "iroha"
 "katakana"
 "keishiki"
 "necgaiji"
 "number"
 "software"
 "suffix"
 )


I hope if anyone else was having this problem this will help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum