Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NO! NO! NO! I DON'T want it started
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1340

PostPosted: Sat Dec 22, 2012 4:39 am    Post subject: NO! NO! NO! I DON'T want it started Reply with quote

After a number of recent updates (notably including openrc and dhcpcd, something is attempting to start dhcpcd at boot (which I most emphatically do NOT want).

The rc-status -u command shows dhcpcd as not assigned to any runlevel

I have had ("forever") in my /etc/rc.conf (to prevent network devices from being started automatically):

Code:

rc_hotplug='!net.eth0 !net.wlan0'


It seems even worse than I imagined. Something is starting every possbile interface (I don't want to see ANY of these, except for lo):

Code:

# /bin/ifconfig
dummy0: flags=195<UP,BROADCAST,RUNNING,NOARP>  mtu 1500
        inet6 fe80::9c14:b3ff:fefb:e5a3  prefixlen 64  scopeid 0x20<link>
        ether 9e:14:b3:fb:e5:a3  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 7  bytes 1678 (1.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:16:36:bd:93:34  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  memory 0xda000000-da020000 

ip6tnl0: flags=193<UP,RUNNING,NOARP>  mtu 1452
        inet6 fe80::9c14:b3ff:fefb:e5a3  prefixlen 64  scopeid 0x20<link>
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 0  (UNSPEC)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 7  dropped 7 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 16436
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 60  bytes 4468 (4.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 60  bytes 4468 (4.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=193<UP,RUNNING,NOARP>  mtu 1480
        inet6 ::127.0.0.1  prefixlen 96  scopeid 0x90<compat,host>
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 4  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:18:de:a3:99:93  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


What do I do so that dhcpcd does NOT get run at boot, and none of the network interfaces (other than lo) gets started?

If (as I now suspect after some thought) that some other service is triggering this, is there some way of configuring the startup so that 1) only specific interfaces are tried, or (even better) 2) the other service fails (quickly) if a specific device is not up, rather than attempting to bring up all of them, or 3) there is someway to say "you are not to start this service no matter what" (I like that best of all)?
Back to top
View user's profile Send private message
chuber
n00b
n00b


Joined: 12 Sep 2010
Posts: 7

PostPosted: Sat Dec 22, 2012 9:00 am    Post subject: Reply with quote

hi,


i would try to put something like config_eth0=( "null" ) in /etc/conf.d/net.

maybe also erase the link /etc/init.d/net.eth0 from net.lo
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Sat Dec 22, 2012 9:01 am    Post subject: Reply with quote

Code:
/etc/rc.conf


^^^ wrong place.

right place:

Code:
/etc/conf.d/network


also why do you need sit0, dummy0 and ip6tnl0?

oO

and I don't see how dhcp is run, all your interfaces have empty addresses.
Back to top
View user's profile Send private message
Crazy_Jerry
n00b
n00b


Joined: 08 May 2012
Posts: 44

PostPosted: Sat Dec 22, 2012 2:08 pm    Post subject: Reply with quote

________________________0 wrote:
Code:
/etc/rc.conf


^^^ wrong place.

right place:

Code:
/etc/conf.d/network


also why do you need sit0, dummy0 and ip6tnl0?

oO

and I don't see how dhcp is run, all your interfaces have empty addresses.



But I guess
Code:
/etc/conf.d/
had no network file .

should be touch one ?
_________________
God be with us !
Back to top
View user's profile Send private message
Crazy_Jerry
n00b
n00b


Joined: 08 May 2012
Posts: 44

PostPosted: Sat Dec 22, 2012 2:20 pm    Post subject: Reply with quote

I have same problem , and I have no answer . But I guess the problem is update bug in some program , is this possible?
_________________
God be with us !
Back to top
View user's profile Send private message
_______0
Guru
Guru


Joined: 15 Oct 2012
Posts: 521

PostPosted: Sat Dec 22, 2012 4:29 pm    Post subject: Reply with quote

Code:
bzless /usr/share/doc/openrc-0.11.8/net.example.bz2


correction, place is:

Code:

/etc/conf.d/net


Gentoo handbook networking chapter:

Quote:
D. Gentoo Network Configuration
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2207
Location: UK

PostPosted: Sat Dec 22, 2012 4:40 pm    Post subject: Reply with quote

Code:
echo "allowinterfaces none" >> /etc/dhcpcd.conf
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8596

PostPosted: Sat Dec 22, 2012 5:45 pm    Post subject: Reply with quote

Are you trying to avoid starting the interface at boot, but use DHCP once the interface is started later, possibly by you? Or are you trying to avoid ever running DHCP on the interface, regardless of when or why the interface is brought up? All prior answers appear to assume the latter, but your remark to prevent network devices from being started automatically seems to mean you just want to control when the interfaces are brought up, but you might still want DHCP on the interface once you bring it up.

What is your current setting for the rc strict network check? Perhaps your configuration is now attempting to start all interfaces in order to satisfy a need net statement.
Back to top
View user's profile Send private message
robvr
n00b
n00b


Joined: 10 Mar 2004
Posts: 44
Location: Best, The Netherlands

PostPosted: Sun Dec 30, 2012 6:43 pm    Post subject: Re: NO! NO! NO! I DON'T want it started Reply with quote

curmudgeon wrote:
After a number of recent updates (notably including openrc and dhcpcd, something is attempting to start dhcpcd at boot (which I most emphatically do NOT want).

I've been battling a very similar situation today. For what it's worth, this is what I found:

A whole bunch of things started by openrc require the 'net' service (this is not illogical).
At present, the /etc/init.d/net.lo service does not provide 'net' (I don't understand this).

As a result of this, whenever anything that needs 'net' is started, openrc will go looking for something that provides it, typically net.eth0, and starts it. One way of preventing this is to modify the /etc/init.d/net.lo script to provide 'net'. This script is the same for all network interfaces, but provides 'net' only if the interface name is different from lo.

Code:

        case "${IFACE}" in
                lo|lo0) ;;
                *)
                        after net.lo net.lo0 dbus
                        provide net
                        ;;
        esac

Replace this with
Code:

        provide net
        case "${IFACE}" in
                lo|lo0) ;;
                *)
                        after net.lo net.lo0 dbus
                        ;;
        esac

and things will improve.

However, I don't think that solves your entire problem; as soon as you bring up any interface except lo, you'll probably still get all of them.

This is caused by the /etc/init.d/dhcpcd script. The command line passed to the actual /sbin/dhcpcd is almost empty, in particular, it does not specify an interface. When invoked without an interface, it default to starting all interfaces. You may want to work some magic on the script to suit your purposes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum