Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[WIFI] broadcom 43225 : lenteur/instabilité flux (en cours)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
davidvs
n00b
n00b


Joined: 10 Sep 2011
Posts: 8

PostPosted: Tue Dec 18, 2012 8:54 am    Post subject: [WIFI] broadcom 43225 : lenteur/instabilité flux (en cours) Reply with quote

Salut à tous,

J'arrive depuis peu dans le monde gentoo par la porte Calculate Linux.
J'avoue être conquis.
Cependant, :roll: , je suis en butte avec un pb que je n'arrive pas à résoudre (2 semaines que je tourne le pb dans tous les sense) : ma connexion wifi est très instable : soit le flux internet s'arrête, soit celui-ci est très lent. Je parle de flux car le wifi ne tombe pas : la connexion est toujours active mais plus rien.
Si je transferts des gros fichier vers mon NAS, j'ai un flux phénoménal (genre 22mo/s) puis le transfert se bloqu

Ce que j'ai tenté de faire :
- remplacer networkmanager par wicd => rien
- pb ipv6 ? je décommente
Code:
alias net-pf-10 off
et ajoute au-dessous
Code:
alias IPv6 off
dans /etc/modprob./aliases.conf => rien ;
dans /etc/conf.d/net, je mets la ligne
Code:
enable_ipv6...
sur "false" => rien
je crée un script /etc/modprob.d/disable-ipv6 avec
Code:
 options ipv6 disable=1
=> rien
- j'ai vérifié le firmware : b43 : ça semble tout

Je précise que j'ai en dual une magéia avec networkmanager et aucun souci : flux, connexion NAS...

J'avoue ne plus avoir d'idée ; je me tourne vers vous, "vous êtes mon dernier espoir (...)" (Princesse Leia :D )
_________________
DAVIDVS


Last edited by davidvs on Tue Dec 18, 2012 1:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2872
Location: Paris

PostPosted: Tue Dec 18, 2012 12:09 pm    Post subject: Reply with quote

Sur la distro qui fonctionne nickel, récupère les versions des drivers/noyau et firmware, et vérifie s'il y a des options passées au chargement du driver/module. Muni de ces infos, faire la comparaison avec ce qui est dispo sous gentoo.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
guilc
Moderator
Moderator


Joined: 15 Nov 2003
Posts: 3321
Location: Paris - France

PostPosted: Tue Dec 18, 2012 12:28 pm    Post subject: Reply with quote

J'ai eu ça chez moi il fut un temps (2010, 2011), avec des kernel un peu plus anciens. Cela venait du driver utilisé par wpa_cupplicant (option "-D").
À l'époque, c'était les débuts de la couche unifiée "nl80211" (http://wireless.kernel.org/en/developers/Documentation/nl80211), et dans wpa_supplicant, ça coincait un peu comme ça : au début ça marche, puis d'un coup, paf ça bloque.
Pour contourner le problème, il fallait utiliser le driver "wext".

Peut-être une piste à vérifier ?

Sinon, oui, la piste suggérer par El_Goretto est aussi à suivre. Un problème de version de firmware (b43-firmware), ou driver différent (sensé être dans le kernel depuis le 2.6.37 d'après ce que je lis là : http://linuxwireless.org/en/users/Drivers/b43) ?

PS: peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plaît ? Merci :)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
davidvs
n00b
n00b


Joined: 10 Sep 2011
Posts: 8

PostPosted: Tue Dec 18, 2012 1:52 pm    Post subject: Reply with quote

ok ; merci ; je regarde ça et vous tiens au courant

Cordialement
_________________
DAVIDVS
Back to top
View user's profile Send private message
Usermind42
n00b
n00b


Joined: 05 Dec 2012
Posts: 19

PostPosted: Tue Dec 18, 2012 5:01 pm    Post subject: Reply with quote

Against who?! I like ur name dude! =]

Change de matos, pour du free par exemple...

Peace.
_________________
Make ur own free penguin baby with Gentoo(DEBLOB!) =]
cflags accuracy =]
accept_keywords='x86'
accept_license='-* @FREE'
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2872
Location: Paris

PostPosted: Tue Dec 18, 2012 7:09 pm    Post subject: Reply with quote

Usermind42 wrote:
Change de matos, pour du free par exemple...

MMMmmm.
A l'avenir, essaie d'éviter ce genre d'intervention qui n'apporte rien, et sont à ranger à côté de celles du genre "beh utilise pas ce soft mais plutôt celui que j'utilise moi". Ça ne fait pas avancer la personne qui demande de l'aide, ni la connaissance des gens sur ce forum.

Ici, on a la chance d'avoir des gens qui savent plein de choses (j'ai un petit autel "guilc" caché au fond de mon placard à balais, sur lequel je viens me recueillir tous les vendredi 13 de pleine lune quand le vent vient du Nord) et partagent. Et c'est tout bête, mais c'est en cherchant à comprendre pourquoi "ça ne marche pas" qu'on en sait un peu plus tous les jours.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
davidvs
n00b
n00b


Joined: 10 Sep 2011
Posts: 8

PostPosted: Tue Dec 18, 2012 9:43 pm    Post subject: Reply with quote

... d'autant que mon pseudo est d'inspiration latine !!! le "U" n'existe pas en latin, il n'y a que des "V" ! Ah !!! culture, culture... :wink:

Bon, comme je disais plus haut, je vous tiens au courant pour vos conseils

cordialement
_________________
DAVIDVS
Back to top
View user's profile Send private message
Usermind42
n00b
n00b


Joined: 05 Dec 2012
Posts: 19

PostPosted: Tue Dec 18, 2012 11:57 pm    Post subject: Reply with quote

@El goreto : C'était juste un conseil de libération , contre les mauvais blob!

@DavidUs : Good luck

Et pardon pour le dérangement! =]
_________________
Make ur own free penguin baby with Gentoo(DEBLOB!) =]
cflags accuracy =]
accept_keywords='x86'
accept_license='-* @FREE'
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5421
Location: ~Brussels - Belgique

PostPosted: Wed Dec 19, 2012 7:50 am    Post subject: Reply with quote

Hey Usermind42,

Ici, c'est pas forum.gnu.org, certains vouent un culte à Saint Ignucius, mais d'autres "font avec" le matériel qu'ils ont ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3137

PostPosted: Wed Dec 19, 2012 8:29 am    Post subject: Reply with quote

'alute

je n'ai pas vu de #lspci -v (ou -n) ni les logs du dmesg pour confirmer mais je rajoute un complément si jamais tu es passé à côté dans tes recherches : Il semble que ce chipset est supporté par 3 drivers (b43 et legacy ; broadcom-sta (5.100.82.1XX) et brcmsmac (pcie/axi).
Et si je suis la news sur phoronix je pencherais vers brcmsmac... à tester peut-être :wink:

Edit: Et le wiki b43 ne donne que wl en support... magnifique pour s'y retrouver :roll:
M'enfin, un autre thread semble encore conforter brcmsmac. Faudrait essayer sinon voir ce que charge Mint sinon
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
davidvs
n00b
n00b


Joined: 10 Sep 2011
Posts: 8

PostPosted: Fri Dec 21, 2012 3:49 pm    Post subject: Reply with quote

Bon ; après tous ces conseils, je tire un premier bilan : il ne s'agit visiblement pas d'un pb de firmware, ni de noyau (2 noyaux recompilés)
Je me tourne vers un pb NFS car ma connexion sature aussitôt que je transferts des fichiers vers mon NAS et fait tomber mon wifi à chaque fois.
Je vais donc chercher du côté des options nfs à intégrer dans fstab.

Merci à vous

cordialement
_________________
DAVIDVS
Back to top
View user's profile Send private message
Usermind42
n00b
n00b


Joined: 05 Dec 2012
Posts: 19

PostPosted: Sun Jan 06, 2013 5:56 am    Post subject: Reply with quote

XavierMiller wrote:
Hey Usermind42,

Ici, c'est pas forum.gnu.org, certains vouent un culte à Saint Ignucius, mais d'autres "font avec" le matériel qu'ils ont ;)


Bonne année a tous =]

Pour le culte de saint Ignucius, il faut sensibiliser les gens!

Sans le mouvement GNU pas de Gentoo, de Linux(OS)[composé d'un userland GNU(outils du shell) et d'un noyau(gestion matériel) sous license de la fondation GNU pour faire valoir ces droits].

Faut pas oublier! (et encore moins le cacher pour rentabiliser le travail colossal que ses gens ont fournis gratuitement! sans abonnement ou autre "hameçon" des temps modernes!).

J'espère ne pas être allé trop loin...

Pour le matos, fallait prendre de l'Atheros, il y a ath5k et ath9k comme driver libre... il en existe d'autre surement.
_________________
Make ur own free penguin baby with Gentoo(DEBLOB!) =]
cflags accuracy =]
accept_keywords='x86'
accept_license='-* @FREE'
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5421
Location: ~Brussels - Belgique

PostPosted: Sun Jan 06, 2013 11:34 am    Post subject: Reply with quote

Oui oui, c'est bien gentil, mais ici, on essaie d'aider les gens avec le matériel qu'ils ont, et pas avec des "tu aurais du prendre du matériel compatible avec les barbus" ;)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum