Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problem with installing Ruby
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
djissi
n00b
n00b


Joined: 30 Jun 2012
Posts: 4

PostPosted: Mon Dec 17, 2012 6:42 pm    Post subject: [SOLVED] Problem with installing Ruby Reply with quote

Hi,

I am having trouble installing Ruby. Looking at Google, it seems that I am the only one with this problem.

Is there any way of treating this error as a warning?

I am getting a bit desperate now, any help would be most welcome.

This is what I am trying to do:
emerge --update --deep --newuse --pretend dev-lang/ruby:

redmine ~ # emerge --update --deep --newuse --pretend dev-lang/ruby

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-ruby/racc-1.4.6-r1  USE="{-test}" RUBY_TARGETS="ruby19 -jruby -ree18 -ruby18"
[ebuild  N     ] dev-ruby/json-1.6.7  USE="-doc {-test}" RUBY_TARGETS="ruby19 -jruby -ree18 -ruby18"
[ebuild  N     ] dev-ruby/rdoc-3.12  USE="-doc {-test}" RUBY_TARGETS="ruby19 -jruby -ree18 -ruby18"


And here is the result:

emerge --update --deep --newuse dev-lang/ruby:

redmine ~ # emerge --update --deep --newuse dev-lang/ruby
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 3) dev-ruby/racc-1.4.6-r1
 * racc-1.4.6.gem SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                        [ ok ]
>>> Unpacking source...
 * Running unpack phase for all ...
 * Unpacking .gem file... ...                                                                                                                                                 [ ok ]
 * Uncompressing metadata ...                                                                                                                                                 [ ok ]
 * Unpacking data.tar.gz ...                                                                                                                                                  [ ok ]
>>> Source unpacked in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work
>>> Preparing source in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work ...
 * Running prepare phase for all ...
 * Applying racc-1.4.6-test-unit.patch ...                                                                                                                                    [ ok ]
 * Running source copy phase for ruby19 ...
 * Running prepare phase for ruby19 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work ...
 * Running compile phase for ruby19 ...
rake aborted!
ERROR: 'rake/gempackagetask' is obsolete and no longer supported. Use 'rubygems/package_task' instead.
/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6/Rakefile:3:in `<top (required)>'
(See full trace by running task with --trace)
 * ERROR: dev-ruby/racc-1.4.6-r1 failed (compile phase):
 *   build failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 4438:  Called ruby-ng_src_compile
 *   environment, line 4102:  Called _ruby_each_implementation 'each_ruby_compile'
 *   environment, line  441:  Called _ruby_invoke_environment 'ruby19' 'each_ruby_compile'
 *   environment, line  493:  Called each_ruby_compile
 *   environment, line  785:  Called die
 * The specific snippet of code:
 *               ${RUBY} -S rake build || die "build failed";
 *
 * If you need support, post the output of `emerge --info '=dev-ruby/racc-1.4.6-r1'`,
 * the complete build log and the output of `emerge -pqv '=dev-ruby/racc-1.4.6-r1'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6'
 * S: '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6'

>>> Failed to emerge dev-ruby/racc-1.4.6-r1, Log file:

>>>  '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/build.log'

 * Messages for package dev-ruby/racc-1.4.6-r1:

 * ERROR: dev-ruby/racc-1.4.6-r1 failed (compile phase):
 *   build failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 4438:  Called ruby-ng_src_compile
 *   environment, line 4102:  Called _ruby_each_implementation 'each_ruby_compile'
 *   environment, line  441:  Called _ruby_invoke_environment 'ruby19' 'each_ruby_compile'
 *   environment, line  493:  Called each_ruby_compile
 *   environment, line  785:  Called die
 * The specific snippet of code:
 *               ${RUBY} -S rake build || die "build failed";
 *
 * If you need support, post the output of `emerge --info '=dev-ruby/racc-1.4.6-r1'`,
 * the complete build log and the output of `emerge -pqv '=dev-ruby/racc-1.4.6-r1'`.
 * The complete build log is located at '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6'
 * S: '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6'


I've tried everything I can think of, I did an emerge --depclean of all the ruby stuff before, to no avail.

Here is my configuration:

/etc/make.conf:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
MAKEOPTS="-j2"

USE="
apache
apache2
innodb
mmx
mysql
passenger
ruby
rubygems
sse
sse2"

RUBY_TARGETS="ruby19"


/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/build.log:

redmine ~ # cat /var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/build.log
 * Package:    dev-ruby/racc-1.4.6-r1
 * Repository: gentoo
 * Maintainer: ruby@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib ruby_targets_ruby19 userland_GNU
 * FEATURES:   sandbox
>>> Unpacking source...
 * Running unpack phase for all ...
 * Unpacking .gem file... ...                                                                                                                                                 [ ok ]
 * Uncompressing metadata ...                                                                                                                                                 [ ok ]
 * Unpacking data.tar.gz ...                                                                                                                                                  [ ok ]
>>> Source unpacked in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work
>>> Preparing source in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work ...
 * Running prepare phase for all ...
 * Applying racc-1.4.6-test-unit.patch ...                                                                                                                                    [ ok ]
 * Running source copy phase for ruby19 ...
 * Running prepare phase for ruby19 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-ruby/racc-1.4.6-r1/work ...
 * Running compile phase for ruby19 ...
rake aborted!
ERROR: 'rake/gempackagetask' is obsolete and no longer supported. Use 'rubygems/package_task' instead.
/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6/Rakefile:3:in `<top (required)>'
(See full trace by running task with --trace)
 * ERROR: dev-ruby/racc-1.4.6-r1 failed (compile phase):
 *   build failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_compile
 *   environment, line 4438:  Called ruby-ng_src_compile
 *   environment, line 4102:  Called _ruby_each_implementation 'each_ruby_compile'
 *   environment, line  441:  Called _ruby_invoke_environment 'ruby19' 'each_ruby_compile'
 *   environment, line  493:  Called each_ruby_compile
 *   environment, line  785:  Called die
 * The specific snippet of code:
 *               ${RUBY} -S rake build || die "build failed";
 *
 * If you need support, post the output of `emerge --info '=dev-ruby/racc-1.4.6-r1'`,
 * the complete build log and the output of `emerge -pqv '=dev-ruby/racc-1.4.6-r1'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info
 * The complete build log is located at '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6'
 * S: '/var/tmp/portage/dev-ruby/racc-1.4.6-r1/work/ruby19/racc-1.4.6'


emerge --info '=dev-ruby/racc-1.4.6-r1':

redmine ~ # emerge --info '=dev-ruby/racc-1.4.6-r1'
Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.15-r3, 3.0.6-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.0.6-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_X3450_@_2.67GHz-with-gentoo-2.0.3
Timestamp of tree: Mon, 17 Dec 2012 12:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="acl amd64 apache apache2 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv innodb ipv6 mmx modules mudflap multilib mysql ncurses nls nptl openmp pam passenger pcre pppd readline ruby rubygems session sse sse2 ssl tcpd unicode zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by djissi on Tue Dec 18, 2012 10:11 am; edited 1 time in total
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1135
Location: Motown

PostPosted: Mon Dec 17, 2012 11:06 pm    Post subject: Reply with quote

I recently needed Ruby for rubyripper and when I realized it was trying to build for and install multiple Ruby versions I added
Code:
RUBY_TARGETS="ruby19"
to /etc/make.conf to narrow it down.

Chris
_________________
What I need is an exact list of specific unknown problems we might encounter.
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Mon Dec 17, 2012 11:11 pm    Post subject: Reply with quote

Not a Ruby user myself, but it looks like your Ruby 1.9 has a version conflict with that dev-ruby/racc version.

There are newer versions of dev-ruby/racc in Portage (1.4.8 and 1.4.9), though they are "unstable", whereas your system runs "stable". You might try to keyword one of these newer versions and try to emerge that.

Don't be afraid of "unstable", it's usally safe … lots of Gentoo users even run their entire system on ~arch. If the keyworded package doesn't work, simply remove the keyword entry and unmerge or downgrade the package.

If emerging a newer version works, it would be nice of you to post a bug report for the 1.4.6-r1 version in combination with the ruby19 target.
_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
djissi
n00b
n00b


Joined: 30 Jun 2012
Posts: 4

PostPosted: Tue Dec 18, 2012 10:15 am    Post subject: [SOLVED] Problem with installing Ruby Reply with quote

Thanks lxg,

I've unmasked dev-ruby/racc-1.4.8 and this was installed successfully. Bug #447690 has been filed regarding this conflict.

darkphader,

I had already added the entry in make.conf. I am actually trying to install Passenger, which doesn't seem to support more than one version of Ruby anyway. So I had to add the entry to select on ly one (I think by default ruby18 and ruby19 are selected).

Thanks for your help,

JC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum